[hbbtv/youtubetv] Fixed hanup bug and segmentation fault on 3rd-party images.
[vuplus_openembedded] / recipes / adns / adns_1.0.bb
1 DESCRIPTION = "An advanced alternative, asynchronous resolver."
2 SECTION = "console/network"
3 LICENSE="GPL"
4
5 SRC_URI = "ftp://ftp.gnu.org/gnu/adns/adns-${PV}.tar.gz \
6            file://configure.patch;patch=1 \
7            file://fixparsedomainflags.patch;patch=1"
8
9 inherit autotools
10
11 acpaths = ""
12 do_configure_prepend () {
13         if ! test -e acinclude.m4; then
14                 cp aclocal.m4 acinclude.m4
15         fi
16 }
17
18 do_stage () {
19         install -m 0644 ${S}/src/adns.h ${STAGING_INCDIR}/
20         oe_libinstall -so -C dynamic libadns ${STAGING_LIBDIR}/
21         oe_libinstall -a -C src libadns ${STAGING_LIBDIR}/
22 }
23
24 do_install () {
25         install -d ${D}${prefix} ${D}${exec_prefix} \
26                    ${D}${bindir} ${D}${libdir} ${D}${includedir}
27         oe_runmake 'prefix=${D}${prefix}' 'exec_prefix=${D}${exec_prefix}' \
28                    'bin_dir=${D}${bindir}' 'lib_dir=${D}${libdir}' \
29                    'include_dir=${D}${includedir}' install
30 }