[squeak] Attempt to add squeak 3.10-1
[vuplus_openembedded] / packages / squeak / squeakvm_3.10.1.bb
1 DESCRIPTION = "Squeak VM"
2 LICENSE = "Squeak License"
3 HOMEPAGE = "http://www.squeakvm.org"
4 DEPENDS = "virtual/libx11"
5
6 EXTRA_OECONF += " --with-x --without-npsqueak"
7
8
9 SRC_URI = "http://www.squeakvm.org/unix/release/Squeak-3.10-1.src.tar.gz \
10            file://configure-fixes.patch;patch=1"
11 S = "${WORKDIR}/Squeak-3.10-1/platforms/unix/config"
12
13 inherit autotools
14
15 do_configure_prepend() {
16     mkdir ${WORKDIR}/Squeak-3.10-1/platforms/unix/bld
17     cd ${WORKDIR}/Squeak-3.10-1/platforms/unix/bld
18 }
19
20 do_compile_append() {
21     cd ${WORKDIR}/Squeak-3.10-1/platforms/unix/bld
22     find . -name 'Makefile' -exec sed -i s/@X_INCLUDES@//g {} \;
23     find . -name 'Makefile' -exec sed -i s/@X_LIBS@//g {} \;
24 }
25
26 do_install_prepend() {
27     cd ${WORKDIR}/Squeak-3.10-1/platforms/unix/bld
28 }