linux 2.6.25: bump PR for defconfig changes
[vuplus_openembedded] / packages / linux / linux_2.6.25.bb
1 require linux.inc
2
3 PR = "r5"
4
5 # Mark archs/machines that this kernel supports
6 DEFAULT_PREFERENCE = "-1"
7 DEFAULT_PREFERENCE_mpc8313e-rdb = "1"
8 DEFAULT_PREFERENCE_kilauea = "1"
9 DEFAULT_PREFERENCE_sequoia = "1"
10 DEFAULT_PREFERENCE_cm-x270 = "1"
11 DEFAULT_PREFERENCE_alix = "1"
12 DEFAULT_PREFERENCE_at32stk1000 = "1"
13 DEFAULT_PREFERENCE_at91-l9260 = "1"
14
15 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.25.tar.bz2 \
16            file://defconfig"
17
18 SRC_URI_append_mpc8313e-rdb = "\
19         file://mpc831x-nand.patch;patch=1 \
20         file://mpc8313e-rdb-leds.patch;patch=1 \
21         file://mpc8313e-rdb-cardbus.patch;patch=1 \
22         "
23
24 SRC_URI_append_cm-x270 = " \
25         file://0001-cm-x270-match-type.patch;patch=1 \
26         file://0002-ramdisk_load.patch;patch=1 \
27         file://0003-mmcsd_large_cards-r0.patch;patch=1 \
28         file://0004-cm-x270-nand-simplify-name.patch;patch=1 \
29         file://0005-add-display-set-default-16bpp.patch;patch=1 \
30         "
31
32 SRC_URI_append_at32stk1000 = " \
33         http://avr32linux.org/twiki/pub/Main/LinuxPatches/linux-2.6.25.6.atmel.1.patch.bz2;patch=1 \
34         file://virtualmouse.patch;patch=1 \
35 "
36
37 SRC_URI_append_at91-l9260 = " \
38         http://maxim.org.za/AT91RM9200/2.6/2.6.25-at91.patch.gz;patch=1 \
39 "
40
41 CMDLINE_cm-x270 = "console=${CMX270_CONSOLE_SERIAL_PORT},38400 monitor=1 mem=64M mtdparts=physmap-flash.0:256k(boot)ro,0x180000(kernel),-(root);cm-x270-nand:64m(app),-(data) rdinit=/sbin/init root=mtd3 rootfstype=jffs2"
42
43 FILES_kernel-image_cm-x270 = ""
44
45 python do_compulab_image() {
46         import os
47         import os.path
48         import struct
49
50         machine = bb.data.getVar('MACHINE', d, 1)
51         if machine == "cm-x270":
52             deploy_dir = bb.data.getVar('DEPLOY_DIR_IMAGE', d, 1)
53             kernel_file = os.path.join(deploy_dir, bb.data.expand('${KERNEL_IMAGE_BASE_NAME}', d) + '.bin')
54             img_file = os.path.join(deploy_dir, bb.data.expand('${KERNEL_IMAGE_BASE_NAME}', d) + '.cmx270')
55
56             fo = open(img_file, 'wb')
57
58             image_data = open(kernel_file, 'rb').read()
59
60             # first write size into first 4 bytes
61             size_s = struct.pack('i', len(image_data))
62
63             # truncate size if we are running on a 64-bit host
64             size_s = size_s[:4]
65
66             fo.write(size_s)
67             fo.write(image_data)
68             fo.close()
69
70             os.chdir(deploy_dir)
71             link_file = bb.data.expand('${KERNEL_IMAGE_SYMLINK_NAME}', d) + '.cmx270'
72             img_file = bb.data.expand('${KERNEL_IMAGE_BASE_NAME}', d) + '.cmx270'
73             try:
74                 os.unlink(link_file)
75             except:
76                 pass
77             os.symlink(img_file, link_file)
78 }
79
80
81 addtask compulab_image after do_deploy before do_package
82