merge from opendreambox branch
[vuplus_openembedded] / packages / dreambox / dreambox-secondstage.bb
1 DESCRIPTION = "Dreambox DM702x second stage bootloader"
2 SECTION = "base"
3 PRIORITY = "required"
4 MAINTAINER = "Felix Domke <tmbinc@elitedvb.net>"
5 PV_dm7020 = "35"
6 PV_dm7025 = "61"
7 PV_dm600pvr = "53"
8 PV_dm500plus = "53"
9 PV_dm8000 = "65"
10 PV_dm800 = "62"
11 PR = "r0"
12
13 SRC_URI = "http://sources.dreamboxupdate.com/download/7020/secondstage-${MACHINE}-${PV}.bin"
14
15 S = "${WORKDIR}"
16
17 do_stage() {
18         install -d ${STAGING_LIBDIR}/dreambox-secondstage
19         gzip -c ${S}/secondstage-${MACHINE}-${PV}.bin > ${STAGING_LIBDIR}/dreambox-secondstage/main.bin.gz
20 }
21
22 # the dm{800,8000} secondstage is already compressed (and encrypted)
23 do_stage_dm800() {
24         install -d ${STAGING_LIBDIR}/dreambox-secondstage
25         cp ${S}/secondstage-${MACHINE}-${PV}.bin ${STAGING_LIBDIR}/dreambox-secondstage/main.bin.gz
26 }
27
28 do_stage_dm8000() {
29         install -d ${STAGING_LIBDIR}/dreambox-secondstage
30         cp ${S}/secondstage-${MACHINE}-${PV}.bin ${STAGING_LIBDIR}/dreambox-secondstage/main.bin.gz
31 }