merge from opendreambox branch
[vuplus_openembedded] / packages / dreambox / dreambox-boottool.bb
1 DESCRIPTION = "Squashfs jffs2 unionfs mount tool"
2 SECTION = "base"
3 PRIORITY = "required"
4 LICENSE = "proprietary"
5 MAINTAINER = "Felix Domke <tmbinc@elitedvb.net>"
6
7 PV = "1.0"
8 PR = "r1"
9 DEPENDS = "klibc"
10
11 SRC_URI = "file://boottool-${MACHINE}.c"
12
13 S = "${WORKDIR}/"
14
15 do_install_append() {
16         install -d ${D}/boot/bin
17         install ${S}/boottool ${D}/boot/bin/init
18 }
19
20 do_compile_append() {
21         ${STAGING_BINDIR}/${TARGET_ARCH}-linux-klcc ${S}/boottool-${MACHINE}.c -o ${S}/boottool
22 }
23
24 PACKAGE_ARCH := "${MACHINE_ARCH}"
25 FILES_${PN} = "/boot/bin/init"