fic-gta0? : renamed fic-gta0? to om-gta0? to reflect true name of device
[vuplus_openembedded] / packages / bluez / bluez-utils_3.13.bb
1 require bluez-utils.inc
2
3 DEPENDS += "glib-2.0"
4
5 SRC_URI = "http://bluez.sourceforge.net/download/bluez-utils-${PV}.tar.gz \
6            file://hcid.conf \
7           "
8 PR = "r0"
9
10 EXTRA_OECONF = " \
11                  --enable-bccmd \
12                  --enable-hid2hci \
13                  --enable-alsa \ 
14                  --enable-cups \
15                  --enable-glib \
16                  --disable-sdpd \
17                  --enable-network \
18                  --enable-serial \
19                  --enable-input \
20                  --enable-audio \
21                  --enable-echo \
22                  --enable-configfile \
23                  --enable-initscripts \
24                  --enable-test \
25                 " 
26
27 # The config options are explained below:
28
29 #  --enable-obex           enable OBEX support
30 #  --enable-alsa           enable ALSA support, not needed for nokia770, nokia800 and om-gtao1
31 #  --enable-cups           install CUPS backend support
32 #  --enable-bccmd          install BCCMD interface utility
33 #  --enable-avctrl         install Audio/Video control utility
34 #  --enable-hid2hci        install HID mode switching utility
35 #  --enable-dfutool        install DFU firmware upgrade utility
36
37 #  --enable-glib           For systems that use and install GLib anyway
38 #  --disable-sdpd          The sdpd is obsolete and should no longer be used. This of course requires that hcid will be started with -s to enable the SDP server
39
40 #Following services can be enabled so far:
41 #       --enable-network
42 #       --enable-serial
43 #       --enable-input
44 #       --enable-audio
45 #       --enable-echo
46
47 #There is no need to modify any init script. They will be started
48 #automatically or on demand. Only /etc/bluetooth/*.service files should
49 #be patched to change name or the autostart value.
50 #       --enable-configfile
51 #       --enable-initscripts
52
53 #For even smaller -doc packages
54 #       --disable-manpages
55 #       --disable-pcmciarules
56
57 #I haven't seen any embedded device with HID proxy support. So simply
58 #disable it:
59 #       --disable-hid2hci
60
61
62 PACKAGES =+ "${PN}-compat ${PN}-alsa"
63
64 CONFFILES_${PN} = " \
65                    ${sysconfdir}/bluetooth/hcid.conf \
66                    ${sysconfdir}/default/bluetooth \
67                   "
68
69 CONFFILES_${PN}-compat = " \
70                           ${sysconfdir}/bluetooth/rfcomm.conf \
71                          " 
72
73 FILES_${PN} = " \
74                ${base_sbindir}/hcid \
75                ${libdir}/bluetooth \
76                ${sysconfdir}/init.d/bluetooth \
77                ${sysconfdir}/bluetooth/*.service \
78                ${sysconfdir}/bluetooth/hcid.conf \
79                ${sysconfdir}/default \
80                ${sysconfdir}/dbus-1 \
81                ${base_sbindir}/hciattach \
82               "
83
84 FILES_${PN}-dbg += " \
85                    ${libdir}/bluetooth/.debug \
86                    ${libdir}/cups/backend/.debug \
87                    ${libdir}/alsa-lib/.debug \
88                   " 
89
90 FILES_${PN}-compat = " \
91                     ${base_bindir}/sdptool \
92                     ${base_bindir}/dund \
93                     ${base_bindir}/rctest \
94                     ${base_bindir}/ciptool \
95                     ${base_bindir}/l2test \
96                     ${base_bindir}/rfcomm \
97                     ${base_bindir}/hcitool \
98                     ${base_bindir}/pand \
99                     ${base_bindir}/hidd \
100                     ${base_bindir}/l2ping \
101                     ${base_sbindir}/hciconfig \
102                     ${base_sbindir}/bccmd \
103                     ${base_sbindir}/hciemu \
104                     ${base_sbindir}/hid2hci \
105                     ${base_bindir}/passkey-agent \
106                     ${sysconfdir}/bluetooth/rfcomm.conf \
107                    " 
108
109 FILES_${PN}-alsa = "${libdir}/alsa-lib/libasound*"
110
111 FILES_bluez-cups-backend = "${libdir}/cups/backend/bluetooth"
112 RDEPENDS_bluez-cups-backend = "cups"
113
114