Merge branch 'org.openembedded.dev' of git://git.openembedded.net/openembedded into...
[vuplus_openembedded] / packages / autofs / autofs_4.1.4.bb
1 DESCRIPTION = "Kernel based automounter for linux."
2 SECTION = "base"
3 LICENSE = "GPL"
4
5 PR = "r2"
6
7 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/daemons/autofs/v4/autofs-${PV}.tar.bz2 \
8            ${KERNELORG_MIRROR}/pub/linux/daemons/autofs/v4/autofs-4.1.4-misc-fixes.patch;patch=1 \
9            ${KERNELORG_MIRROR}/pub/linux/daemons/autofs/v4/autofs-4.1.4-multi-parse-fix.patch;patch=1 \
10            ${KERNELORG_MIRROR}/pub/linux/daemons/autofs/v4/autofs-4.1.4-non-replicated-ping.patch;patch=1 \
11            file://cross.patch;patch=1 \
12            file://Makefile.rules-cross.patch;patch=1 \
13            file://install.patch;patch=1 \
14            file://auto.net-sort-option-fix.patch;patch=1 \
15            file://autofs-additional-distros.patch;patch=1 \
16            file://no-bash.patch;patch=1 \
17            file://autofs-add-hotplug.patch;patch=1"
18
19 inherit autotools update-rc.d
20
21 INITSCRIPT_NAME = "autofs"
22 INITSCRIPT_PARAMS = "defaults"
23
24 EXTRA_OEMAKE="TARGET_PREFIX=${TARGET_PREFIX}"
25 PARALLEL_MAKE = ""
26
27 do_configure_prepend () {
28         if [ ! -e acinclude.m4 ]; then
29                 cp aclocal.m4 acinclude.m4
30         fi
31 }
32
33 do_install () {
34         oe_runmake 'INSTALLROOT=${D}' install
35 }