Update drivers
[vuplus_openembedded] / classes / task.bbclass
1 # Task packages are only used to pull in other packages
2 # via their dependencies. They are empty.
3 ALLOW_EMPTY = "1"
4
5 # By default, only the task package itself is in PACKAGES.
6 # -dbg and -dev flavours are handled by the anonfunc below.
7 # This means that task recipes used to build multiple task
8 # packages have to modify PACKAGES after inheriting task.bbclass.
9 PACKAGES = "${PN}"
10
11 # By default, task packages do not depend on a certain architecture.
12 # Only if dependencies are modified by MACHINE_FEATURES, packages
13 # need to be set to MACHINE_ARCH after inheriting task.bbclass
14 PACKAGE_ARCH = "all"
15
16 # This automatically adds -dbg and -dev flavours of all PACKAGES
17 # to the list. Their dependencies (RRECOMMENDS) are handled as usual
18 # by package_depchains in a following step.
19 python () {
20     packages = bb.data.getVar('PACKAGES', d, 1).split()
21     genpackages = []
22     for pkg in packages:
23         for postfix in ['-dbg', '-dev']:
24             genpackages.append(pkg+postfix)
25     bb.data.setVar('PACKAGES', ' '.join(packages+genpackages), d)
26 }
27