merge of 21d66a92293faf76a506c7d17e3cd16e143bb401
[vuplus_openembedded] / classes / opie.bbclass
1 #
2 # This oeclass takes care about some of the itchy details of installing parts
3 # of Opie applications. Depending on quicklaunch or not, plugin or not, the
4 # TARGET is either a shared object, a shared object with a link to quicklauncher,
5 # or a usual binary.
6
7 # You have to provide two things: 1.) A proper SECTION field, and 2.) a proper APPNAME
8 # Then opie.oeclass will:
9 #    * create the directory for the binary and install the binary file(s)
10 #    * for applications: create the directory for the .desktop and install the .desktop file
11 #    * for quicklauncher applications: create the startup symlink to the quicklauncher
12 # You can override the automatic detection of APPTYPE, valid values are 'quicklaunch', 'binary', 'plugin'
13 # You can override the default location of APPDESKTOP (<workdir>/apps/<section>/)
14 #
15
16 inherit palmtop
17
18 DEPENDS_prepend = "${@["libopie2 ", ""][(bb.data.getVar('PN', d, 1) == 'libopie2')]}"
19
20 # to be consistent, put all targets into workdir
21 EXTRA_QMAKEVARS_POST_append = " DESTDIR=${S}"
22
23 # Opie standard TAG value
24 TAG = "${@'v' + bb.data.getVar('PV',d,1).replace('.', '_')}"
25
26 # plan for later:
27 # add common scopes for opie applications, see qmake-native/common.pro
28 # qmake should care about all the details then. qmake can do that, i know it :)
29 #
30
31 python opie_do_opie_install() {
32         import os, shutil
33         section = bb.data.getVar( "SECTION", d ).split( '/' )[1] or "Applications"
34         section = section.title()
35         if section in ( "Base", "Libs" ):
36                 bb.note( "Section = Base or Libs. Target won't be installed automatically." )
37                 return
38
39         #               SECTION         : BINDIR                        DESKTOPDIR
40         dirmap = {      "Applets"       : ( "/plugins/applets",         None                    ),
41                         "Applications"  : ( "<BINDIR>",                 "/apps/Applications"    ),
42                         "Multimedia"    : ( "<BINDIR>",                 "/apps/Applications"    ),
43                         "Games"         : ( "<BINDIR>",                 "/apps/Games"           ),
44                         "Settings"      : ( "<BINDIR>",                 "/apps/Settings"        ),
45                         "Pim"           : ( "<BINDIR>",                 "/apps/1Pim"            ),
46                         "Examples"      : ( "<BINDIR>",                 "/apps/Examples"        ),
47                         "Shell"         : ( "/bin",                     "/apps/Opie-SH"         ),
48                         "Codecs"        : ( "/plugins/codecs",          None                    ),
49                         "Decorations"   : ( "/plugins/decorations",     None                    ),
50                         "Inputmethods"  : ( "/plugins/inputmethods",    None                    ),
51                         "Fontfactories" : ( "/plugins/fontfactories",   None                    ),
52                         "Security"      : ( "/plugins/security",        None                    ),
53                         "Styles"        : ( "/plugins/styles",          None                    ),
54                         "Today"         : ( "/plugins/today",           None                    ),
55                         "Datebook"      : ( "/plugins/holidays",        None                    ),
56                 "Networksettings"       : ( "/plugins/networksettings", None                    ) }
57
58         if section not in dirmap:
59                 raise ValueError, "Unknown section '%s'. Valid sections are: %s" % ( section, dirmap.keys() )
60         
61         bindir, desktopdir = dirmap[section]
62         APPNAME = bb.data.getVar( "APPNAME", d, True ) or bb.data.getVar( "PN", d, True )
63         APPTYPE = bb.data.getVar( "APPTYPE", d, True )
64         if not APPTYPE:
65                 if bindir == "<BINDIR>":
66                         APPTYPE = "quicklaunch"
67                 else:
68                         APPTYPE = "plugin"
69
70         appmap = { "binary":"/bin", "quicklaunch":"/plugins/application" }
71         if bindir == "<BINDIR>": bindir = appmap[APPTYPE]
72         
73         bb.note( "Section='%s', bindir='%s', desktopdir='%s', name='%s', type='%s'" %
74                ( section, bindir, desktopdir, APPNAME, APPTYPE ) )
75
76         S = bb.data.getVar( "S", d, 1 )
77         D = "%s/image" % bb.data.getVar( "WORKDIR", d, True )
78         WORKDIR = bb.data.getVar( "WORKDIR", d, True )
79         palmtopdir = bb.data.getVar( "palmtopdir", d )
80         APPDESKTOP = bb.data.getVar( "APPDESKTOP", d, True ) or "%s/%s" % ( WORKDIR, desktopdir )
81
82         if desktopdir is not None:
83                 os.system( "install -d %s%s%s/" % ( D, palmtopdir, desktopdir ) )
84                 os.system( "install -m 0644 %s/%s.desktop %s%s%s/" % ( APPDESKTOP, APPNAME, D, palmtopdir, desktopdir ) )
85
86         os.system( "install -d %s%s%s/" % ( D, palmtopdir, bindir ) )
87
88         if APPTYPE == "binary":
89                 os.system( "install -m 0755 %s/%s %s%s%s/" % ( S, APPNAME, D, palmtopdir, bindir ) )
90         elif APPTYPE == "quicklaunch":
91                 os.system( "install -m 0755 %s/lib%s.so %s%s%s/" % ( S, APPNAME, D, palmtopdir, bindir ) )
92                 os.system( "install -d %s%s/bin/" % ( D, palmtopdir ) )
93                 os.system( "ln -sf %s/bin/quicklauncher %s%s/bin/%s" % ( palmtopdir, D, palmtopdir, APPNAME ) )
94         elif APPTYPE == "plugin":
95                 os.system( "install -m 0755 %s/lib%s.so %s%s%s/" % ( S, APPNAME, D, palmtopdir, bindir ) )
96 }
97
98 EXPORT_FUNCTIONS do_opie_install
99 addtask opie_install after do_compile before do_populate_staging