Update drivers
[vuplus_openembedded] / classes / glibc-package.bbclass
1 #
2 # This class knows how to package up glibc. Its shared since prebuild binary toolchains
3 # may need packaging and its pointless to duplicate this code.
4 #
5 # Caller should set GLIBC_INTERNAL_USE_BINARY_LOCALE to one of:
6 #  "compile" - Use QEMU to generate the binary locale files
7 #  "precompiled" - The binary locale files are pregenerated and already present
8 #  "ondevice" - The device will build the locale files upon first boot through the postinst
9
10 GLIBC_INTERNAL_USE_BINARY_LOCALE ?= "ondevice"
11
12 PACKAGES = "glibc-dbg glibc catchsegv sln nscd ldd localedef glibc-utils glibc-dev glibc-static glibc-doc glibc-locale libcidn libmemusage libsegfault glibc-extra-nss glibc-thread-db glibc-pcprofile"
13 PACKAGES_DYNAMIC = "glibc-gconv-* glibc-charmap-* glibc-localedata-* locale-base-* glibc-binary-localedata-*"
14
15 INSANE_SKIP_glibc-dbg = True
16
17 libc_baselibs = "${base_libdir}/libcrypt*.so.* ${base_libdir}/libcrypt-*.so ${base_libdir}/libc*.so.* ${base_libdir}/libc-*.so ${base_libdir}/libm*.so.* ${base_libdir}/libm-*.so ${base_libdir}/ld*.so.* ${base_libdir}/ld-*.so ${base_libdir}/libpthread*.so.* ${base_libdir}/libpthread-*.so ${base_libdir}/libresolv*.so.* ${base_libdir}/libresolv-*.so ${base_libdir}/librt*.so.* ${base_libdir}/librt-*.so ${base_libdir}/libutil*.so.* ${base_libdir}/libutil-*.so ${base_libdir}/libnsl*.so.* ${base_libdir}/libnsl-*.so ${base_libdir}/libnss_files*.so.* ${base_libdir}/libnss_files-*.so ${base_libdir}/libnss_compat*.so.* ${base_libdir}/libnss_compat-*.so ${base_libdir}/libnss_dns*.so.* ${base_libdir}/libnss_dns-*.so ${base_libdir}/libdl*.so.* ${base_libdir}/libdl-*.so ${base_libdir}/libanl*.so.* ${base_libdir}/libanl-*.so ${base_libdir}/libBrokenLocale*.so.* ${base_libdir}/libBrokenLocale-*.so"
18
19 # The problem is that if PN = "glibc", FILES_${PN} will overwrite FILES_glibc
20 # Solution: Make them both the same thing, then it doesn't matter
21
22 glibcfiles = "${libc_baselibs} ${libexecdir}/* ${datadir}/zoneinfo ${@base_conditional('USE_LDCONFIG', '1', '${base_sbindir}/ldconfig', '', d)}"
23 glibcdbgfiles = "${bindir}/.debug ${sbindir}/.debug ${libdir}/.debug \
24                   ${base_bindir}/.debug ${base_sbindir}/.debug ${base_libdir}/.debug \
25                   ${libdir}/gconv/.debug ${libexecdir}/*/.debug"
26 glibcdevfiles = "${bindir}/rpcgen ${includedir} ${libdir}/lib*${SOLIBSDEV} ${libdir}/*.la \
27                 ${libdir}/*.a ${libdir}/*.o ${libdir}/pkgconfig ${libdir}/*nonshared.a \
28                 ${base_libdir}/*.a ${base_libdir}/*.o ${datadir}/aclocal"
29
30 FILES_glibc = "${glibcfiles}"
31 FILES_${PN} = "${glibcfiles}"
32 FILES_ldd = "${bindir}/ldd"
33 FILES_libsegfault = "${base_libdir}/libSegFault*"
34 FILES_libcidn = "${base_libdir}/libcidn*.so"
35 FILES_libmemusage = "${base_libdir}/libmemusage.so"
36 FILES_glibc-extra-nss = "${base_libdir}/libnss*"
37 FILES_sln = "${base_sbindir}/sln"
38 FILES_glibc-dev = "${glibcdevfiles}"
39 FILES_${PN}-dev = "${glibcdevfiles}"
40 FILES_glibc-dbg = "${glibcdbgfiles}"
41 FILES_${PN}-dbg = "${glibcdbgfiles}"
42 FILES_nscd = "${sbindir}/nscd* ${sysconfdir}/nscd* ${sysconfdir}/init.d/nscd*"
43 FILES_glibc-utils = "${bindir}/* ${sbindir}/*"
44 FILES_glibc-gconv = "${libdir}/gconv/*"
45 FILES_catchsegv = "${bindir}/catchsegv"
46 RDEPENDS_catchsegv = "libsegfault"
47 FILES_glibc-pcprofile = "${base_libdir}/libpcprofile.so"
48 FILES_glibc-thread-db = "${base_libdir}/libthread_db*"
49 FILES_localedef = "${bindir}/localedef"
50 RPROVIDES_glibc-dev += "libc-dev"
51
52 DESCRIPTION_sln = "glibc: create symbolic links between files"
53 DESCRIPTION_nscd = "glibc: name service cache daemon for passwd, group, and hosts"
54 DESCRIPTION_glibc-extra-nss = "glibc: nis, nisplus and hesiod search services"
55 DESCRIPTION_ldd = "glibc: print shared library dependencies"
56 DESCRIPTION_localedef = "glibc: compile locale definition files"
57 DESCRIPTION_glibc-utils = "glibc: misc utilities like iconf, local, gencat, tzselect, rpcinfo, ..."
58
59 TMP_LOCALE="/tmp/locale${libdir}/locale"
60
61 locale_base_postinst() {
62 #!/bin/sh
63
64 if [ "x$D" != "x" ]; then
65   exit 1
66 fi
67
68 rm -rf ${TMP_LOCALE}
69 mkdir -p ${TMP_LOCALE}
70 if [ -f ${libdir}/locale/locale-archive ]; then
71         cp ${libdir}/locale/locale-archive ${TMP_LOCALE}/
72 fi
73 localedef --inputfile=${datadir}/i18n/locales/%s --charmap=%s --prefix=/tmp/locale %s
74 mkdir -p ${libdir}/locale/
75 mv ${TMP_LOCALE}/locale-archive ${libdir}/locale/
76 rm -rf ${TMP_LOCALE}
77 }
78
79 locale_base_postrm() {
80 #!/bin/sh
81
82 rm -rf ${TMP_LOCALE}
83 mkdir -p ${TMP_LOCALE}
84 if [ -f ${libdir}/locale/locale-archive ]; then
85         cp ${libdir}/locale/locale-archive ${TMP_LOCALE}/
86 fi
87 localedef --delete-from-archive --inputfile=${datadir}/locales/%s --charmap=%s --prefix=/tmp/locale %s
88 mv ${TMP_LOCALE}/locale-archive ${libdir}/locale/
89 rm -rf ${TMP_LOCALE}
90 }
91
92 do_prep_locale_tree() {
93         treedir=${WORKDIR}/locale-tree
94         rm -rf $treedir
95         mkdir -p $treedir/bin $treedir/lib $treedir/${datadir} $treedir/${libdir}/locale
96         cp -pPR ${PKGD}${datadir}/i18n $treedir/${datadir}/i18n
97         # unzip to avoid parsing errors
98         for i in $treedir/${datadir}/i18n/charmaps/*gz; do 
99                 gunzip $i
100         done
101         ls -d ${PKGD}${base_libdir}/* | xargs -iBLAH cp -pPR BLAH $treedir/lib
102         if [ -f ${CROSS_DIR}/${TARGET_SYS}/lib/libgcc_s.so ]; then
103                 cp -pPR ${CROSS_DIR}/${TARGET_SYS}/lib/libgcc_s.so $treedir/lib
104         fi
105         if [ -f ${CROSS_DIR}/${TARGET_SYS}/lib/libgcc_s.so.* ]; then
106                 cp -pPR ${CROSS_DIR}/${TARGET_SYS}/lib/libgcc_s.so.* $treedir/lib
107         fi
108         install -m 0755 ${PKGD}${bindir}/localedef $treedir/bin
109 }
110
111 do_collect_bins_from_locale_tree() {
112         treedir=${WORKDIR}/locale-tree
113
114         mkdir -p ${PKGD}${libdir}
115         cp -pPR $treedir/${libdir}/locale ${PKGD}${libdir}
116 }
117
118 python package_do_split_gconvs () {
119         import os, re
120         if (bb.data.getVar('PACKAGE_NO_GCONV', d, 1) == '1'):
121                 bb.note("package requested not splitting gconvs")
122                 return
123
124         if not bb.data.getVar('PACKAGES', d, 1):
125                 return
126
127         libdir = bb.data.getVar('libdir', d, 1)
128         if not libdir:
129                 bb.error("libdir not defined")
130                 return
131         datadir = bb.data.getVar('datadir', d, 1)
132         if not datadir:
133                 bb.error("datadir not defined")
134                 return
135
136         gconv_libdir = base_path_join(libdir, "gconv")
137         charmap_dir = base_path_join(datadir, "i18n", "charmaps")
138         locales_dir = base_path_join(datadir, "i18n", "locales")
139         binary_locales_dir = base_path_join(libdir, "locale")
140
141         do_split_packages(d, gconv_libdir, file_regex='^(.*)\.so$', output_pattern='glibc-gconv-%s', description='gconv module for character set %s', extra_depends='glibc-gconv')
142
143         do_split_packages(d, charmap_dir, file_regex='^(.*)\.gz$', output_pattern='glibc-charmap-%s', description='character map for %s encoding', extra_depends='')
144
145         def calc_locale_deps(fn, pkg, file_regex, output_pattern, group):
146                 deps = []
147                 f = open(fn, "r")
148                 c_re = re.compile('^copy "(.*)"')
149                 i_re = re.compile('^include "(\w+)".*')
150                 for l in f.readlines():
151                         m = c_re.match(l) or i_re.match(l)
152                         if m:
153                                 dp = legitimize_package_name('glibc-localedata-%s' % m.group(1))
154                                 if not dp in deps:
155                                         deps.append(dp)
156                 f.close()
157                 if deps != []:
158                         bb.data.setVar('RDEPENDS_%s' % pkg, " ".join(deps), d)
159
160         do_split_packages(d, locales_dir, file_regex='(.*)', output_pattern='glibc-localedata-%s', description='locale definition for %s', hook=calc_locale_deps, extra_depends='')
161         bb.data.setVar('PACKAGES', bb.data.getVar('PACKAGES', d) + ' glibc-gconv', d)
162
163         use_bin = bb.data.getVar("GLIBC_INTERNAL_USE_BINARY_LOCALE", d, 1)
164
165         dot_re = re.compile("(.*)\.(.*)")
166
167         if use_bin != "precompiled":
168                 supported = bb.data.getVar('GLIBC_GENERATE_LOCALES', d, 1)
169                 if not supported or supported == "all":
170                     f = open(base_path_join(bb.data.getVar('WORKDIR', d, 1), "SUPPORTED"), "r")
171                     supported = f.readlines()
172                     f.close()
173                 else:
174                     supported = supported.split()
175                     supported = map(lambda s:s.replace(".", " ") + "\n", supported)
176         else:
177                 supported = []
178                 full_bin_path = bb.data.getVar('PKGD', d, True) + binary_locales_dir
179                 for dir in os.listdir(full_bin_path):
180                         dbase = dir.split(".")
181                         d2 = "  "
182                         if len(dbase) > 1:
183                                 d2 = "." + dbase[1].upper() + "  "
184                         supported.append(dbase[0] + d2)
185
186         # Collate the locales by base and encoding
187         utf8_only = int(bb.data.getVar('LOCALE_UTF8_ONLY', d, 1) or 0)
188         encodings = {}
189         for l in supported:
190                 l = l[:-1]
191                 (locale, charset) = l.split(" ")
192                 if utf8_only and charset != 'UTF-8':
193                         continue
194                 m = dot_re.match(locale)
195                 if m:
196                         locale = m.group(1)
197                 if not encodings.has_key(locale):
198                         encodings[locale] = []
199                 encodings[locale].append(charset)
200
201         def output_locale_source(name, pkgname, locale, encoding):
202                 bb.data.setVar('RDEPENDS_%s' % pkgname, 'localedef glibc-localedata-%s glibc-charmap-%s' % (legitimize_package_name(locale), legitimize_package_name(encoding)), d)
203                 bb.data.setVar('pkg_postinst_%s' % pkgname, bb.data.getVar('locale_base_postinst', d, 1) % (locale, encoding, locale), d)
204                 bb.data.setVar('pkg_postrm_%s' % pkgname, bb.data.getVar('locale_base_postrm', d, 1) % (locale, encoding, locale), d)
205
206         def output_locale_binary_rdepends(name, pkgname, locale, encoding):
207                 m = re.match("(.*)\.(.*)", name)
208                 if m:
209                         glibc_name = "%s.%s" % (m.group(1), m.group(2).lower().replace("-",""))
210                 else:
211                         glibc_name = name
212                 bb.data.setVar('RDEPENDS_%s' % pkgname, legitimize_package_name('glibc-binary-localedata-%s' % glibc_name), d)
213
214         def output_locale_binary(name, pkgname, locale, encoding):
215                 target_arch = bb.data.getVar("TARGET_ARCH", d, 1)
216                 if target_arch in ("i486", "i586", "i686"):
217                         target_arch = "i386"
218                 elif target_arch == "powerpc":
219                         target_arch = "ppc"
220
221                 # This is a hack till linux-libc-headers gets patched for the missing arm syscalls and all arm device kernels as well
222                 if bb.data.getVar("DISTRO_NAME", d, 1) == "Angstrom":
223                         kernel_ver = "2.6.24"
224                 elif bb.data.getVar("DISTRO_NAME", d, 1) == "KaeilOS":
225                         kernel_ver = "2.6.24"
226                 else:
227                         kernel_ver = bb.data.getVar("OLDEST_KERNEL", d, 1)
228
229                 if kernel_ver is None:
230                         qemu = "qemu-%s  -s 1048576" % target_arch
231                 else:
232                         qemu = "qemu-%s  -s 1048576 -r %s" % (target_arch, kernel_ver)
233                 pkgname = 'locale-base-' + legitimize_package_name(name)
234
235                 treedir = base_path_join(bb.data.getVar("WORKDIR", d, 1), "locale-tree")
236                 ldlibdir = "%s/lib" % treedir
237                 path = bb.data.getVar("PATH", d, 1)
238                 i18npath = base_path_join(treedir, datadir, "i18n")
239
240                 localedef_opts = "--force --old-style --no-archive --prefix=%s --inputfile=%s/i18n/locales/%s --charmap=%s %s" % (treedir, datadir, locale, encoding, name)
241
242                 qemu_options = bb.data.getVar("QEMU_OPTIONS_%s" % bb.data.getVar('PACKAGE_ARCH', d, 1), d, 1)
243                 if not qemu_options:
244                         qemu_options = bb.data.getVar('QEMU_OPTIONS', d, 1)
245                 
246                 cmd = "PATH=\"%s\" I18NPATH=\"%s\" %s -L %s -E LD_LIBRARY_PATH=%s %s %s/bin/localedef %s" % (path, i18npath, qemu, treedir, ldlibdir, qemu_options, treedir, localedef_opts)
247                 bb.note("generating locale %s (%s)" % (locale, encoding))
248                 if os.system(cmd):
249                         raise bb.build.FuncFailed("localedef returned an error (command was %s)." % cmd)
250
251         def output_locale(name, locale, encoding):
252                 pkgname = 'locale-base-' + legitimize_package_name(name)
253                 bb.data.setVar('ALLOW_EMPTY_%s' % pkgname, '1', d)
254                 bb.data.setVar('PACKAGES', '%s %s' % (pkgname, bb.data.getVar('PACKAGES', d, 1)), d)
255                 rprovides = 'virtual-locale-%s' % legitimize_package_name(name)
256                 m = re.match("(.*)_(.*)", name)
257                 if m:
258                         rprovides += ' virtual-locale-%s' % m.group(1)
259                 bb.data.setVar('RPROVIDES_%s' % pkgname, rprovides, d)
260                 if use_bin == "compile":
261                         output_locale_binary_rdepends(name, pkgname, locale, encoding)
262                         output_locale_binary(name, pkgname, locale, encoding)
263                 elif use_bin == "precompiled":
264                         output_locale_binary_rdepends(name, pkgname, locale, encoding)
265                 else:
266                         output_locale_source(name, pkgname, locale, encoding)
267
268         if use_bin == "compile":
269                 bb.note("preparing tree for binary locale generation")
270                 bb.build.exec_func("do_prep_locale_tree", d)
271
272         # Reshuffle names so that UTF-8 is preferred over other encodings
273         non_utf8 = []
274         for l in encodings.keys():
275                 if len(encodings[l]) == 1:
276                         output_locale(l, l, encodings[l][0])
277                         if encodings[l][0] != "UTF-8":
278                                 non_utf8.append(l)
279                 else:
280                         if "UTF-8" in encodings[l]:
281                                 output_locale(l, l, "UTF-8")
282                                 encodings[l].remove("UTF-8")
283                         else:
284                                 non_utf8.append(l)
285                         for e in encodings[l]:
286                                 output_locale('%s.%s' % (l, e), l, e)
287
288         if non_utf8 != [] and use_bin != "precompiled":
289                 bb.note("the following locales are supported only in legacy encodings:")
290                 bb.note("  " + " ".join(non_utf8))
291
292         if use_bin == "compile":
293                 bb.note("collecting binary locales from locale tree")
294                 bb.build.exec_func("do_collect_bins_from_locale_tree", d)
295                 do_split_packages(d, binary_locales_dir, file_regex='(.*)', output_pattern='glibc-binary-localedata-%s', description='binary locale definition for %s', extra_depends='', allow_dirs=True)
296         elif use_bin == "precompiled":
297                 do_split_packages(d, binary_locales_dir, file_regex='(.*)', output_pattern='glibc-binary-localedata-%s', description='binary locale definition for %s', extra_depends='', allow_dirs=True)
298         else:
299                 bb.note("generation of binary locales disabled. this may break i18n!")
300
301 }
302
303 # We want to do this indirection so that we can safely 'return'
304 # from the called function even though we're prepending
305 python populate_packages_prepend () {
306         if bb.data.getVar('DEBIAN_NAMES', d, 1):
307                 bb.data.setVar('PKG_glibc', 'libc6', d)
308                 bb.data.setVar('PKG_glibc-dev', 'libc6-dev', d)
309         bb.build.exec_func('package_do_split_gconvs', d)
310 }