Update drivers
[vuplus_openembedded] / classes / e.bbclass
1 HOMEPAGE = "http://www.enlightenment.org"
2 SECTION = "e/apps"
3 SRCNAME ?= "${PN}"
4
5 SRC_URI = "svn://svn.enlightenment.org/svn/e/trunk;module=${SRCNAME};proto=http"
6 S = "${WORKDIR}/${SRCNAME}"
7
8 ARM_INSTRUCTION_SET = "arm"
9
10 inherit autotools pkgconfig binconfig
11
12 do_prepsources () {
13   make clean distclean || true
14 }
15 addtask prepsources after do_patch before do_configure
16
17 do_configure_append() {
18         find ${S} -name Makefile | xargs sed -i s:'-I$(includedir)':'-I.':g
19 }
20
21 export CURL_CONFIG = "${STAGING_BINDIR_CROSS}/curl-config"
22 export FREETYPE_CONFIG = "${STAGING_BINDIR_CROSS}/freetype-config"
23
24 # This construction is stupid, someone with more E knowledge should change it to =+ or something
25 # And it's in efl.bbclass as well....
26 PACKAGES = "${PN}-dbg ${PN}-themes ${PN} ${PN}-dev ${PN}-doc ${PN}-lib ${PN}-static"
27 FILES_${PN}-lib = "${libdir}/lib*.so.*"
28 FILES_${PN}-themes = "${datadir}/${PN}/themes ${datadir}/${PN}/data ${datadir}/${PN}/fonts ${datadir}/${PN}/pointers ${datadir}/${PN}/images ${datadir}/${PN}/users ${datadir}/${PN}/images ${datadir}/${PN}/styles"
29 FILES_${PN}-dev += "${includedir} ${libdir}/lib*.so"