bitbake.conf: use rootfs/${PN} for IMAGE_ROOTFS
[vuplus_openembedded] / classes / cpan_build.bbclass
1 #
2 # This is for perl modules that use the new Build.PL build system
3 #
4 inherit cpan-base
5
6 INHIBIT_NATIVE_STAGE_INSTALL = "1"
7
8 #
9 # We also need to have built libmodule-build-perl-native for
10 # everything except libmodule-build-perl-native itself (which uses
11 # this class, but uses itself as the provider of
12 # libmodule-build-perl)
13 #
14 def cpan_build_dep_prepend(d):
15         import bb;
16         if bb.data.getVar('CPAN_BUILD_DEPS', d, 1):
17                 return ''
18         pn = bb.data.getVar('PN', d, 1)
19         if pn in ['libmodule-build-perl', 'libmodule-build-perl-native']:
20                 return ''
21         return 'libmodule-build-perl-native '
22
23 DEPENDS_prepend = "${@cpan_build_dep_prepend(d)}"
24
25 cpan_build_do_configure () {
26         if [ ${@is_target(d)} == "yes" ]; then
27                 # build for target
28                 . ${STAGING_DIR_TARGET}/perl/config.sh
29                 if [ "${IS_NEW_PERL}" = "yes" ]; then
30                         perl Build.PL --installdirs vendor \
31                                 --destdir ${D} \
32                                 --install_path lib="${datadir}/perl5" \
33                                 --install_path arch="${libdir}/perl5" \
34                                 --install_path script=${bindir} \
35                                 --install_path bin=${bindir} \
36                                 --install_path bindoc=${mandir}/man1 \
37                                 --install_path libdoc=${mandir}/man3
38                 else
39                         perl Build.PL --installdirs vendor \
40                                 --destdir ${D} \
41                                 --install_path lib="${libdir}/perl5/site_perl/${version}" \
42                                 --install_path arch="${libdir}/perl5/site_perl/${version}/${TARGET_SYS}" \
43                                 --install_path script=${bindir} \
44                                 --install_path bin=${bindir} \
45                                 --install_path bindoc=${mandir}/man1 \
46                                 --install_path libdoc=${mandir}/man3
47                 fi
48         else
49                 # build for host
50                 perl Build.PL --installdirs site
51         fi
52 }
53
54 cpan_build_do_compile () {
55         perl Build
56 }
57
58 cpan_build_do_install () {
59         if [ ${@is_target(d)} == "yes" ]; then
60                 perl Build install
61         fi
62 }
63
64 do_stage_append () {
65         if [ ${@is_target(d)} == "no" ]; then
66                 perl Build install
67         fi
68 }
69
70 EXPORT_FUNCTIONS do_configure do_compile do_install