Update drivers
[vuplus_openembedded] / classes / ccdv.bbclass
1 python () {
2     if bb.data.getVar('PN', d, 1) in ['ccdv-native']:
3         if not bb.data.getVar('INHIBIT_DEFAULT_DEPS', d, 1):
4             bb.data.setVar("DEPENDS", '%s %s' % ("ccdv-native", bb.data.getVar("DEPENDS", d, 1) or ""), d)
5             bb.data.setVar("CC", '%s %s' % ("ccdv", bb.data.getVar("CC", d, 1) or ""), d)
6             bb.data.setVar("BUILD_CC", '%s %s' % ("ccdv", bb.data.getVar("BUILD_CC", d, 1) or ""), d)
7             bb.data.setVar("CCLD", '%s %s' % ("ccdv", bb.data.getVar("CCLD", d, 1) or ""), d)
8 }
9
10 def quiet_libtool(bb,d):
11         deps = (bb.data.getVar('DEPENDS', d, 1) or "").split()
12         if 'libtool-cross' in deps:
13                 return "'LIBTOOL=${STAGING_BINDIR_NATIVE}/${HOST_SYS}-libtool --silent'"
14         elif 'libtool-native' in deps:
15                 return "'LIBTOOL=${B}/${HOST_SYS}-libtool --silent'"
16         else:
17                 return ""
18
19 CCDV = "ccdv"
20 EXTRA_OEMAKE_append = " ${@quiet_libtool(bb,d)}"
21 MAKE += "-s"