Support Uno4k/Ultimo4k
[vuplus_openvuplus_3.0] / meta-openvuplus / recipes-vuplus / bluetoothsetup / enigma2-plugin-systemplugins-bluetoothsetup.bb
diff --git a/meta-openvuplus/recipes-vuplus/bluetoothsetup/enigma2-plugin-systemplugins-bluetoothsetup.bb b/meta-openvuplus/recipes-vuplus/bluetoothsetup/enigma2-plugin-systemplugins-bluetoothsetup.bb
new file mode 100644 (file)
index 0000000..3c17bbf
--- /dev/null
@@ -0,0 +1,38 @@
+DESCRIPTION = "Vuplus bluetooth plugin"
+
+LICENSE = "CLOSED"
+
+DEPENDS = "python-native"
+RDEPENDS_${PN} = "vuplus-bluetooth-util"
+
+SRCDATE="20161123"
+SRCDATE_PR = "r0"
+PR="${SRCDATE}.${SRCDATE_PR}"
+
+SRC_URI = " \
+    http://archive.vuplus.com/download/build_support/vuplus/enigma2-plugin-bluetoothsetup-${MACHINE}-${PR}.tar.gz \
+"
+
+S = "${WORKDIR}/plugin"
+
+BLUETOOTH_PLUGIN_PATH = "/usr/lib/enigma2/python/Plugins/SystemPlugins/BluetoothSetup"
+
+do_compile() {
+       python -O -m compileall ${S}
+}
+
+do_install() {
+       install -d  ${D}${BLUETOOTH_PLUGIN_PATH}
+       cp -rp ${S}/* ${D}${BLUETOOTH_PLUGIN_PATH}
+}
+
+FILES_${PN} = "${BLUETOOTH_PLUGIN_PATH}"
+
+do_populate_sysroot[noexec] = "1"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+INSANE_SKIP_${PN} = "already-stripped"
+
+SRC_URI[md5sum] = "a26cf03038c879bc226cf31b9038cbcb"
+SRC_URI[sha256sum] = "1f7a4501dbdb598ae6a4743840eacb1821556df529168406e9a586379f24a80e"