Fix/update bb files.
[vuplus_openembedded] / recipes / linux / linux-replicant_git.bb
1 require linux.inc
2
3 PV = "2.6.25+${PR}+gitr${SRCREV}"
4 PV_htcraphael = "2.6.27+${PR}+gitr${SRCREV}"
5 PV_htcdiamond = "2.6.27+${PR}+gitr${SRCREV}"
6 PV_htcdream = "2.6.29+${PR}+gitr${SRCREV}"
7 PR = "r13"
8
9 COMPATIBLE_MACHINE = "htckaiser|htcpolaris|htcvogue|htctitan|htcnike|htcraphael|htcdiamond|htcblackstone|htcdream"
10
11 SRCREV = "d2fc2471ba384dabad1c9a4126e2e2372349d34c"
12 SRCREV_htcraphael = "905eb169a7d659c221aad5c38aac443065178c4c"
13 SRCREV_htcdiamond = "905eb169a7d659c221aad5c38aac443065178c4c"
14 SRCREV_htcblackstone = "905eb169a7d659c221aad5c38aac443065178c4c"
15 SRCREV_htcdream = "31f124b5a67f6b2da2354e76a01bcc9ca9526f63"
16
17 SRC_BRANCH = "htc-vogue"
18 SRC_BRANCH_htcraphael = "htc-msm-2.6.27"
19 SRC_BRANCH_htcdiamond = "htc-msm-2.6.27"
20 SRC_BRANCH_htcblackstone = "htc-msm-2.6.27"
21 SRC_BRANCH_htcdream = "leviathan"
22
23 SRC_URI = "\
24         git://gitorious.org/replicant/gnulinuxkernel.git;branch=${SRC_BRANCH};protocol=git \
25         file://defconfig \
26 "
27
28 S = "${WORKDIR}/git"