ptp-gadget: add ptp gadgetfs driver
[vuplus_openembedded] / recipes / gphoto2 / ptp-gadget_git.bb
1 DESCRIPTION = "This is a device-side implementation of the PTP (Picture Transfer Protocol)"
2 LICENSE = "GPLv3"
3
4 DEPENDS = "virtual/kernel"
5 RDEPENDS = "imagemagick"
6
7 PV = "1.1"
8 PR_append = "+gitr${SRCREV}"
9
10 SRCREV = "ef7ef29b5cdcf8630c901362a66905b956242e0d"
11 SRC_URI = "git://git.denx.de/ptp-gadget.git;protocol=git"
12
13 S = "${WORKDIR}/git"
14
15 do_compile () {
16         export CPPFLAGS="${CPPFLAGS} ${CFLAGS}"
17         sed -i -e 's:pthread:pthread ${LDFLAGS}:' Makefile
18         oe_runmake KERNEL_SRC=${STAGING_KERNEL_DIR} CROSS_COMPILE=${TARGET_PREFIX}
19 }
20
21 do_install () {
22         sed -i -e s:local/::g Makefile
23         # "/usr/bin" is hardcoded in the makefile
24         install -d ${D}/usr/bin
25         oe_runmake install DESTDIR="${D}"
26 }
27
28 #Need specific kernel headers
29 PACKAGE_ARCH = "${MACHINE_ARCH}"