ptp-gadget: add ptp gadgetfs driver
authorKoen Kooi <koen@openembedded.org>
Fri, 29 May 2009 14:36:57 +0000 (16:36 +0200)
committerKoen Kooi <koen@openembedded.org>
Fri, 29 May 2009 14:36:57 +0000 (16:36 +0200)
recipes/gphoto2/ptp-gadget_git.bb [new file with mode: 0644]

diff --git a/recipes/gphoto2/ptp-gadget_git.bb b/recipes/gphoto2/ptp-gadget_git.bb
new file mode 100644 (file)
index 0000000..edd08cd
--- /dev/null
@@ -0,0 +1,29 @@
+DESCRIPTION = "This is a device-side implementation of the PTP (Picture Transfer Protocol)"
+LICENSE = "GPLv3"
+
+DEPENDS = "virtual/kernel"
+RDEPENDS = "imagemagick"
+
+PV = "1.1"
+PR_append = "+gitr${SRCREV}"
+
+SRCREV = "ef7ef29b5cdcf8630c901362a66905b956242e0d"
+SRC_URI = "git://git.denx.de/ptp-gadget.git;protocol=git"
+
+S = "${WORKDIR}/git"
+
+do_compile () {
+       export CPPFLAGS="${CPPFLAGS} ${CFLAGS}"
+       sed -i -e 's:pthread:pthread ${LDFLAGS}:' Makefile
+       oe_runmake KERNEL_SRC=${STAGING_KERNEL_DIR} CROSS_COMPILE=${TARGET_PREFIX}
+}
+
+do_install () {
+       sed -i -e s:local/::g Makefile
+       # "/usr/bin" is hardcoded in the makefile
+       install -d ${D}/usr/bin
+       oe_runmake install DESTDIR="${D}"
+}
+
+#Need specific kernel headers
+PACKAGE_ARCH = "${MACHINE_ARCH}"