opera hbbtv.
[vuplus_openembedded] / recipes / ekiga / ekiga_3.0.2.bb
1 DESCRIPTION = "Gnome videoconferencing application"
2 LICENSE = "GPLv2"
3
4 PR = "r1"
5
6 ARM_INSTRUCTION_SET = "arm"
7
8 inherit gnome
9 DEPENDS += " avahi libnotify eds-dbus libgnome gtkmm libsigc++-2.0 gstreamer opal ptlib"
10 RDEPENDS += "opal ptlib"
11
12 SRC_URI = "http://www.ekiga.org/admin/downloads/latest/sources/ekiga_${PV}/ekiga-${PV}.tar.gz \
13            file://static-fix.diff;patch=1"
14
15 EXTRA_OECONF = "  --enable-static-libs --disable-gdu --disable-scrollkeeper "
16
17 CFLAGS_append = " -DSTATIC_LIBS_USED "
18 CXXFLAGS_append = " -DSTATIC_LIBS_USED "
19
20 do_configure_append() {
21         find ${S} -name Makefile | xargs sed -i s:'-I$(includedir)':'-I.':g
22         find ${S} -name Makefile | xargs sed -i s:'-I/usr/include':'-I${STAGING_INCDIR}':g
23 }
24
25 FILES_${PN} += "${datadir}/dbus-1 ${datadir}/icons"
26