task-self-hosting: Metapackage to install everything needed for self hosted builds
[vuplus_openembedded] / packages / tasks / task-self-hosting.bb
1 DESCRIPTION = "All tools needed for OpenEmbedded build"
2 SECTION = "devel"
3 LICENSE = "MIT"
4 RDEPENDS = "cpp gcc-symlinks binutils-symlinks \
5             perl perl-modules bitbake bash \
6                         task-proper-tools glibc-utils \
7                         libc-linux-headers-dev glibc-dev \
8                         texinfo make cvs subversion monotone-6"
9
10 #
11 # quilt-native REQ bash and perl/perl-modules
12 # binutils REQ texinfo
13 #
14 # bitbake will fetch all needed python modules
15 #
16 # toolchain: 
17 # - gcc-symlinks will fetch gcc
18 # - binutils-symlinks will fetch binutils
19 # - glibc-utils REQ cpp
20
21 # problems:
22 # - binutils-synlinks conflict with busybox
23 # - glibc-dev conflict with libc-linux-headers-dev
24 # - perl is so granulated that it is probably impossible 
25 #   to find out which packages are needed
26 #
27
28 ALLOW_EMPTY = "1"
29
30 PACKAGE_ARCH = "all"