task-self-hosting: Metapackage to install everything needed for self hosted builds
authorMarcin Juszkiewicz <hrw@openembedded.org>
Mon, 18 Dec 2006 13:47:00 +0000 (13:47 +0000)
committerMarcin Juszkiewicz <hrw@openembedded.org>
Mon, 18 Dec 2006 13:47:00 +0000 (13:47 +0000)
Tested with Angstrom-2007.1/i686 build in chroot - bitbake nano finished.

packages/tasks/task-self-hosting.bb [new file with mode: 0644]

diff --git a/packages/tasks/task-self-hosting.bb b/packages/tasks/task-self-hosting.bb
new file mode 100644 (file)
index 0000000..a82d6a6
--- /dev/null
@@ -0,0 +1,30 @@
+DESCRIPTION = "All tools needed for OpenEmbedded build"
+SECTION = "devel"
+LICENSE = "MIT"
+RDEPENDS = "cpp gcc-symlinks binutils-symlinks \
+            perl perl-modules bitbake bash \
+                       task-proper-tools glibc-utils \
+                       libc-linux-headers-dev glibc-dev \
+                       texinfo make cvs subversion monotone-6"
+
+#
+# quilt-native REQ bash and perl/perl-modules
+# binutils REQ texinfo
+#
+# bitbake will fetch all needed python modules
+#
+# toolchain: 
+# - gcc-symlinks will fetch gcc
+# - binutils-symlinks will fetch binutils
+# - glibc-utils REQ cpp
+# 
+# problems:
+# - binutils-synlinks conflict with busybox
+# - glibc-dev conflict with libc-linux-headers-dev
+# - perl is so granulated that it is probably impossible 
+#   to find out which packages are needed
+#
+
+ALLOW_EMPTY = "1"
+
+PACKAGE_ARCH = "all"