kexecboot_0.4.bb : add patch to always use 16bit writes, this fixes tosa
[vuplus_openembedded] / packages / kexecboot / kexecboot_0.4.bb
1 LICENSE = "GPL"
2 PR = "r3"
3 DEPENDS = "klibc"
4 RDEPENDS = "kexec-static"
5
6 inherit autotools
7
8 # You can create your own *-img.h by doing
9 # ./make-image-header.sh <file>.png HAND
10
11 SRC_URI = "http://projects.linuxtogo.org/~jay7/kexecboot-${PV}.tar.gz \
12         file://add-reboot-option.patch;patch=1 \
13         file://scan_devices-top.patch;patch=1 \
14         file://graphical-no-devices.patch;patch=1 \
15         file://switch-cursor-off.patch;patch=1 \
16         file://add-sleep.patch;patch=1 \
17         file://silent-output-hack.patch;patch=1 \
18         file://kexecboot-tosa.patch;patch=1 \
19         file://fb-render-16bit.patch;patch=1 \
20         "
21
22 S = "${WORKDIR}/kexecboot-${PV}"
23
24 export CC=${TARGET_PREFIX}klcc
25
26 # standard oe cflags don't work with klcc
27 export CFLAGS = ""
28 export CPPFLAGS = ""
29 export LDFLAGS = ""
30
31 do_install () {
32         install -d ${D}${bindir}
33         install -m 0755 kexecboot ${D}${bindir}/
34
35         install -d ${D}/proc
36         install -d ${D}/mnt
37 }
38
39 FILES_${PN} += " ${bindir}/kexecboot /init /proc /mnt"
40
41 pkg_postinst_${PN} () {
42         ln -sf ${bindir}/kexecboot $D/init
43 }