kexecboot_0.4.bb : add patch to always use 16bit writes, this fixes tosa
authorGraeme Gregory <dp@xora.org.uk>
Thu, 29 Jan 2009 22:16:37 +0000 (22:16 +0000)
committerGraeme Gregory <dp@xora.org.uk>
Thu, 29 Jan 2009 22:18:18 +0000 (22:18 +0000)
screen corruption and wont harm other machines

packages/kexecboot/kexecboot-0.4/fb-render-16bit.patch [new file with mode: 0644]
packages/kexecboot/kexecboot_0.4.bb

diff --git a/packages/kexecboot/kexecboot-0.4/fb-render-16bit.patch b/packages/kexecboot/kexecboot-0.4/fb-render-16bit.patch
new file mode 100644 (file)
index 0000000..f3405e4
--- /dev/null
@@ -0,0 +1,21 @@
+Index: kexecboot-0.4/fb.c
+===================================================================
+--- kexecboot-0.4.orig/fb.c    2009-01-29 22:03:34.000000000 +0000
++++ kexecboot-0.4/fb.c 2009-01-29 22:08:22.000000000 +0000
+@@ -19,7 +19,15 @@
+ void fb_render(FB * fb)
+ {
+-      memcpy(fb->data, fb->backbuffer, fb->screensize);
++      uint16 *source, *dest;
++      int n = fb->screensize/2;
++
++      source = (uint16 *)fb->backbuffer;
++      dest = (uint16 *)fb->data;
++
++      while (n--) {
++              *dest++ = *source++;
++      }
+ }
+ void fb_destroy(FB * fb)
index 85dd29e..ef68881 100644 (file)
@@ -1,5 +1,5 @@
 LICENSE = "GPL"
-PR = "r2"
+PR = "r3"
 DEPENDS = "klibc"
 RDEPENDS = "kexec-static"
 
@@ -16,6 +16,7 @@ SRC_URI = "http://projects.linuxtogo.org/~jay7/kexecboot-${PV}.tar.gz \
        file://add-sleep.patch;patch=1 \
        file://silent-output-hack.patch;patch=1 \
        file://kexecboot-tosa.patch;patch=1 \
+       file://fb-render-16bit.patch;patch=1 \
        "
 
 S = "${WORKDIR}/kexecboot-${PV}"