summaryrefslogtreecommitdiff
path: root/meta-openvuplus/recipes-vuplus
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openvuplus/recipes-vuplus')
-rw-r--r--meta-openvuplus/recipes-vuplus/e2openplugins/enigma2-plugin-extensions-openwebif.bb3
-rw-r--r--meta-openvuplus/recipes-vuplus/e2openplugins/files/openwebif_block_in_qpip.patch37
-rwxr-xr-xmeta-openvuplus/recipes-vuplus/enigma2/enigma2-plugins.bb3
-rw-r--r--meta-openvuplus/recipes-vuplus/enigma2/enigma2-plugins/enigma2_plugins_setqpipmode.patch36
-rw-r--r--meta-openvuplus/recipes-vuplus/enigma2/enigma2.bb2
-rw-r--r--meta-openvuplus/recipes-vuplus/packagegroups/packagegroup-vuplus-enigma2.bb3
-rw-r--r--meta-openvuplus/recipes-vuplus/vuplus-skin/vuplus-skins.bb2
7 files changed, 81 insertions, 5 deletions
diff --git a/meta-openvuplus/recipes-vuplus/e2openplugins/enigma2-plugin-extensions-openwebif.bb b/meta-openvuplus/recipes-vuplus/e2openplugins/enigma2-plugin-extensions-openwebif.bb
index 3f84aaf..3671b9f 100644
--- a/meta-openvuplus/recipes-vuplus/e2openplugins/enigma2-plugin-extensions-openwebif.bb
+++ b/meta-openvuplus/recipes-vuplus/e2openplugins/enigma2-plugin-extensions-openwebif.bb
@@ -12,11 +12,12 @@ SRCREV_pn-${PN}="d84307958746e6a597b43defe5bd1cb78fd745c8"
inherit gitpkgv
PV = "1+git${SRCPV}"
PKGV = "1+git${GITPKGV}"
-PR = "r3"
+PR = "r4"
require openplugins-distutils.inc
SRC_URI += " file://openwebif_solo4k.patch;striplevel=1 "
+SRC_URI += " file://openwebif_block_in_qpip.patch"
# Just a quick hack to "compile" it
do_compile() {
diff --git a/meta-openvuplus/recipes-vuplus/e2openplugins/files/openwebif_block_in_qpip.patch b/meta-openvuplus/recipes-vuplus/e2openplugins/files/openwebif_block_in_qpip.patch
new file mode 100644
index 0000000..6794280
--- /dev/null
+++ b/meta-openvuplus/recipes-vuplus/e2openplugins/files/openwebif_block_in_qpip.patch
@@ -0,0 +1,37 @@
+diff --git a/plugin/controllers/models/control.py b/plugin/controllers/models/control.py
+old mode 100644
+new mode 100755
+index 1045d44..4a564bb
+--- a/plugin/controllers/models/control.py
++++ b/plugin/controllers/models/control.py
+@@ -13,6 +13,17 @@ from enigma import eServiceReference, eActionMap, eServiceCenter
+ from urllib import unquote
+ from services import getProtection
+ from Screens.InfoBar import InfoBar, MoviePlayer
++import os
++
++ENABLE_QPIP_PROCPATH = "/proc/stb/video/decodermode"
++def checkIsQPiP():
++ if os.access(ENABLE_QPIP_PROCPATH, os.F_OK):
++ fd = open(ENABLE_QPIP_PROCPATH,"r")
++ data = fd.read()
++ fd.close()
++
++ return data.strip() == "mosaic"
++ return False
+
+ def zapInServiceList(service):
+ InfoBar_Instance = InfoBar.instance
+@@ -60,6 +71,12 @@ def zapInServiceList(service):
+ servicelist.zap()
+
+ def zapService(session, id, title = ""):
++ if checkIsQPiP():
++ return {
++ "result": False,
++ "message": "Can not zap service in quad PiP mode."
++ }
++
+ # Must NOT unquote id here, breaks zap to streams
+ service = eServiceReference(id)
+
diff --git a/meta-openvuplus/recipes-vuplus/enigma2/enigma2-plugins.bb b/meta-openvuplus/recipes-vuplus/enigma2/enigma2-plugins.bb
index 3aad601..38ed869 100755
--- a/meta-openvuplus/recipes-vuplus/enigma2/enigma2-plugins.bb
+++ b/meta-openvuplus/recipes-vuplus/enigma2/enigma2-plugins.bb
@@ -11,7 +11,7 @@ SRCREV="c8fc96e8e51e1ef71e1709f9dd6f733007f9463e"
SRCDATE="20110215"
BRANCH="master"
PV = "experimental-git${SRCDATE}"
-PR = "r13"
+PR = "r14"
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
@@ -40,6 +40,7 @@ SRC_URI_append_vuplus = " \
file://dreamboxwebtv.png \
file://favicon.ico \
file://Makefile.am \
+ file://enigma2_plugins_setqpipmode.patch \
"
FILES_${PN} += " /usr/share/enigma2 /usr/share/fonts "
diff --git a/meta-openvuplus/recipes-vuplus/enigma2/enigma2-plugins/enigma2_plugins_setqpipmode.patch b/meta-openvuplus/recipes-vuplus/enigma2/enigma2-plugins/enigma2_plugins_setqpipmode.patch
new file mode 100644
index 0000000..834936a
--- /dev/null
+++ b/meta-openvuplus/recipes-vuplus/enigma2/enigma2-plugins/enigma2_plugins_setqpipmode.patch
@@ -0,0 +1,36 @@
+diff --git a/merlinmusicplayer/src/merlinmp3player/merlinmp3player.h b/merlinmusicplayer/src/merlinmp3player/merlinmp3player.h
+index 693cbbb..d72d4d4 100644
+--- a/merlinmusicplayer/src/merlinmp3player/merlinmp3player.h
++++ b/merlinmusicplayer/src/merlinmp3player/merlinmp3player.h
+@@ -65,6 +65,7 @@ public:
+ RESULT stream(ePtr<iStreamableService> &ptr) { ptr = 0; return -1; };
+ RESULT streamed(ePtr<iStreamedService> &ptr) { ptr = 0; return -1; };
+ RESULT keys(ePtr<iServiceKeys> &ptr) { ptr = 0; return -1; };
++ void setQpipMode(bool value, bool audio) { }
+
+ // iPausableService
+ RESULT pause();
+diff --git a/partnerbox/src/servicewebts/servicewebts.h b/partnerbox/src/servicewebts/servicewebts.h
+index 27464a4..8142197 100644
+--- a/partnerbox/src/servicewebts/servicewebts.h
++++ b/partnerbox/src/servicewebts/servicewebts.h
+@@ -105,6 +105,7 @@ public:
+ RESULT stream(ePtr<iStreamableService> &ptr) { ptr = 0; return -1; };
+ RESULT streamed(ePtr<iStreamedService> &ptr) { ptr = 0; return -1; };
+ RESULT keys(ePtr<iServiceKeys> &ptr) { ptr = 0; return -1; };
++ void setQpipMode(bool value, bool audio) { }
+
+ // iPausableService
+ RESULT pause();
+diff --git a/vlcplayer/src/servicets/servicets.h b/vlcplayer/src/servicets/servicets.h
+index 5b0b65a..83710b5 100644
+--- a/vlcplayer/src/servicets/servicets.h
++++ b/vlcplayer/src/servicets/servicets.h
+@@ -80,6 +80,7 @@ public:
+ RESULT stream(ePtr<iStreamableService> &ptr) { ptr = 0; return -1; };
+ RESULT streamed(ePtr<iStreamedService> &ptr) { ptr = 0; return -1; };
+ RESULT keys(ePtr<iServiceKeys> &ptr) { ptr = 0; return -1; };
++ void setQpipMode(bool value, bool audio) { }
+
+ // iPausableService
+ RESULT pause();
diff --git a/meta-openvuplus/recipes-vuplus/enigma2/enigma2.bb b/meta-openvuplus/recipes-vuplus/enigma2/enigma2.bb
index 2e28219..5743b68 100644
--- a/meta-openvuplus/recipes-vuplus/enigma2/enigma2.bb
+++ b/meta-openvuplus/recipes-vuplus/enigma2/enigma2.bb
@@ -231,7 +231,7 @@ DEPENDS += "${@base_contains("VUPLUS_FEATURES", "uianimation", "libgles libvugle
RDEPENDS_${PN}_append_vuplus += "${@base_contains("VUPLUS_FEATURES", "uianimation", "libvugles2" , "", d)}"
PN = "enigma2"
-PR = "r155"
+PR = "r156"
inherit gitpkgv pythonnative
diff --git a/meta-openvuplus/recipes-vuplus/packagegroups/packagegroup-vuplus-enigma2.bb b/meta-openvuplus/recipes-vuplus/packagegroups/packagegroup-vuplus-enigma2.bb
index 2a74516..6245312 100644
--- a/meta-openvuplus/recipes-vuplus/packagegroups/packagegroup-vuplus-enigma2.bb
+++ b/meta-openvuplus/recipes-vuplus/packagegroups/packagegroup-vuplus-enigma2.bb
@@ -2,7 +2,7 @@ SUMMARY = "Enigma2 set of packages for Vuplus"
SECTION = "vuplus/base"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
-PR = "r20"
+PR = "r21"
PACKAGE_ARCH = "${MACHINE_ARCH}"
@@ -80,6 +80,7 @@ RDEPENDS_${PN} += " \
${@base_contains("VUPLUS_FEATURES", "bluetooth", "enigma2-plugin-extensions-witaispeechtotext", "", d)} \
${@base_conditional("MACHINE", "vuultimo4k", "enigma2-plugin-systemplugins-ultimo4kmisccontrol", "", d)} \
${@base_contains("VUPLUS_FEATURES", "scrambledplayback", "enigma2-plugin-systemplugins-pvrdescrambleconvert", "", d)} \
+ ${@base_contains("VUPLUS_FEATURES", "quadpip", "enigma2-plugin-extensions-quadpip", "", d)} \
"
PACKAGE_ARCH = "${MACHINE_ARCH}"
diff --git a/meta-openvuplus/recipes-vuplus/vuplus-skin/vuplus-skins.bb b/meta-openvuplus/recipes-vuplus/vuplus-skin/vuplus-skins.bb
index 07a3db4..e5f6e30 100644
--- a/meta-openvuplus/recipes-vuplus/vuplus-skin/vuplus-skins.bb
+++ b/meta-openvuplus/recipes-vuplus/vuplus-skin/vuplus-skins.bb
@@ -3,7 +3,7 @@ LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
PV = "1.0"
-PR = "r5"
+PR = "r6"
RDEPENDS_${PN} = "enigma2"