summaryrefslogtreecommitdiff
path: root/meta-openvuplus
diff options
context:
space:
mode:
authorhschang <chang@dev3>2018-11-12 07:36:36 (GMT)
committerhschang <chang@dev3>2018-11-13 04:42:12 (GMT)
commitb3c10d75cdbdecf044df85d2dda62ff4c409a4d3 (patch)
tree3233d8c38bad600c79eb7ada5e5c1b10928a2ac8 /meta-openvuplus
parentcef20fab184476968c2346e7558c9d9c5ee7ed10 (diff)
Support duo4k.
Diffstat (limited to 'meta-openvuplus')
-rw-r--r--meta-openvuplus/recipes-connectivity/packagegroups/packagegroup-vuplus-wlan.bb3
-rw-r--r--meta-openvuplus/recipes-connectivity/ppp/files/ppp_compile_error.patch22
-rw-r--r--meta-openvuplus/recipes-connectivity/ppp/ppp_2.4.7.bbappend8
-rw-r--r--meta-openvuplus/recipes-core/udev/udev_182.bbappend2
-rwxr-xr-xmeta-openvuplus/recipes-vuplus/aio-grab/aio-grab.bb4
-rw-r--r--meta-openvuplus/recipes-vuplus/aio-grab/aio-grab/aio-grab_vuplus_c469655e3498abdb58a36b4f62edbd9699ff6f84.patch (renamed from meta-openvuplus/recipes-vuplus/aio-grab/aio-grab/aio-grab_vuplus_6706273e6987e54e4dace15936a2cfd4e8c8c41c.patch)28
-rw-r--r--meta-openvuplus/recipes-vuplus/e2openplugins/enigma2-plugin-extensions-openwebif.bb5
-rw-r--r--meta-openvuplus/recipes-vuplus/e2openplugins/files/box_duo4k.pngbin0 -> 53029 bytes
-rw-r--r--meta-openvuplus/recipes-vuplus/e2openplugins/files/openwebif_support_vumodels.patch4
-rw-r--r--meta-openvuplus/recipes-vuplus/e2openplugins/files/openwebif_vu_box_remote.patch2
-rw-r--r--meta-openvuplus/recipes-vuplus/enigma2/enigma2-transtreamproxy.bb1
-rw-r--r--meta-openvuplus/recipes-vuplus/packagegroups/packagegroup-vuplus-base.bb3
-rw-r--r--meta-openvuplus/recipes-vuplus/packagegroups/packagegroup-vuplus-enigma2.bb2
13 files changed, 60 insertions, 24 deletions
diff --git a/meta-openvuplus/recipes-connectivity/packagegroups/packagegroup-vuplus-wlan.bb b/meta-openvuplus/recipes-connectivity/packagegroups/packagegroup-vuplus-wlan.bb
index 8875b03..f79f89c 100644
--- a/meta-openvuplus/recipes-connectivity/packagegroups/packagegroup-vuplus-wlan.bb
+++ b/meta-openvuplus/recipes-connectivity/packagegroups/packagegroup-vuplus-wlan.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "Vuplus: W-LAN package group for the Vuplus Distribution"
SECTION = "vuplus/base"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
-PR = "r20"
+PR = "r22"
PACKAGE_ARCH = "${MACHINE_ARCH}"
@@ -54,5 +54,6 @@ RDEPENDS_${PN}_append = "\
${LEGACY_MODULES} \
rt2870sta \
${@base_conditional("MACHINE", "vuultimo4k", "vuplus-wifi-util-vuultimo4k", "", d)} \
+ ${@base_conditional("MACHINE", "vuduo4k", "vuplus-wifi-util-vuduo4k", "", d)} \
"
diff --git a/meta-openvuplus/recipes-connectivity/ppp/files/ppp_compile_error.patch b/meta-openvuplus/recipes-connectivity/ppp/files/ppp_compile_error.patch
new file mode 100644
index 0000000..2f6933f
--- /dev/null
+++ b/meta-openvuplus/recipes-connectivity/ppp/files/ppp_compile_error.patch
@@ -0,0 +1,22 @@
+diff --git a/pppd/plugins/rp-pppoe/pppoe.h b/pppd/plugins/rp-pppoe/pppoe.h
+index 9ab2eee..b827620 100644
+--- a/pppd/plugins/rp-pppoe/pppoe.h
++++ b/pppd/plugins/rp-pppoe/pppoe.h
+@@ -47,6 +47,8 @@
+ #include <sys/socket.h>
+ #endif
+
++#include <netinet/in.h>
++
+ /* Ugly header files on some Linux boxes... */
+ #if defined(HAVE_LINUX_IF_H)
+ #include <linux/if.h>
+@@ -84,8 +86,6 @@ typedef unsigned long UINT32_t;
+ #include <linux/if_ether.h>
+ #endif
+
+-#include <netinet/in.h>
+-
+ #ifdef HAVE_NETINET_IF_ETHER_H
+ #include <sys/types.h>
+
diff --git a/meta-openvuplus/recipes-connectivity/ppp/ppp_2.4.7.bbappend b/meta-openvuplus/recipes-connectivity/ppp/ppp_2.4.7.bbappend
index e6587d2..eadf7d3 100644
--- a/meta-openvuplus/recipes-connectivity/ppp/ppp_2.4.7.bbappend
+++ b/meta-openvuplus/recipes-connectivity/ppp/ppp_2.4.7.bbappend
@@ -1,4 +1,8 @@
-PR .= "-vuplus0"
+PR .= "-vuplus1"
+
+SRC_URI += " \
+ ${@base_version_less_or_equal('VUPLUS_KERNEL_VERSION', '4.1.20', '', 'file://ppp_compile_error.patch', d)} \
+"
do_install_append() {
rm ${D}/${sysconfdir}/ppp/options
@@ -6,3 +10,5 @@ do_install_append() {
}
CONFFILES_${PN} = "${sysconfdir}/ppp/chap-secrets"
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
diff --git a/meta-openvuplus/recipes-core/udev/udev_182.bbappend b/meta-openvuplus/recipes-core/udev/udev_182.bbappend
index 06620a1..4bedf38 100644
--- a/meta-openvuplus/recipes-core/udev/udev_182.bbappend
+++ b/meta-openvuplus/recipes-core/udev/udev_182.bbappend
@@ -1,4 +1,4 @@
-PR .= "-vuplus7"
+PR .= "-vuplus9"
SRC_URI += " \
file://99_vuplus.rules \
diff --git a/meta-openvuplus/recipes-vuplus/aio-grab/aio-grab.bb b/meta-openvuplus/recipes-vuplus/aio-grab/aio-grab.bb
index 27e0a05..5d727a5 100755
--- a/meta-openvuplus/recipes-vuplus/aio-grab/aio-grab.bb
+++ b/meta-openvuplus/recipes-vuplus/aio-grab/aio-grab.bb
@@ -2,13 +2,13 @@ SUMMARY = "Screen grabber for Set-Top-Boxes"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://LICENSE;md5=94d55d512a9ba36caa9b7df079bae19f"
SRCREV = "8394e1ba98c73d7c56d3235ef16cce253dc597cd"
-PR = "r4"
+PR = "r5"
DEPENDS = "jpeg libpng"
SRC_URI = " \
git://schwerkraft.elitedvb.net/aio-grab/aio-grab.git;protocol=git;tag=${SRCREV} \
- file://aio-grab_vuplus_6706273e6987e54e4dace15936a2cfd4e8c8c41c.patch;striplevel=1 \
+ file://aio-grab_vuplus_c469655e3498abdb58a36b4f62edbd9699ff6f84.patch;striplevel=1 \
"
S = "${WORKDIR}/git"
diff --git a/meta-openvuplus/recipes-vuplus/aio-grab/aio-grab/aio-grab_vuplus_6706273e6987e54e4dace15936a2cfd4e8c8c41c.patch b/meta-openvuplus/recipes-vuplus/aio-grab/aio-grab/aio-grab_vuplus_c469655e3498abdb58a36b4f62edbd9699ff6f84.patch
index 8d7bc10..884a908 100644
--- a/meta-openvuplus/recipes-vuplus/aio-grab/aio-grab/aio-grab_vuplus_6706273e6987e54e4dace15936a2cfd4e8c8c41c.patch
+++ b/meta-openvuplus/recipes-vuplus/aio-grab/aio-grab/aio-grab_vuplus_c469655e3498abdb58a36b4f62edbd9699ff6f84.patch
@@ -8,7 +8,7 @@ index ccfb515..a6f8d11 100644
stamp-h1
+aio-grab_vuplus_*
diff --git a/main.c b/main.c
-index 190ff5f..c600103 100644
+index 190ff5f..0a4cc01 100644
--- a/main.c
+++ b/main.c
@@ -1,5 +1,5 @@
@@ -72,7 +72,7 @@ index 190ff5f..c600103 100644
unsigned int xres_v = 0,yres_v = 0,xres_o,yres_o,xres,yres,aspect,width;
int c,osd_only,video_only,use_osd_res,use_png,use_jpg,jpg_quality,no_aspect,use_letterbox;
-@@ -205,11 +221,43 @@ int main(int argc, char **argv) {
+@@ -205,11 +221,45 @@ int main(int argc, char **argv) {
char filename[256] = { "/tmp/screenshot.bmp" };
// detect STB
@@ -113,11 +113,13 @@ index 190ff5f..c600103 100644
+ stb_type=BRCM_ARM;
+ else if (strstr(upcase(line),"7260"))
+ stb_type=BRCM_ARM;
++ else if (strstr(upcase(line),"7278"))
++ stb_type=BRCM_ARM;
+#else
line = file_getline("/proc/stb/info/model");
if (line == NULL)
return 1;
-@@ -221,6 +269,7 @@ int main(int argc, char **argv) {
+@@ -221,6 +271,7 @@ int main(int argc, char **argv) {
!strcmp(line, "dm800se") ||
!strcmp(line, "dm7020hd"))
stb_type = BRCM7405;
@@ -125,7 +127,7 @@ index 190ff5f..c600103 100644
} else if (strstr(line, "xilleonfb")) {
stb_type = XILLEON;
} else if (strstr(line, "Pallas FB")) {
-@@ -325,9 +374,18 @@ int main(int argc, char **argv) {
+@@ -325,9 +376,18 @@ int main(int argc, char **argv) {
if (!video_only && !getosd(osd, &xres_o, &yres_o))
return 1;
@@ -147,7 +149,7 @@ index 190ff5f..c600103 100644
// get aspect ratio
if (stb_type == VULCAN || stb_type == PALLAS)
-@@ -549,6 +607,22 @@ int main(int argc, char **argv) {
+@@ -549,6 +609,22 @@ int main(int argc, char **argv) {
}
// grabing the video picture
@@ -170,7 +172,7 @@ index 190ff5f..c600103 100644
static bool getvideo(unsigned char *video, unsigned int *xres, unsigned int *yres)
{
-@@ -563,16 +637,34 @@ static bool getvideo(unsigned char *video, unsigned int *xres, unsigned int *yre
+@@ -563,16 +639,34 @@ static bool getvideo(unsigned char *video, unsigned int *xres, unsigned int *yre
perror("/dev/mem");
return false;
}
@@ -207,7 +209,7 @@ index 190ff5f..c600103 100644
unsigned char data[100];
unsigned int adr,adr2,ofs,ofs2,offset/*,vert_start,vert_end*/;
-@@ -582,12 +674,30 @@ static bool getvideo(unsigned char *video, unsigned int *xres, unsigned int *yre
+@@ -582,12 +676,30 @@ static bool getvideo(unsigned char *video, unsigned int *xres, unsigned int *yre
memcpy(data,memory,100);
//vert_start=data[0x1B]<<8|data[0x1A];
//vert_end=data[0x19]<<8|data[0x18];
@@ -238,7 +240,7 @@ index 190ff5f..c600103 100644
munmap(memory, 100);
-@@ -609,7 +719,11 @@ static bool getvideo(unsigned char *video, unsigned int *xres, unsigned int *yre
+@@ -609,7 +721,11 @@ static bool getvideo(unsigned char *video, unsigned int *xres, unsigned int *yre
assert(chroma);
// grabbing luma & chroma plane from the decoder memory
@@ -250,7 +252,7 @@ index 190ff5f..c600103 100644
// on dm800/dm500hd we have direct access to the decoder memory
memory = mmap(0, offset + stride*(ofs2+64), PROT_READ, MAP_SHARED, mem_fd, adr);
if (memory == MAP_FAILED) {
-@@ -620,7 +734,11 @@ static bool getvideo(unsigned char *video, unsigned int *xres, unsigned int *yre
+@@ -620,7 +736,11 @@ static bool getvideo(unsigned char *video, unsigned int *xres, unsigned int *yre
usleep(50000); // we try to get a full picture, its not possible to get a sync from the decoder so we use a delay
// and hope we get a good timing. dont ask me why, but every DM800 i tested so far produced a good
// result with a 50ms delay
@@ -262,7 +264,7 @@ index 190ff5f..c600103 100644
// on dm8000 we have to use dma, so dont change anything here until you really know what you are doing !
unsigned int i = 0;
-@@ -639,7 +757,11 @@ static bool getvideo(unsigned char *video, unsigned int *xres, unsigned int *yre
+@@ -639,7 +759,11 @@ static bool getvideo(unsigned char *video, unsigned int *xres, unsigned int *yre
}
volatile unsigned long *mem_dma;
@@ -274,7 +276,7 @@ index 190ff5f..c600103 100644
if (mem_dma == MAP_FAILED) {
perror("mmap");
return false;
-@@ -675,8 +797,11 @@ static bool getvideo(unsigned char *video, unsigned int *xres, unsigned int *yre
+@@ -675,8 +799,11 @@ static bool getvideo(unsigned char *video, unsigned int *xres, unsigned int *yre
unsigned int t = 0, t2 = 0, dat1 = 0;
unsigned int chr_luma_stride = 0x40;
unsigned int sw;
@@ -287,7 +289,7 @@ index 190ff5f..c600103 100644
chr_luma_stride *= 2;
xsub=chr_luma_stride;
-@@ -692,6 +817,7 @@ static bool getvideo(unsigned char *video, unsigned int *xres, unsigned int *yre
+@@ -692,6 +819,7 @@ static bool getvideo(unsigned char *video, unsigned int *xres, unsigned int *yre
for (ytmp = 0; ytmp < ofs; ytmp++)
{
memcpy(luma + dat1, memory + t, xsub); // luma
@@ -295,7 +297,7 @@ index 190ff5f..c600103 100644
t += chr_luma_stride;
switch (ofs2-ytmp) // the two switch commands are much faster than one if statement
-@@ -710,10 +836,17 @@ static bool getvideo(unsigned char *video, unsigned int *xres, unsigned int *yre
+@@ -710,10 +838,17 @@ static bool getvideo(unsigned char *video, unsigned int *xres, unsigned int *yre
dat1+=stride;
}
}
diff --git a/meta-openvuplus/recipes-vuplus/e2openplugins/enigma2-plugin-extensions-openwebif.bb b/meta-openvuplus/recipes-vuplus/e2openplugins/enigma2-plugin-extensions-openwebif.bb
index de2a1a2..b3c3f93 100644
--- a/meta-openvuplus/recipes-vuplus/e2openplugins/enigma2-plugin-extensions-openwebif.bb
+++ b/meta-openvuplus/recipes-vuplus/e2openplugins/enigma2-plugin-extensions-openwebif.bb
@@ -12,7 +12,7 @@ SRCREV_pn-${PN}="d84307958746e6a597b43defe5bd1cb78fd745c8"
inherit gitpkgv
PV = "1+git${SRCPV}"
PKGV = "1+git${GITPKGV}"
-PR = "r6"
+PR = "r9"
require openplugins-distutils.inc
@@ -26,6 +26,7 @@ SRC_URI = "git://github.com/E2OpenPlugins/e2openplugin-${MODULE}.git;protocol=gi
file://box_ultimo4k.png \
file://box_uno4kse.png \
file://box_zero4k.png \
+ file://box_duo4k.png \
"
# Just a quick hack to "compile" it
@@ -44,6 +45,7 @@ do_install_append() {
install -m 0755 ${WORKDIR}/box_ultimo4k.png ${D}${PLUGINPATH}/public/images/boxes/ultimo4k.png
install -m 0755 ${WORKDIR}/box_uno4kse.png ${D}${PLUGINPATH}/public/images/boxes/uno4kse.png
install -m 0755 ${WORKDIR}/box_zero4k.png ${D}${PLUGINPATH}/public/images/boxes/zero4k.png
+ install -m 0755 ${WORKDIR}/box_duo4k.png ${D}${PLUGINPATH}/public/images/boxes/duo4k.png
}
python do_package_prepend () {
@@ -61,6 +63,7 @@ python do_package_prepend () {
('vuultimo4k', 'ultimo4k.png', 'vu_normal.png'),
('vuuno4kse', 'uno4kse.png', 'vu_brown.png'),
('vuzero4k', 'zero4k.png', 'vu_brown.png'),
+ ('vuduo4k', 'duo4k.png', 'vu_brown.png'),
]
import os
top = '${D}${PLUGINPATH}/public/images/'
diff --git a/meta-openvuplus/recipes-vuplus/e2openplugins/files/box_duo4k.png b/meta-openvuplus/recipes-vuplus/e2openplugins/files/box_duo4k.png
new file mode 100644
index 0000000..a0d6b3e
--- /dev/null
+++ b/meta-openvuplus/recipes-vuplus/e2openplugins/files/box_duo4k.png
Binary files differ
diff --git a/meta-openvuplus/recipes-vuplus/e2openplugins/files/openwebif_support_vumodels.patch b/meta-openvuplus/recipes-vuplus/e2openplugins/files/openwebif_support_vumodels.patch
index b7726fe..a4ef179 100644
--- a/meta-openvuplus/recipes-vuplus/e2openplugins/files/openwebif_support_vumodels.patch
+++ b/meta-openvuplus/recipes-vuplus/e2openplugins/files/openwebif_support_vumodels.patch
@@ -7,7 +7,7 @@ index 446a97c..8e0e0f6 100644
info['transcoding'] = False
- if (info['model'] in ("Solo²", "Duo²", "Solo SE", "Quad", "Quad Plus") or info['machinebuild'] in ('inihdp', 'hd2400', 'et10000', 'xpeedlx3', 'ew7356', 'dags3', 'dags4')):
-+ if (info['model'] in ("Uno4Kse", "Uno4K", "Ultimo4K", "Solo4K", "Solo²", "Duo²", "Solo SE", "Quad", "Quad Plus") or info['machinebuild'] in ('inihdp', 'hd2400', 'et10000', 'xpeedlx3', 'ew7356', 'dags3', 'dags4')):
++ if (info['model'] in ("Duo4K", "Uno4Kse", "Uno4K", "Ultimo4K", "Solo4K", "Solo²", "Duo²", "Solo SE", "Quad", "Quad Plus") or info['machinebuild'] in ('inihdp', 'hd2400', 'et10000', 'xpeedlx3', 'ew7356', 'dags3', 'dags4')):
if os.path.exists(eEnv.resolve('${libdir}/enigma2/python/Plugins/SystemPlugins/TransCodingSetup/plugin.pyo')) or os.path.exists(eEnv.resolve('${libdir}/enigma2/python/Plugins/SystemPlugins/TranscodingSetup/plugin.pyo')) or os.path.exists(eEnv.resolve('${libdir}/enigma2/python/Plugins/SystemPlugins/MultiTransCodingSetup/plugin.pyo')):
info['transcoding'] = True
@@ -20,7 +20,7 @@ index cb33277..d75ca6f 100644
transcoder_port = None
args = ""
- if model in ("Solo²", "Duo²", "Solo SE", "Quad", "Quad Plus") or machinebuild in ('dags3', 'dags4'):
-+ if model in ("Uno4Kse", "Uno4K", "Ultimo4K", "Solo4K", "Solo²", "Duo²", "Solo SE", "Quad", "Quad Plus") or machinebuild in ('dags3', 'dags4'):
++ if model in ("Duo4K", "Uno4Kse", "Uno4K", "Ultimo4K", "Solo4K", "Solo²", "Duo²", "Solo SE", "Quad", "Quad Plus") or machinebuild in ('dags3', 'dags4'):
try:
transcoder_port = int(config.plugins.transcodingsetup.port.value)
except StandardError:
diff --git a/meta-openvuplus/recipes-vuplus/e2openplugins/files/openwebif_vu_box_remote.patch b/meta-openvuplus/recipes-vuplus/e2openplugins/files/openwebif_vu_box_remote.patch
index 996793e..315022a 100644
--- a/meta-openvuplus/recipes-vuplus/e2openplugins/files/openwebif_vu_box_remote.patch
+++ b/meta-openvuplus/recipes-vuplus/e2openplugins/files/openwebif_vu_box_remote.patch
@@ -21,7 +21,7 @@ index 9b8f1e5..4bbf6fb 100644
remote = "vu_duo2"
elif procmodel == "ultimo":
remote = "vu_ultimo"
-+ elif procmodel in ("uno4kse", "zero4k"):
++ elif procmodel in ("uno4kse", "zero4k", "duo4k"):
+ remote = "vu_brown"
elif procmodel == "e3hd":
remote = "e3hd"
diff --git a/meta-openvuplus/recipes-vuplus/enigma2/enigma2-transtreamproxy.bb b/meta-openvuplus/recipes-vuplus/enigma2/enigma2-transtreamproxy.bb
index 41765a5..6d8764b 100644
--- a/meta-openvuplus/recipes-vuplus/enigma2/enigma2-transtreamproxy.bb
+++ b/meta-openvuplus/recipes-vuplus/enigma2/enigma2-transtreamproxy.bb
@@ -21,6 +21,7 @@ EXTRA_OECONF_vusolo4k += " --enable-ext-pid "
EXTRA_OECONF_vuultimo4k += " --enable-ext-pid "
EXTRA_OECONF_vuuno4k += " --enable-ext-pid "
EXTRA_OECONF_vuuno4kse += " --enable-ext-pid "
+EXTRA_OECONF_vuduo4k += " --enable-ext-pid "
S = "${WORKDIR}/git"
diff --git a/meta-openvuplus/recipes-vuplus/packagegroups/packagegroup-vuplus-base.bb b/meta-openvuplus/recipes-vuplus/packagegroups/packagegroup-vuplus-base.bb
index 90f7e00..601bfac 100644
--- a/meta-openvuplus/recipes-vuplus/packagegroups/packagegroup-vuplus-base.bb
+++ b/meta-openvuplus/recipes-vuplus/packagegroups/packagegroup-vuplus-base.bb
@@ -2,7 +2,7 @@ SUMMARY = "Vuplus: Base set of packages for Vuplus."
SECTION = "vuplus/base"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
-PR = "r7"
+PR = "r10"
inherit packagegroup
@@ -66,6 +66,7 @@ VUPLUS_BASE_RECOMMENDS = "\
${@base_contains("VUPLUS_FEATURES", "vuplus-fpga-update", "vuplus-fpga-update", "", d)} \
${@base_contains("VUPLUS_FEATURES", "wol", "vuplus-coldboot", "", d)} \
${@base_contains("VUPLUS_FEATURES", "wowl", "vuplus-wowl", "", d)} \
+ bash \
"
VUPLUS_BASE_OPTIONAL_RECOMMENDS = "\
diff --git a/meta-openvuplus/recipes-vuplus/packagegroups/packagegroup-vuplus-enigma2.bb b/meta-openvuplus/recipes-vuplus/packagegroups/packagegroup-vuplus-enigma2.bb
index 8251abd..6dd087b 100644
--- a/meta-openvuplus/recipes-vuplus/packagegroups/packagegroup-vuplus-enigma2.bb
+++ b/meta-openvuplus/recipes-vuplus/packagegroups/packagegroup-vuplus-enigma2.bb
@@ -2,7 +2,7 @@ SUMMARY = "Enigma2 set of packages for Vuplus"
SECTION = "vuplus/base"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
-PR = "r23"
+PR = "r27"
PACKAGE_ARCH = "${MACHINE_ARCH}"