summaryrefslogtreecommitdiff
path: root/meta-openvuplus
diff options
context:
space:
mode:
authorhschang <chang@dev3>2017-11-02 06:37:42 (GMT)
committerhschang <chang@dev3>2017-11-03 05:28:56 (GMT)
commit97ad97c7f392918c70271958d570660295fd0376 (patch)
tree6a667bc603a98d4bebf4401d92b89e83022d7c88 /meta-openvuplus
parentc9edee525f366bd90113272d2618e16ed5c471aa (diff)
Support Uno4kSE
Diffstat (limited to 'meta-openvuplus')
-rw-r--r--meta-openvuplus/recipes-connectivity/packagegroups/packagegroup-vuplus-wlan.bb2
-rw-r--r--meta-openvuplus/recipes-connectivity/realtek/r8192cu-4.0.2.9000.20130911/strnicmp_error_patch.diff13
-rw-r--r--meta-openvuplus/recipes-connectivity/realtek/r8192cu_4.0.2.9000.20130911.bb1
-rwxr-xr-xmeta-openvuplus/recipes-vuplus/aio-grab/aio-grab.bb4
-rw-r--r--meta-openvuplus/recipes-vuplus/aio-grab/aio-grab/aio-grab_vuplus_6706273e6987e54e4dace15936a2cfd4e8c8c41c.patch (renamed from meta-openvuplus/recipes-vuplus/aio-grab/aio-grab/aio-grab_vuplus_03b822d1c72c30ba2ce55f8b584be419447dca03.patch)28
-rw-r--r--meta-openvuplus/recipes-vuplus/e2openplugins/enigma2-plugin-extensions-openwebif.bb5
-rw-r--r--meta-openvuplus/recipes-vuplus/e2openplugins/files/openwebif_support_vumodels.patch (renamed from meta-openvuplus/recipes-vuplus/e2openplugins/files/openwebif_solo4k.patch)4
-rw-r--r--meta-openvuplus/recipes-vuplus/enigma2/enigma2-transtreamproxy.bb1
-rw-r--r--meta-openvuplus/recipes-vuplus/enigma2/enigma2.bb2
-rw-r--r--meta-openvuplus/recipes-vuplus/vuplus-3gcommand/vuplus-3gcommand.bb6
-rw-r--r--meta-openvuplus/recipes-vuplus/vuplus-dlnaserver/vuplus-dlnaserver.bb6
11 files changed, 45 insertions, 27 deletions
diff --git a/meta-openvuplus/recipes-connectivity/packagegroups/packagegroup-vuplus-wlan.bb b/meta-openvuplus/recipes-connectivity/packagegroups/packagegroup-vuplus-wlan.bb
index 01de7d1..8875b03 100644
--- a/meta-openvuplus/recipes-connectivity/packagegroups/packagegroup-vuplus-wlan.bb
+++ b/meta-openvuplus/recipes-connectivity/packagegroups/packagegroup-vuplus-wlan.bb
@@ -32,7 +32,6 @@ KERNEL_WIFI_MODULES = " \
kernel-module-rt2500usb \
kernel-module-rtl8187 \
kernel-module-r8712u \
- kernel-module-w35und \
kernel-module-zd1211rw \
kernel-module-llc \
kernel-module-stp \
@@ -42,6 +41,7 @@ KERNEL_WIFI_MODULES = " \
"
KERNEL_WIFI_MODULES += "${@base_version_less_or_equal('VUPLUS_KERNEL_VERSION', '3.1.1', 'kernel-module-r8192u-usb', '', d)}"
+KERNEL_WIFI_MODULES += "${@base_version_less_or_equal('VUPLUS_KERNEL_VERSION', '3.14.28', 'kernel-module-w35und', '', d)}"
LEGACY_MODULES = " \
r8192cu \
diff --git a/meta-openvuplus/recipes-connectivity/realtek/r8192cu-4.0.2.9000.20130911/strnicmp_error_patch.diff b/meta-openvuplus/recipes-connectivity/realtek/r8192cu-4.0.2.9000.20130911/strnicmp_error_patch.diff
new file mode 100644
index 0000000..97a773e
--- /dev/null
+++ b/meta-openvuplus/recipes-connectivity/realtek/r8192cu-4.0.2.9000.20130911/strnicmp_error_patch.diff
@@ -0,0 +1,13 @@
+diff --git a/os_dep/linux/rtw_android.c b/os_dep/linux/rtw_android.c
+index a4bb073..d6ac16c 100755
+--- a/os_dep/linux/rtw_android.c
++++ b/os_dep/linux/rtw_android.c
+@@ -230,7 +230,7 @@ int rtw_android_cmdstr_to_num(char *cmdstr)
+ {
+ int cmd_num;
+ for(cmd_num=0 ; cmd_num<ANDROID_WIFI_CMD_MAX; cmd_num++)
+- if(0 == strnicmp(cmdstr , android_wifi_cmd_str[cmd_num], strlen(android_wifi_cmd_str[cmd_num])) )
++ if(0 == strncasecmp(cmdstr , android_wifi_cmd_str[cmd_num], strlen(android_wifi_cmd_str[cmd_num])) )
+ break;
+
+ return cmd_num;
diff --git a/meta-openvuplus/recipes-connectivity/realtek/r8192cu_4.0.2.9000.20130911.bb b/meta-openvuplus/recipes-connectivity/realtek/r8192cu_4.0.2.9000.20130911.bb
index e5a8559..b135f03 100644
--- a/meta-openvuplus/recipes-connectivity/realtek/r8192cu_4.0.2.9000.20130911.bb
+++ b/meta-openvuplus/recipes-connectivity/realtek/r8192cu_4.0.2.9000.20130911.bb
@@ -7,6 +7,7 @@ LIC_FILES_CHKSUM = "file://os_dep/linux/os_intfs.c;endline=19;md5=72c75de415f1e8
SRC_URI = " \
file://rtl8188C_8192C_usb_linux_v4.0.2_9000.20130911.tar.gz \
file://r8192cu_remove_debug.patch \
+ file://strnicmp_error_patch.diff \
"
S = "${WORKDIR}/rtl8188C_8192C_usb_linux_v4.0.2_9000.20130911"
diff --git a/meta-openvuplus/recipes-vuplus/aio-grab/aio-grab.bb b/meta-openvuplus/recipes-vuplus/aio-grab/aio-grab.bb
index 8f2bc3b..27e0a05 100755
--- a/meta-openvuplus/recipes-vuplus/aio-grab/aio-grab.bb
+++ b/meta-openvuplus/recipes-vuplus/aio-grab/aio-grab.bb
@@ -2,13 +2,13 @@ SUMMARY = "Screen grabber for Set-Top-Boxes"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://LICENSE;md5=94d55d512a9ba36caa9b7df079bae19f"
SRCREV = "8394e1ba98c73d7c56d3235ef16cce253dc597cd"
-PR = "r3"
+PR = "r4"
DEPENDS = "jpeg libpng"
SRC_URI = " \
git://schwerkraft.elitedvb.net/aio-grab/aio-grab.git;protocol=git;tag=${SRCREV} \
- file://aio-grab_vuplus_03b822d1c72c30ba2ce55f8b584be419447dca03.patch;striplevel=1 \
+ file://aio-grab_vuplus_6706273e6987e54e4dace15936a2cfd4e8c8c41c.patch;striplevel=1 \
"
S = "${WORKDIR}/git"
diff --git a/meta-openvuplus/recipes-vuplus/aio-grab/aio-grab/aio-grab_vuplus_03b822d1c72c30ba2ce55f8b584be419447dca03.patch b/meta-openvuplus/recipes-vuplus/aio-grab/aio-grab/aio-grab_vuplus_6706273e6987e54e4dace15936a2cfd4e8c8c41c.patch
index 48887ae..8d7bc10 100644
--- a/meta-openvuplus/recipes-vuplus/aio-grab/aio-grab/aio-grab_vuplus_03b822d1c72c30ba2ce55f8b584be419447dca03.patch
+++ b/meta-openvuplus/recipes-vuplus/aio-grab/aio-grab/aio-grab_vuplus_6706273e6987e54e4dace15936a2cfd4e8c8c41c.patch
@@ -8,7 +8,7 @@ index ccfb515..a6f8d11 100644
stamp-h1
+aio-grab_vuplus_*
diff --git a/main.c b/main.c
-index 190ff5f..a4df66f 100644
+index 190ff5f..c600103 100644
--- a/main.c
+++ b/main.c
@@ -1,5 +1,5 @@
@@ -72,7 +72,7 @@ index 190ff5f..a4df66f 100644
unsigned int xres_v = 0,yres_v = 0,xres_o,yres_o,xres,yres,aspect,width;
int c,osd_only,video_only,use_osd_res,use_png,use_jpg,jpg_quality,no_aspect,use_letterbox;
-@@ -205,11 +221,41 @@ int main(int argc, char **argv) {
+@@ -205,11 +221,43 @@ int main(int argc, char **argv) {
char filename[256] = { "/tmp/screenshot.bmp" };
// detect STB
@@ -111,11 +111,13 @@ index 190ff5f..a4df66f 100644
+ stb_type=BRCM_ARM;
+ else if (strstr(upcase(line),"7252"))
+ stb_type=BRCM_ARM;
++ else if (strstr(upcase(line),"7260"))
++ stb_type=BRCM_ARM;
+#else
line = file_getline("/proc/stb/info/model");
if (line == NULL)
return 1;
-@@ -221,6 +267,7 @@ int main(int argc, char **argv) {
+@@ -221,6 +269,7 @@ int main(int argc, char **argv) {
!strcmp(line, "dm800se") ||
!strcmp(line, "dm7020hd"))
stb_type = BRCM7405;
@@ -123,7 +125,7 @@ index 190ff5f..a4df66f 100644
} else if (strstr(line, "xilleonfb")) {
stb_type = XILLEON;
} else if (strstr(line, "Pallas FB")) {
-@@ -325,9 +372,18 @@ int main(int argc, char **argv) {
+@@ -325,9 +374,18 @@ int main(int argc, char **argv) {
if (!video_only && !getosd(osd, &xres_o, &yres_o))
return 1;
@@ -145,7 +147,7 @@ index 190ff5f..a4df66f 100644
// get aspect ratio
if (stb_type == VULCAN || stb_type == PALLAS)
-@@ -549,6 +605,22 @@ int main(int argc, char **argv) {
+@@ -549,6 +607,22 @@ int main(int argc, char **argv) {
}
// grabing the video picture
@@ -168,7 +170,7 @@ index 190ff5f..a4df66f 100644
static bool getvideo(unsigned char *video, unsigned int *xres, unsigned int *yres)
{
-@@ -563,16 +635,34 @@ static bool getvideo(unsigned char *video, unsigned int *xres, unsigned int *yre
+@@ -563,16 +637,34 @@ static bool getvideo(unsigned char *video, unsigned int *xres, unsigned int *yre
perror("/dev/mem");
return false;
}
@@ -205,7 +207,7 @@ index 190ff5f..a4df66f 100644
unsigned char data[100];
unsigned int adr,adr2,ofs,ofs2,offset/*,vert_start,vert_end*/;
-@@ -582,12 +672,30 @@ static bool getvideo(unsigned char *video, unsigned int *xres, unsigned int *yre
+@@ -582,12 +674,30 @@ static bool getvideo(unsigned char *video, unsigned int *xres, unsigned int *yre
memcpy(data,memory,100);
//vert_start=data[0x1B]<<8|data[0x1A];
//vert_end=data[0x19]<<8|data[0x18];
@@ -236,7 +238,7 @@ index 190ff5f..a4df66f 100644
munmap(memory, 100);
-@@ -609,7 +717,11 @@ static bool getvideo(unsigned char *video, unsigned int *xres, unsigned int *yre
+@@ -609,7 +719,11 @@ static bool getvideo(unsigned char *video, unsigned int *xres, unsigned int *yre
assert(chroma);
// grabbing luma & chroma plane from the decoder memory
@@ -248,7 +250,7 @@ index 190ff5f..a4df66f 100644
// on dm800/dm500hd we have direct access to the decoder memory
memory = mmap(0, offset + stride*(ofs2+64), PROT_READ, MAP_SHARED, mem_fd, adr);
if (memory == MAP_FAILED) {
-@@ -620,7 +732,11 @@ static bool getvideo(unsigned char *video, unsigned int *xres, unsigned int *yre
+@@ -620,7 +734,11 @@ static bool getvideo(unsigned char *video, unsigned int *xres, unsigned int *yre
usleep(50000); // we try to get a full picture, its not possible to get a sync from the decoder so we use a delay
// and hope we get a good timing. dont ask me why, but every DM800 i tested so far produced a good
// result with a 50ms delay
@@ -260,7 +262,7 @@ index 190ff5f..a4df66f 100644
// on dm8000 we have to use dma, so dont change anything here until you really know what you are doing !
unsigned int i = 0;
-@@ -639,7 +755,11 @@ static bool getvideo(unsigned char *video, unsigned int *xres, unsigned int *yre
+@@ -639,7 +757,11 @@ static bool getvideo(unsigned char *video, unsigned int *xres, unsigned int *yre
}
volatile unsigned long *mem_dma;
@@ -272,7 +274,7 @@ index 190ff5f..a4df66f 100644
if (mem_dma == MAP_FAILED) {
perror("mmap");
return false;
-@@ -675,8 +795,11 @@ static bool getvideo(unsigned char *video, unsigned int *xres, unsigned int *yre
+@@ -675,8 +797,11 @@ static bool getvideo(unsigned char *video, unsigned int *xres, unsigned int *yre
unsigned int t = 0, t2 = 0, dat1 = 0;
unsigned int chr_luma_stride = 0x40;
unsigned int sw;
@@ -285,7 +287,7 @@ index 190ff5f..a4df66f 100644
chr_luma_stride *= 2;
xsub=chr_luma_stride;
-@@ -692,6 +815,7 @@ static bool getvideo(unsigned char *video, unsigned int *xres, unsigned int *yre
+@@ -692,6 +817,7 @@ static bool getvideo(unsigned char *video, unsigned int *xres, unsigned int *yre
for (ytmp = 0; ytmp < ofs; ytmp++)
{
memcpy(luma + dat1, memory + t, xsub); // luma
@@ -293,7 +295,7 @@ index 190ff5f..a4df66f 100644
t += chr_luma_stride;
switch (ofs2-ytmp) // the two switch commands are much faster than one if statement
-@@ -710,10 +834,17 @@ static bool getvideo(unsigned char *video, unsigned int *xres, unsigned int *yre
+@@ -710,10 +836,17 @@ static bool getvideo(unsigned char *video, unsigned int *xres, unsigned int *yre
dat1+=stride;
}
}
diff --git a/meta-openvuplus/recipes-vuplus/e2openplugins/enigma2-plugin-extensions-openwebif.bb b/meta-openvuplus/recipes-vuplus/e2openplugins/enigma2-plugin-extensions-openwebif.bb
index 3671b9f..82784f1 100644
--- a/meta-openvuplus/recipes-vuplus/e2openplugins/enigma2-plugin-extensions-openwebif.bb
+++ b/meta-openvuplus/recipes-vuplus/e2openplugins/enigma2-plugin-extensions-openwebif.bb
@@ -12,11 +12,11 @@ SRCREV_pn-${PN}="d84307958746e6a597b43defe5bd1cb78fd745c8"
inherit gitpkgv
PV = "1+git${SRCPV}"
PKGV = "1+git${GITPKGV}"
-PR = "r4"
+PR = "r5"
require openplugins-distutils.inc
-SRC_URI += " file://openwebif_solo4k.patch;striplevel=1 "
+SRC_URI += " file://openwebif_support_vumodels.patch"
SRC_URI += " file://openwebif_block_in_qpip.patch"
# Just a quick hack to "compile" it
@@ -43,6 +43,7 @@ python do_package_prepend () {
('vuuno', 'uno.jpg', 'vu_normal.png'),
('vuultimo4k', 'unknown.jpg', 'vu_normal.png'),
('vuuno4k', 'unknown.jpg', 'vu_normal.png'),
+ ('vuuno4kse', 'unknown.jpg', 'vu_normal.png'),
]
import os
top = '${D}${PLUGINPATH}/public/images/'
diff --git a/meta-openvuplus/recipes-vuplus/e2openplugins/files/openwebif_solo4k.patch b/meta-openvuplus/recipes-vuplus/e2openplugins/files/openwebif_support_vumodels.patch
index 81afa5f..b7726fe 100644
--- a/meta-openvuplus/recipes-vuplus/e2openplugins/files/openwebif_solo4k.patch
+++ b/meta-openvuplus/recipes-vuplus/e2openplugins/files/openwebif_support_vumodels.patch
@@ -7,7 +7,7 @@ index 446a97c..8e0e0f6 100644
info['transcoding'] = False
- if (info['model'] in ("Solo²", "Duo²", "Solo SE", "Quad", "Quad Plus") or info['machinebuild'] in ('inihdp', 'hd2400', 'et10000', 'xpeedlx3', 'ew7356', 'dags3', 'dags4')):
-+ if (info['model'] in ("Uno4K", "Ultimo4K", "Solo4K", "Solo²", "Duo²", "Solo SE", "Quad", "Quad Plus") or info['machinebuild'] in ('inihdp', 'hd2400', 'et10000', 'xpeedlx3', 'ew7356', 'dags3', 'dags4')):
++ if (info['model'] in ("Uno4Kse", "Uno4K", "Ultimo4K", "Solo4K", "Solo²", "Duo²", "Solo SE", "Quad", "Quad Plus") or info['machinebuild'] in ('inihdp', 'hd2400', 'et10000', 'xpeedlx3', 'ew7356', 'dags3', 'dags4')):
if os.path.exists(eEnv.resolve('${libdir}/enigma2/python/Plugins/SystemPlugins/TransCodingSetup/plugin.pyo')) or os.path.exists(eEnv.resolve('${libdir}/enigma2/python/Plugins/SystemPlugins/TranscodingSetup/plugin.pyo')) or os.path.exists(eEnv.resolve('${libdir}/enigma2/python/Plugins/SystemPlugins/MultiTransCodingSetup/plugin.pyo')):
info['transcoding'] = True
@@ -20,7 +20,7 @@ index cb33277..d75ca6f 100644
transcoder_port = None
args = ""
- if model in ("Solo²", "Duo²", "Solo SE", "Quad", "Quad Plus") or machinebuild in ('dags3', 'dags4'):
-+ if model in ("Uno4K", "Ultimo4K", "Solo4K", "Solo²", "Duo²", "Solo SE", "Quad", "Quad Plus") or machinebuild in ('dags3', 'dags4'):
++ if model in ("Uno4Kse", "Uno4K", "Ultimo4K", "Solo4K", "Solo²", "Duo²", "Solo SE", "Quad", "Quad Plus") or machinebuild in ('dags3', 'dags4'):
try:
transcoder_port = int(config.plugins.transcodingsetup.port.value)
except StandardError:
diff --git a/meta-openvuplus/recipes-vuplus/enigma2/enigma2-transtreamproxy.bb b/meta-openvuplus/recipes-vuplus/enigma2/enigma2-transtreamproxy.bb
index 9b65f4d..41765a5 100644
--- a/meta-openvuplus/recipes-vuplus/enigma2/enigma2-transtreamproxy.bb
+++ b/meta-openvuplus/recipes-vuplus/enigma2/enigma2-transtreamproxy.bb
@@ -20,6 +20,7 @@ inherit autotools-brokensep
EXTRA_OECONF_vusolo4k += " --enable-ext-pid "
EXTRA_OECONF_vuultimo4k += " --enable-ext-pid "
EXTRA_OECONF_vuuno4k += " --enable-ext-pid "
+EXTRA_OECONF_vuuno4kse += " --enable-ext-pid "
S = "${WORKDIR}/git"
diff --git a/meta-openvuplus/recipes-vuplus/enigma2/enigma2.bb b/meta-openvuplus/recipes-vuplus/enigma2/enigma2.bb
index ca49970..c660eb1 100644
--- a/meta-openvuplus/recipes-vuplus/enigma2/enigma2.bb
+++ b/meta-openvuplus/recipes-vuplus/enigma2/enigma2.bb
@@ -231,7 +231,7 @@ DEPENDS += "${@base_contains("VUPLUS_FEATURES", "uianimation", "libgles libvugle
RDEPENDS_${PN}_append_vuplus += "${@base_contains("VUPLUS_FEATURES", "uianimation", "libvugles2" , "", d)}"
PN = "enigma2"
-PR = "r159"
+PR = "r165"
inherit gitpkgv pythonnative
diff --git a/meta-openvuplus/recipes-vuplus/vuplus-3gcommand/vuplus-3gcommand.bb b/meta-openvuplus/recipes-vuplus/vuplus-3gcommand/vuplus-3gcommand.bb
index d1d76b3..bbfe00b 100644
--- a/meta-openvuplus/recipes-vuplus/vuplus-3gcommand/vuplus-3gcommand.bb
+++ b/meta-openvuplus/recipes-vuplus/vuplus-3gcommand/vuplus-3gcommand.bb
@@ -3,7 +3,7 @@ MAINTAINER = "vuplus team"
LICENSE = "CLOSED"
require conf/license/license-close.inc
-PV = "1.1"
+PV = "1.2"
PR = "r1"
SRC_URI = "http://archive.vuplus.com/download/utils/vuplus-3gcommand-${PV}.tar.gz"
@@ -24,6 +24,6 @@ FILES_${PN} = "/"
do_populate_sysroot[noexec] = "1"
INSANE_SKIP_${PN} = "already-stripped"
-SRC_URI[md5sum] = "cc5bf83dcb28da14e84557ec7ce42809"
-SRC_URI[sha256sum] = "1f6e98abe2a56a2091e576a0b57dcf27f06173aada60726640c97028a4a3871c"
+SRC_URI[md5sum] = "f6a4be1ebfa405918ac5b645f7ff7d6d"
+SRC_URI[sha256sum] = "e37a6aaf2e9853326986aa8ab7cc28df17200e0a2cd1ec3f21e59b9483c73485"
diff --git a/meta-openvuplus/recipes-vuplus/vuplus-dlnaserver/vuplus-dlnaserver.bb b/meta-openvuplus/recipes-vuplus/vuplus-dlnaserver/vuplus-dlnaserver.bb
index e9e9476..9a3e9a6 100644
--- a/meta-openvuplus/recipes-vuplus/vuplus-dlnaserver/vuplus-dlnaserver.bb
+++ b/meta-openvuplus/recipes-vuplus/vuplus-dlnaserver/vuplus-dlnaserver.bb
@@ -3,7 +3,7 @@ MAINTAINER = "vuplus team"
LICENSE = "CLOSED"
require conf/license/license-close.inc
-PV = "1.1"
+PV = "1.2"
PR = "r1"
SRC_URI = "http://archive.vuplus.com/download/utils/vuplus-dlnaserver-${PV}.tar.gz"
@@ -24,6 +24,6 @@ FILES_${PN} = "/"
do_populate_sysroot[noexec] = "1"
INSANE_SKIP_${PN} = "already-stripped"
-SRC_URI[md5sum] = "6b07e98fe748e85cd846e37449bf8d90"
-SRC_URI[sha256sum] = "26576e1723187fd7c0fed134dae9b6f1a109c9651bc5a0ec974234a0189d5f32"
+SRC_URI[md5sum] = "215a700d00172a1637c2e9269b1c54ca"
+SRC_URI[sha256sum] = "a73d83303b09fab93e53108fd93c8cfaa9011d3e3e564804d319e351ba1df985"