summaryrefslogtreecommitdiff
path: root/meta-openvuplus
diff options
context:
space:
mode:
authorsmlee <smlee@dev3>2018-05-02 02:04:49 (GMT)
committersmlee <smlee@dev3>2018-05-02 02:09:26 (GMT)
commit70cdfec95680f59459274eb3116db4e5d180f3c1 (patch)
treefcd0b0a39187af56d159651def098441711f3f79 /meta-openvuplus
parent9f53a7227f283bd87f5a02a7cdebd68a5e426a90 (diff)
[libvupl] added.
- libvupl is Vu+ API for EGL/OpenGLES. - libvupl-example-cube is simple example using libvupl based https://code.google.com/archive/p/opengles-book-samples. - enigma2-plugin-demoplugins-libvupldemo is launcher of cube demo.
Diffstat (limited to 'meta-openvuplus')
-rw-r--r--meta-openvuplus/recipes-extended/libvupl-examples/enigma2-plugin-demoplugins-libvupldemo.bb26
-rw-r--r--meta-openvuplus/recipes-extended/libvupl-examples/libvupl-example-cube_0.2.0.bb26
2 files changed, 52 insertions, 0 deletions
diff --git a/meta-openvuplus/recipes-extended/libvupl-examples/enigma2-plugin-demoplugins-libvupldemo.bb b/meta-openvuplus/recipes-extended/libvupl-examples/enigma2-plugin-demoplugins-libvupldemo.bb
new file mode 100644
index 0000000..a6590db
--- /dev/null
+++ b/meta-openvuplus/recipes-extended/libvupl-examples/enigma2-plugin-demoplugins-libvupldemo.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "Plugin for libvupl Demo"
+SECTION = "devel"
+LICENSE = "CLOSED"
+require conf/license/license-close.inc
+
+PR = "r1"
+
+RDEPENDS_${PN} = "libvupl-example-cube"
+
+SRC_URI = "http://archive.vuplus.com/download/build_support/${PN}.${PR}.tar.gz"
+
+do_install_append() {
+ install -d ${D}/usr/lib/enigma2/python/Plugins/DemoPlugins/libvupldemo
+ install -m 0644 ${WORKDIR}/${PN}/* ${D}/usr/lib/enigma2/python/Plugins/DemoPlugins/libvupldemo/
+}
+
+do_package_qa() {
+}
+
+PROVIDES += "enigma2-plugin-demoplugins-libvupldemo"
+RPROVIDES_${PN} += "enigma2-plugin-demoplugins-libvupldemo"
+
+FILES_${PN} = "/"
+
+SRC_URI[md5sum] = "5f3a250fd3d2e9bde34f4e3fea265006"
+SRC_URI[sha256sum] = "160e98a21cc161fac7d977000e4b2eb350993ea8abeadca5824ecfd34962f0fe"
diff --git a/meta-openvuplus/recipes-extended/libvupl-examples/libvupl-example-cube_0.2.0.bb b/meta-openvuplus/recipes-extended/libvupl-examples/libvupl-example-cube_0.2.0.bb
new file mode 100644
index 0000000..2b5dde5
--- /dev/null
+++ b/meta-openvuplus/recipes-extended/libvupl-examples/libvupl-example-cube_0.2.0.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "Cube Demo example for libvupl"
+SECTION = "devel"
+HOMEPAGE = "https://code.google.com/archive/p/opengles-book-samples/"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=7c01ce978e205f99897d26c061b2c09a"
+
+PR = "r1"
+
+DEPENDS = "libvupl libgles"
+RDEPENDS_${PN} = "libvupl libgles"
+
+SRC_URI = "http://archive.vuplus.com/download/build_support/${PN}-${PV}.${PR}.tar.gz"
+
+S = "${WORKDIR}/${PN}-${PV}"
+
+EXTRA_OECMAKE += "-DVUPLUS=1"
+
+inherit cmake
+
+do_install() {
+ install -d ${D}/usr/bin
+ install -m 0755 ${WORKDIR}/build/Simple_VertexShader/Simple_VertexShader ${D}/usr/bin/cube
+}
+
+SRC_URI[md5sum] = "fe812abfc9c52ed26c4aa7192f94fe03"
+SRC_URI[sha256sum] = "0cc58ec3d6d0d1be358e805268fa29704dde6fceeace8bc60d001bb63dac26ee"