summaryrefslogtreecommitdiff
path: root/meta-openvuplus/recipes-vuplus/e2openplugins
diff options
context:
space:
mode:
authorhschang <chang@dev3>2017-11-27 02:32:34 (GMT)
committerhschang <chang@dev3>2017-11-27 06:59:50 (GMT)
commit8e86621a63f8dc359eb63fe927c75c5158ee9c38 (patch)
tree47524bdaf54d50e8661ab71d58995d7d9263bc58 /meta-openvuplus/recipes-vuplus/e2openplugins
parentc3e542a8e06411e3e58a735970043e53c24315af (diff)
Support zero4k.
Diffstat (limited to 'meta-openvuplus/recipes-vuplus/e2openplugins')
-rw-r--r--meta-openvuplus/recipes-vuplus/e2openplugins/enigma2-plugin-extensions-openwebif.bb3
-rw-r--r--meta-openvuplus/recipes-vuplus/e2openplugins/files/box_zero4k.pngbin0 -> 14790 bytes
-rw-r--r--meta-openvuplus/recipes-vuplus/e2openplugins/files/openwebif_vu_box_remote.patch6
3 files changed, 6 insertions, 3 deletions
diff --git a/meta-openvuplus/recipes-vuplus/e2openplugins/enigma2-plugin-extensions-openwebif.bb b/meta-openvuplus/recipes-vuplus/e2openplugins/enigma2-plugin-extensions-openwebif.bb
index f3d3eb7..de2a1a2 100644
--- a/meta-openvuplus/recipes-vuplus/e2openplugins/enigma2-plugin-extensions-openwebif.bb
+++ b/meta-openvuplus/recipes-vuplus/e2openplugins/enigma2-plugin-extensions-openwebif.bb
@@ -25,6 +25,7 @@ SRC_URI = "git://github.com/E2OpenPlugins/e2openplugin-${MODULE}.git;protocol=gi
file://box_uno4k.png \
file://box_ultimo4k.png \
file://box_uno4kse.png \
+ file://box_zero4k.png \
"
# Just a quick hack to "compile" it
@@ -42,6 +43,7 @@ do_install_append() {
install -m 0755 ${WORKDIR}/box_uno4k.png ${D}${PLUGINPATH}/public/images/boxes/uno4k.png
install -m 0755 ${WORKDIR}/box_ultimo4k.png ${D}${PLUGINPATH}/public/images/boxes/ultimo4k.png
install -m 0755 ${WORKDIR}/box_uno4kse.png ${D}${PLUGINPATH}/public/images/boxes/uno4kse.png
+ install -m 0755 ${WORKDIR}/box_zero4k.png ${D}${PLUGINPATH}/public/images/boxes/zero4k.png
}
python do_package_prepend () {
@@ -58,6 +60,7 @@ python do_package_prepend () {
('vuuno4k', 'uno4k.png', 'vu_normal.png'),
('vuultimo4k', 'ultimo4k.png', 'vu_normal.png'),
('vuuno4kse', 'uno4kse.png', 'vu_brown.png'),
+ ('vuzero4k', 'zero4k.png', 'vu_brown.png'),
]
import os
top = '${D}${PLUGINPATH}/public/images/'
diff --git a/meta-openvuplus/recipes-vuplus/e2openplugins/files/box_zero4k.png b/meta-openvuplus/recipes-vuplus/e2openplugins/files/box_zero4k.png
new file mode 100644
index 0000000..07518e7
--- /dev/null
+++ b/meta-openvuplus/recipes-vuplus/e2openplugins/files/box_zero4k.png
Binary files differ
diff --git a/meta-openvuplus/recipes-vuplus/e2openplugins/files/openwebif_vu_box_remote.patch b/meta-openvuplus/recipes-vuplus/e2openplugins/files/openwebif_vu_box_remote.patch
index 270d8d5..996793e 100644
--- a/meta-openvuplus/recipes-vuplus/e2openplugins/files/openwebif_vu_box_remote.patch
+++ b/meta-openvuplus/recipes-vuplus/e2openplugins/files/openwebif_vu_box_remote.patch
@@ -14,21 +14,21 @@ index 9add982..da2be4a 100644
else:
info["boximage"] = "unknown.jpg"
diff --git a/plugin/controllers/models/owibranding.py b/plugin/controllers/models/owibranding.py
-index 9b8f1e5..835cee5 100644
+index 9b8f1e5..4bbf6fb 100644
--- a/plugin/controllers/models/owibranding.py
+++ b/plugin/controllers/models/owibranding.py
@@ -277,6 +277,8 @@ def getAllInfo():
remote = "vu_duo2"
elif procmodel == "ultimo":
remote = "vu_ultimo"
-+ elif procmodel == "uno4kse":
++ elif procmodel in ("uno4kse", "zero4k"):
+ remote = "vu_brown"
elif procmodel == "e3hd":
remote = "e3hd"
elif procmodel in ("et9x00", "et9000", "et9200", "et9500"):
diff --git a/plugin/public/static/remotes/vu_brown.html b/plugin/public/static/remotes/vu_brown.html
new file mode 100644
-index 0000000..b7835d3
+index 0000000..0c3bf8b
--- /dev/null
+++ b/plugin/public/static/remotes/vu_brown.html
@@ -0,0 +1,47 @@