summaryrefslogtreecommitdiff
path: root/meta-openvuplus/recipes-vuplus/e2openplugins
diff options
context:
space:
mode:
authorkos <kos@dev3>2012-12-24 03:04:21 (GMT)
committerkos <kos@dev3>2012-12-24 03:04:21 (GMT)
commit4977da0f186cc715b071e9c37e70f2dee241d06c (patch)
treed1617d50f399b443f57705ad82ab53b6a16b3239 /meta-openvuplus/recipes-vuplus/e2openplugins
parent7127826ed3c58ef66f65f879619d7e24e0e1f75a (diff)
fixed machine config.
added missing packages.
Diffstat (limited to 'meta-openvuplus/recipes-vuplus/e2openplugins')
-rw-r--r--meta-openvuplus/recipes-vuplus/e2openplugins/enigma2-plugin-systemplugins-autoshutdown.bb22
-rw-r--r--meta-openvuplus/recipes-vuplus/e2openplugins/files/autoshutdown-default-time_20121207.patch22
2 files changed, 44 insertions, 0 deletions
diff --git a/meta-openvuplus/recipes-vuplus/e2openplugins/enigma2-plugin-systemplugins-autoshutdown.bb b/meta-openvuplus/recipes-vuplus/e2openplugins/enigma2-plugin-systemplugins-autoshutdown.bb
new file mode 100644
index 0000000..e7ae673
--- /dev/null
+++ b/meta-openvuplus/recipes-vuplus/e2openplugins/enigma2-plugin-systemplugins-autoshutdown.bb
@@ -0,0 +1,22 @@
+MODULE = "AutoShutDown"
+DESCRIPTION = "automated power off for STB"
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+inherit gitpkgv
+SRCREV = ""
+PV = "0.3+git${SRCPV}"
+PKGV = "0.3+git${GITPKGV}"
+PR = "r2"
+
+require openplugins.inc
+
+SRC_REV = "406e54cb250fecb5040dba844098140982186668"
+SRC_URI = "git://github.com/E2OpenPlugins/e2openplugin-${MODULE}.git;protocol=git;tag=${SRC_REV} \
+ file://autoshutdown-default-time_20121207.patch;patch=1;pnum=1 \
+ "
+
+inherit autotools
+
+FILES_${PN} = "/"
+
+require assume-gplv2.inc
diff --git a/meta-openvuplus/recipes-vuplus/e2openplugins/files/autoshutdown-default-time_20121207.patch b/meta-openvuplus/recipes-vuplus/e2openplugins/files/autoshutdown-default-time_20121207.patch
new file mode 100644
index 0000000..4cfaf21
--- /dev/null
+++ b/meta-openvuplus/recipes-vuplus/e2openplugins/files/autoshutdown-default-time_20121207.patch
@@ -0,0 +1,22 @@
+diff --git a/src/plugin.py b/src/plugin.py
+index 4bb7533..4f90dae 100644
+--- a/src/plugin.py
++++ b/src/plugin.py
+@@ -27,7 +27,7 @@ from __init__ import _
+
+ config.autoshutdown = ConfigSubsection()
+ config.autoshutdown.time = ConfigInteger(default = 120, limits = (1, 1440))
+-config.autoshutdown.inactivetime = ConfigInteger(default = 60, limits = (1, 1440))
++config.autoshutdown.inactivetime = ConfigInteger(default = 300, limits = (1, 1440))
+ config.autoshutdown.autostart = ConfigEnableDisable(default=True)
+ config.autoshutdown.enableinactivity = ConfigEnableDisable(default=True)
+ config.autoshutdown.inactivityaction = ConfigSelection(default = "standby", choices = [("standby", _("Standby")), ("deepstandby", _("Deepstandby"))])
+@@ -263,7 +263,7 @@ class AutoShutDownConfiguration(Screen, ConfigListScreen):
+ config.autoshutdown.time.setValue(120)
+ config.autoshutdown.autostart.setValue(1)
+ config.autoshutdown.enableinactivity.setValue(1)
+- config.autoshutdown.inactivetime.setValue(60)
++ config.autoshutdown.inactivetime.setValue(300)
+ config.autoshutdown.inactivityaction.setValue("standby")
+ config.autoshutdown.epgrefresh.setValue(1)
+ config.autoshutdown.plugin.setValue(1)