summaryrefslogtreecommitdiff
path: root/meta-openvuplus/recipes-vuplus/e2openplugins
diff options
context:
space:
mode:
authorhschang <chang@dev3>2013-12-27 08:06:13 (GMT)
committerhschang <chang@dev3>2014-05-21 04:41:50 (GMT)
commit44dfbe0925e78711115fb65ad82a9caa08b248a6 (patch)
treec4661cdbc87c992ac412e0f03e070b5d2c6e5f07 /meta-openvuplus/recipes-vuplus/e2openplugins
parent9c1e91bc323a5328de43dd36a8559a11c56fa8be (diff)
remove testlab (is now provided by buildhistory)
remove old autotools.class fix IndentationError
Diffstat (limited to 'meta-openvuplus/recipes-vuplus/e2openplugins')
-rw-r--r--meta-openvuplus/recipes-vuplus/e2openplugins/enigma2-plugin-extensions-openwebif.bb50
1 files changed, 25 insertions, 25 deletions
diff --git a/meta-openvuplus/recipes-vuplus/e2openplugins/enigma2-plugin-extensions-openwebif.bb b/meta-openvuplus/recipes-vuplus/e2openplugins/enigma2-plugin-extensions-openwebif.bb
index 390f696..458d1de 100644
--- a/meta-openvuplus/recipes-vuplus/e2openplugins/enigma2-plugin-extensions-openwebif.bb
+++ b/meta-openvuplus/recipes-vuplus/e2openplugins/enigma2-plugin-extensions-openwebif.bb
@@ -26,31 +26,31 @@ do_install() {
}
python do_package_prepend () {
- boxtypes = [
- ('bm750', 'duo.jpg', 'vu_normal.png'),
- ('vuduo2', 'duo2.jpg', 'vu_normal.png'),
- ('vusolo', 'solo.jpg', 'vu_normal.png'),
- ('vusolo2', 'solo2.jpg', 'vu_normal.png'),
- ('vuultimo', 'ultimo.jpg', 'vu_ultimo.png'),
- ('vuuno', 'uno.jpg', 'vu_normal.png'),
- ]
- import os
- top = '${D}${PLUGINPATH}/public/images/'
- target_box = 'unknown.jpg'
- target_remote = 'ow_remote.png'
- for x in boxtypes:
- if x[0] == '${MACHINE}':
- target_box = x[1]
- target_remote = x[2]
- break
- for root, dirs, files in os.walk(top + 'boxes', topdown=False):
- for name in files:
- if target_box != name and name != 'unknown.jpg':
- os.remove(os.path.join(root, name))
- for root, dirs, files in os.walk(top + 'remotes', topdown=False):
- for name in files:
- if target_remote != name and name != 'ow_remote.png':
- os.remove(os.path.join(root, name))
+ boxtypes = [
+ ('bm750', 'duo.jpg', 'vu_normal.png'),
+ ('vuduo2', 'duo2.jpg', 'vu_normal.png'),
+ ('vusolo', 'solo.jpg', 'vu_normal.png'),
+ ('vusolo2', 'solo2.jpg', 'vu_normal.png'),
+ ('vuultimo', 'ultimo.jpg', 'vu_ultimo.png'),
+ ('vuuno', 'uno.jpg', 'vu_normal.png'),
+ ]
+ import os
+ top = '${D}${PLUGINPATH}/public/images/'
+ target_box = 'unknown.jpg'
+ target_remote = 'ow_remote.png'
+ for x in boxtypes:
+ if x[0] == '${MACHINE}':
+ target_box = x[1]
+ target_remote = x[2]
+ break
+ for root, dirs, files in os.walk(top + 'boxes', topdown=False):
+ for name in files:
+ if target_box != name and name != 'unknown.jpg':
+ os.remove(os.path.join(root, name))
+ for root, dirs, files in os.walk(top + 'remotes', topdown=False):
+ for name in files:
+ if target_remote != name and name != 'ow_remote.png':
+ os.remove(os.path.join(root, name))
}
FILES_${PN} = "${PLUGINPATH}"