summaryrefslogtreecommitdiff
path: root/meta-openvuplus/recipes-support
diff options
context:
space:
mode:
authorhschang <chang@dev3>2014-12-12 06:49:33 (GMT)
committerhschang <chang@dev3>2014-12-12 06:50:15 (GMT)
commitbbf0249ac1cae7d2212e53b30dfd1fb92c159a15 (patch)
tree85787c53f518a6ec0a45d1b67cd11525fe0869db /meta-openvuplus/recipes-support
parentace0665511bd0f288a33f4aa1b6ab44c9a766c5c (diff)
fix configure errors. (gettext, pkgconfig, autotools)
Diffstat (limited to 'meta-openvuplus/recipes-support')
-rw-r--r--meta-openvuplus/recipes-support/libxmlccwrap/files/use-pkgconfig.patch25
-rw-r--r--meta-openvuplus/recipes-support/libxmlccwrap/libxmlccwrap_0.0.12.bb6
2 files changed, 29 insertions, 2 deletions
diff --git a/meta-openvuplus/recipes-support/libxmlccwrap/files/use-pkgconfig.patch b/meta-openvuplus/recipes-support/libxmlccwrap/files/use-pkgconfig.patch
new file mode 100644
index 0000000..cb01fad
--- /dev/null
+++ b/meta-openvuplus/recipes-support/libxmlccwrap/files/use-pkgconfig.patch
@@ -0,0 +1,25 @@
+Index: libxmlccwrap-0.0.12/configure.ac
+===================================================================
+--- libxmlccwrap-0.0.12.orig/configure.ac
++++ libxmlccwrap-0.0.12/configure.ac
+@@ -14,7 +14,7 @@ AC_DISABLE_STATIC
+ AC_PROG_LIBTOOL
+ AM_PROG_LIBTOOL
+
+-AC_CHECK_LIB(xml2,main)
++PKG_CHECK_MODULES(XML2, [libxml-2.0])
+ #AC_CHECK_LIB(xslt,main)
+
+ AC_OUTPUT([Makefile \
+Index: libxmlccwrap-0.0.12/xmlccwrap/Makefile.am
+===================================================================
+--- libxmlccwrap-0.0.12.orig/xmlccwrap/Makefile.am
++++ libxmlccwrap-0.0.12/xmlccwrap/Makefile.am
+@@ -1,6 +1,6 @@
+ lib_LTLIBRARIES = libxmlccwrap.la
+
+-INCLUDES = -I$(top_srcdir) `xml2-config --cflags` `xslt-config --cflags`
++AM_CPPFLAGS = -I$(top_srcdir) $(XML2_CFLAGS)
+
+ libxmlccwrap_la_LDFLAGS = -release $(VERSION)
+ libxmlccwrap_la_SOURCES=xmlccwrap.cc libxmlexport.cc
diff --git a/meta-openvuplus/recipes-support/libxmlccwrap/libxmlccwrap_0.0.12.bb b/meta-openvuplus/recipes-support/libxmlccwrap/libxmlccwrap_0.0.12.bb
index 51b934a..57f2fce 100644
--- a/meta-openvuplus/recipes-support/libxmlccwrap/libxmlccwrap_0.0.12.bb
+++ b/meta-openvuplus/recipes-support/libxmlccwrap/libxmlccwrap_0.0.12.bb
@@ -10,12 +10,14 @@ PR = "r1"
SRC_URI = "http://www.ant.uni-bremen.de/whomes/rinas/libxmlccwrap/download/${P}.tar.gz \
file://dont_build_unneeded.patch \
file://disable_libxslt.patch \
- file://fix_assignment_operator.patch"
+ file://fix_assignment_operator.patch \
+ file://use-pkgconfig.patch \
+"
SRC_URI[md5sum] = "9f8bbad3452d704603246273b2dda758"
SRC_URI[sha256sum] = "38fb5f75f8b7dad1c8d535cc7b18ea9f1603e14a8b9256a2f60cf721513dc299"
-inherit autotools
+inherit autotools pkgconfig
FILES_${PN} = "${libdir}/${P}${SOLIBSDEV}"
FILES_${PN}-dev = "${includedir} ${libdir}/${PN}${SOLIBSDEV} ${libdir}/*.la"