summaryrefslogtreecommitdiff
path: root/meta-openvuplus/recipes-support
diff options
context:
space:
mode:
authorhschang <chang@dev3>2016-11-24 01:20:47 (GMT)
committerhschang <chang@dev3>2016-11-24 03:00:59 (GMT)
commit623e5552c9aa9669b99172d0008e8d0a3d1dca8d (patch)
treea922fec13cf0e9c74e783abf3b6033c7bc67027c /meta-openvuplus/recipes-support
parentb426b6bc07894326e24f098165bb109e33d1727e (diff)
Support Uno4k/Ultimo4k
Diffstat (limited to 'meta-openvuplus/recipes-support')
-rw-r--r--meta-openvuplus/recipes-support/libcrossguid/libcrossguid.bb8
1 files changed, 6 insertions, 2 deletions
diff --git a/meta-openvuplus/recipes-support/libcrossguid/libcrossguid.bb b/meta-openvuplus/recipes-support/libcrossguid/libcrossguid.bb
index 9cc9aa6..7387d86 100644
--- a/meta-openvuplus/recipes-support/libcrossguid/libcrossguid.bb
+++ b/meta-openvuplus/recipes-support/libcrossguid/libcrossguid.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "Lightweight cross platform C++ GUID/UUID library"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE;md5=1373274bc8d8001edc54933919f36f68"
-PR = "r0"
+PR = "r1"
inherit autotools pkgconfig
SRC_URI = "\
@@ -22,7 +22,11 @@ do_compile() {
}
do_install() {
- mkdir -p ${D}/usr/{include,lib/pkgconfig}
+ install -d ${D}
+ install -d ${D}/usr
+ install -d ${D}/usr/include
+ install -d ${D}/usr/lib
+ install -d ${D}/usr/lib/pkgconfig
install -m 644 ${S}/guid.h ${D}/usr/include
install -m 644 ${S}/libcrossguid.a ${D}/usr/lib
install -m 644 ${WORKDIR}/crossguid.pc ${D}/usr/lib/pkgconfig