summaryrefslogtreecommitdiff
path: root/meta-openvuplus/recipes-support/taglib
diff options
context:
space:
mode:
authoroskwon <oskwon@dev3>2017-04-11 06:12:19 (GMT)
committeroskwon <oskwon@dev3>2017-04-11 06:12:19 (GMT)
commitea52bcf13111628b3ca999626ca8a84564754a0f (patch)
tree921d9da70450b14c10c1a086c975c3374ae4237e /meta-openvuplus/recipes-support/taglib
parent6d787b47d67562aa877b0d3b950833210597e35b (diff)
update kodi to 17.x. (MIPS based models not supported yet)
Diffstat (limited to 'meta-openvuplus/recipes-support/taglib')
-rw-r--r--meta-openvuplus/recipes-support/taglib/taglib_1.11.1.bb39
-rw-r--r--meta-openvuplus/recipes-support/taglib/taglib_1.8.bb30
2 files changed, 39 insertions, 30 deletions
diff --git a/meta-openvuplus/recipes-support/taglib/taglib_1.11.1.bb b/meta-openvuplus/recipes-support/taglib/taglib_1.11.1.bb
new file mode 100644
index 0000000..6eb8265
--- /dev/null
+++ b/meta-openvuplus/recipes-support/taglib/taglib_1.11.1.bb
@@ -0,0 +1,39 @@
+SUMMARY = "Library for reading and editing the meta-data of popular audio formats"
+SECTION = "libs/multimedia"
+HOMEPAGE = "http://taglib.github.io/"
+LICENSE = "LGPLv2.1 | MPL-1"
+LIC_FILES_CHKSUM = "file://COPYING.LGPL;md5=4fbd65380cdd255951079008b364516c \
+ file://COPYING.MPL;md5=bfe1f75d606912a4111c90743d6c7325 \
+ file://taglib/audioproperties.h;beginline=1;endline=24;md5=9df2c7399519b7310568a7c55042ecee"
+
+DEPENDS = "zlib"
+
+SRC_URI = "http://taglib.github.io/releases/${BP}.tar.gz"
+SRC_URI[md5sum] = "cee7be0ccfc892fa433d6c837df9522a"
+SRC_URI[sha256sum] = "b6d1a5a610aae6ff39d93de5efd0fdc787aa9e9dc1e7026fa4c961b26563526b"
+
+UPSTREAM_CHECK_URI = "http://github.com/taglib/taglib/releases/"
+
+BINCONFIG = "${bindir}/taglib-config"
+
+inherit cmake pkgconfig binconfig
+
+PACKAGES =+ "${PN}-c"
+FILES_${PN}-c = "${libdir}/libtag_c.so.*"
+
+EXTRA_OECMAKE = "-DBUILD_SHARED_LIBS=ON \
+ -DCMAKE_DISABLE_FIND_PACKAGE_Boost=TRUE \
+ -DHAVE_BOOST_BYTESWAP=FALSE \
+ -DCMAKE_CXX_STANDARD=11 \
+ -DCMAKE_CXX_STANDARD_REQUIRED=OFF \
+"
+CXXFLAGS += "-std=c++11"
+
+do_configure_prepend () {
+ rm -f ${S}/admin/ltmain.sh
+ rm -f ${S}/admin/libtool.m4.in
+}
+
+# without -fPIC depending packages failed with many error like:
+# | <...>/ld: error: <...>/usr/lib/libtag.a(modfilebase.cpp.o): requires unsupported dynamic reloc R_ARM_THM_MOVW_ABS_NC; recompile with -fPIC
+CXXFLAGS += "-fPIC"
diff --git a/meta-openvuplus/recipes-support/taglib/taglib_1.8.bb b/meta-openvuplus/recipes-support/taglib/taglib_1.8.bb
deleted file mode 100644
index b032c92..0000000
--- a/meta-openvuplus/recipes-support/taglib/taglib_1.8.bb
+++ /dev/null
@@ -1,30 +0,0 @@
-DESCRIPTION = "TagLib is a library for reading and editing the meta-data of several popular audio formats"
-SECTION = "libs/multimedia"
-HOMEPAGE = "http://developer.kde.org/~wheeler/taglib.html"
-LICENSE = "LGPLv2.1 | MPL-1"
-LIC_FILES_CHKSUM = "file://COPYING.LGPL;md5=4fbd65380cdd255951079008b364516c \
- file://COPYING.MPL;md5=bfe1f75d606912a4111c90743d6c7325 \
- file://taglib/audioproperties.h;beginline=1;endline=24;md5=9df2c7399519b7310568a7c55042ecee"
-
-DEPENDS = "zlib"
-
-PR = "r0"
-# http://developer.kde.org/~wheeler/files/src/taglib-${PV}.tar.gz
-SRC_URI = "https://github.com/downloads/taglib/taglib/taglib-1.8.tar.gz \
- "
-
-SRC_URI[md5sum] = "dcb8bd1b756f2843e18b1fdf3aaeee15"
-SRC_URI[sha256sum] = "66d33481703c90236a0a9d1c38fd81b584ca7109ded049225f5463dcaffc209a"
-
-S = "${WORKDIR}/taglib-${PV}"
-
-inherit cmake pkgconfig binconfig
-
-PACKAGES =+ "${PN}-c"
-FILES_${PN}-c = "${libdir}/libtag_c.so.*"
-
-do_configure_prepend () {
- rm -f ${S}/admin/ltmain.sh
- rm -f ${S}/admin/libtool.m4.in
-}
-