summaryrefslogtreecommitdiff
path: root/meta-openvuplus/recipes-multimedia
diff options
context:
space:
mode:
authorhschang <chang@dev3>2015-02-12 11:58:57 (GMT)
committerhschang <chang@dev3>2015-02-12 11:58:57 (GMT)
commit72a489c8029075ab8bd69b1b158a1bf877195ddb (patch)
treedc836efc5b9b61159f60adde59814ebac6b1a962 /meta-openvuplus/recipes-multimedia
parent1b79033b19248c5e7d403f947ac435eb7048210d (diff)
parent0fcc166c661506586b71b1a251604f238aea09b8 (diff)
Merge remote-tracking branch 'oe_21/master' into vuplus-3.0
Conflicts: meta-bsp/common/recipes/linux/linux-vuplus_3.13.5.bb meta-openvuplus/recipes-core/meta/distro-feed-configs.bbappend meta-openvuplus/recipes-core/tasks/task-core-boot.bb meta-openvuplus/recipes-devtools/python/python-native_2.7.2.bbappend meta-openvuplus/recipes-devtools/swig/swig_2.0.4.bb meta-openvuplus/recipes-vuplus/enigma2/enigma2.bb meta-openvuplus/recipes-vuplus/opera-hbbtv/opera-hbbtv_0.1.bb meta-openvuplus/recipes-vuplus/opera-hbbtv/opera-hbbtv_0.2.bb meta-openvuplus/recipes-vuplus/packagegroups/packagegroup-vuplus-enigma2.bb meta-openvuplus/recipes-vuplus/tasks/task-vuplus-base.inc
Diffstat (limited to 'meta-openvuplus/recipes-multimedia')
-rw-r--r--meta-openvuplus/recipes-multimedia/xbmc/enigma2-plugin-extensions-xbmc.bb31
-rw-r--r--meta-openvuplus/recipes-multimedia/xbmc/xbmc_git.bb85
-rw-r--r--meta-openvuplus/recipes-multimedia/xbmc/xbmc_git.bbappend102
3 files changed, 218 insertions, 0 deletions
diff --git a/meta-openvuplus/recipes-multimedia/xbmc/enigma2-plugin-extensions-xbmc.bb b/meta-openvuplus/recipes-multimedia/xbmc/enigma2-plugin-extensions-xbmc.bb
new file mode 100644
index 0000000..2385471
--- /dev/null
+++ b/meta-openvuplus/recipes-multimedia/xbmc/enigma2-plugin-extensions-xbmc.bb
@@ -0,0 +1,31 @@
+SECTION = "base"
+LICENSE = "CLOSED"
+
+PKG_DATE="20141219.0_beta"
+
+PV="1.0"
+PR="${PKG_DATE}_r0"
+
+DEPENDS += "enigma2 xbmc"
+RDEPENDS += "xbmc"
+
+SRC_URI = "http://archive.vuplus.com/download/build_support/e2xbmc-plugin_${PKG_DATE}.tar.gz"
+
+S = "${WORKDIR}/plugin"
+
+PLUGIN_DIR="${D}${libdir}/enigma2/python/Plugins/Extensions/XBMC"
+
+do_install() {
+ install -d ${PLUGIN_DIR}
+ install -m 0755 ${S}/*.py ${PLUGIN_DIR}
+ install -m 0755 ${S}/button.png ${PLUGIN_DIR}
+}
+
+do_package_qa() {
+}
+
+FILES_${PN}="/"
+
+SRC_URI[md5sum] = "31542f3ad42725d2a7ac498be4870e31"
+SRC_URI[sha256sum] = "f662de7daab96fa690686cbefab597f0cf5e42a7abfc6e414faa1f1c4aff1cdc"
+
diff --git a/meta-openvuplus/recipes-multimedia/xbmc/xbmc_git.bb b/meta-openvuplus/recipes-multimedia/xbmc/xbmc_git.bb
new file mode 100644
index 0000000..ce6bec3
--- /dev/null
+++ b/meta-openvuplus/recipes-multimedia/xbmc/xbmc_git.bb
@@ -0,0 +1,85 @@
+DESCRIPTION = "XBMC Media Center"
+
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://LICENSE.GPL;md5=6eb631b6da7fdb01508a80213ffc35ff"
+
+DEPENDS = "libusb1 libcec libplist expat yajl gperf-native libxmu fribidi mpeg2dec ffmpeg samba fontconfig curl python libass libmodplug libmicrohttpd wavpack libmms cmake-native libsdl-image libsdl-mixer virtual/egl mysql5 sqlite3 libmms faad2 libcdio libpcre boost lzo enca avahi libsamplerate0 libxinerama libxrandr libxtst bzip2 virtual/libsdl jasper zip-native zlib libtinyxml"
+#require recipes/egl/egl.inc
+
+SRCREV = "82388d55dae79cbb2e486e307e23202e76a43efa"
+
+PV = "11.0"
+PR = "r14"
+#PR_append = "+gitr${SRCPV}"
+SRC_URI = "git://github.com/xbmc/xbmc.git;branch=eden;protocol=git \
+ file://0001-configure-don-t-run-python-distutils-to-find-STAGING.patch \
+ file://0002-Revert-fixed-ios-Add-memory-barriers-to-atomic-Add-S.patch \
+ file://0003-Revert-fixed-ios-Add-memory-barriers-to-cas-assembly.patch \
+ file://configure.in-Avoid-running-code.patch \
+ "
+
+inherit autotools gettext python-dir
+
+S = "${WORKDIR}/git"
+
+CACHED_CONFIGUREVARS += " \
+ ac_cv_path_PYTHON="${STAGING_BINDIR_NATIVE}/python-native/python" \
+"
+
+EXTRA_OECONF = " \
+ --disable-rpath \
+ --enable-gles \
+ --enable-libusb \
+ --enable-airplay \
+ --disable-optical-drive \
+ --enable-external-libraries \
+"
+
+FULL_OPTIMIZATION_armv7a = "-fexpensive-optimizations -fomit-frame-pointer -O4 -ffast-math"
+BUILD_OPTIMIZATION = "${FULL_OPTIMIZATION}"
+
+EXTRA_OECONF_append_armv7a = "--cpu=cortex-a8"
+
+# for python modules
+export HOST_SYS
+export BUILD_SYS
+export STAGING_LIBDIR
+export STAGING_INCDIR
+export PYTHON_DIR
+
+do_configure() {
+ sh bootstrap
+ oe_runconf
+}
+
+PARALLEL_MAKE = ""
+
+do_compile_prepend() {
+ for i in $(find . -name "Makefile") ; do
+ sed -i -e 's:I/usr/include:I${STAGING_INCDIR}:g' $i
+ done
+
+ for i in $(find . -name "*.mak*" -o -name "Makefile") ; do
+ sed -i -e 's:I/usr/include:I${STAGING_INCDIR}:g' -e 's:-rpath \$(libdir):-rpath ${libdir}:g' $i
+ done
+}
+
+INSANE_SKIP_${PN} = "rpaths"
+
+# on ARM architectures xbmc will use GLES which will make the regular wrapper fail, so start it directly
+do_install_append_arm() {
+ sed -i -e 's:Exec=xbmc:Exec=${libdir}/xbmc/xbmc.bin:g' ${D}${datadir}/applications/xbmc.desktop
+}
+
+FILES_${PN} += "${datadir}/xsessions ${datadir}/icons"
+FILES_${PN}-dbg += "${libdir}/xbmc/.debug ${libdir}/xbmc/*/.debug ${libdir}/xbmc/*/*/.debug ${libdir}/xbmc/*/*/*/.debug"
+
+# xbmc uses some kind of dlopen() method for libcec so we need to add it manually
+RRECOMMENDS_${PN}_append = " libcec \
+ python \
+ python-lang \
+ python-re \
+ python-netclient \
+ libcurl \
+ "
+RRECOMMENDS_${PN}_append_libc-glibc = " glibc-charmap-ibm850 glibc-gconv-ibm850"
diff --git a/meta-openvuplus/recipes-multimedia/xbmc/xbmc_git.bbappend b/meta-openvuplus/recipes-multimedia/xbmc/xbmc_git.bbappend
new file mode 100644
index 0000000..59039ed
--- /dev/null
+++ b/meta-openvuplus/recipes-multimedia/xbmc/xbmc_git.bbappend
@@ -0,0 +1,102 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+SUMMARY = "XBMC Media Center"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://LICENSE.GPL;md5=6eb631b6da7fdb01508a80213ffc35ff"
+
+DEPENDS = "libgles libxslt libusb1 libcec libplist expat yajl gperf-native fribidi mpeg2dec samba fontconfig curl python libass libmodplug libmicrohttpd wavpack libmms cmake-native libsdl-image libsdl-mixer mysql5 sqlite3 libmms faad2 libcdio libpcre boost lzo enca avahi libsamplerate0 bzip2 virtual/libsdl jasper zip-native zlib libtinyxml taglib libbluray libshairport librtmp zlib libnfs libxslt"
+
+RDEPENDS = "python"
+RDEPENDS += "\
+ python-distutils \
+ python-subprocess \
+ python-robotparser \
+ python-mechanize \
+ python-threading \
+ python-shell \
+ python-zlib \
+ python-sqlite3 \
+ python-json \
+ python-xml \
+ python-html \
+ python-netserver \
+ python-misc \
+ python-pygobject \
+ python-pygobject-lib \
+ python-textutils \
+ python-simplejson \
+ python-xmlrpc \
+ python-pprint \
+ python-difflib \
+ python-email \
+ python-compression \
+ python-compile \
+ python-compiler \
+ python-numbers \
+ nfs-utils-client \
+ libshairport \
+ eglibc-gconv-utf-32 \
+ lzma \
+ tiff \
+ yajl \
+ libxslt \
+ libupnp \
+ libplist \
+ librtmp \
+ libbluray \
+ libnfs \
+"
+
+BUILD_PR="r2"
+NATIVEGLES_PR="20141202_p0"
+
+BRANCH = "gotham_vuplus"
+SRCREV = "a4cee0ded4d72572be519ffe8c3aad329113e10a"
+
+PV = "13.2"
+PR = "${BUILD_PR}_${NATIVEGLES_PR}_${SRCREV}"
+
+SRC_URI = "git://code.vuplus.com/git/xbmc.git;protocol=http;branch=${BRANCH};tag=${SRCREV} \
+ http://archive.vuplus.com/download/build_support/xbmc-support_${NATIVEGLES_PR}.tar.gz;name=xbmc-support \
+"
+S = "${WORKDIR}/git"
+
+EXTRA_OECONF = " \
+ --disable-rpath \
+ --enable-gles \
+ --enable-libusb \
+ --enable-airplay \
+ --disable-optical-drive \
+ --enable-external-libraries \
+ --disable-ssh \
+ --enable-external_ffmpeg \
+ --disable-x11 \
+ --disable-sdl \
+ --disable-joystick \
+ --disable-alsa \
+ --disable-libcec \
+ --enable-rtmp \
+ --disable-gnutls \
+ --disable-texturepacker \
+ --with-platform=dvbbox \
+"
+
+do_configure_prepend(){
+ cp -av ${WORKDIR}/xbmc-support/gles_init.* ${WORKDIR}/git/xbmc/windowing/egl/
+}
+
+do_install_append(){
+ install -d ${D}${bindir}
+ install -m 0755 ${WORKDIR}/xbmc-support/xbmc.helper ${D}${bindir}
+}
+
+do_package_qa(){
+}
+
+PARALLEL_MAKE = " -j8 "
+
+FILES_${PN} += "/usr/bin /usr/share /usr/lib"
+
+SRC_URI[xbmc-support.md5sum] = "9d0c73505484823e3816b5577f28a8a8"
+SRC_URI[xbmc-support.sha256sum] = "5483e24db81efca03120dbf0ef4cc423d2665ebc4d52149be15d75a0ae9b626d"
+