summaryrefslogtreecommitdiff
path: root/meta-openvuplus/recipes-multimedia
diff options
context:
space:
mode:
authorhschang <chang@dev3>2015-05-07 06:41:03 (GMT)
committerhschang <chang@dev3>2015-05-07 06:50:25 (GMT)
commit36bda3a5383a328d24f2a44883e5f497f45291f5 (patch)
treeed9f9ee8057a34fece31db9e5ddf2d9c755047c6 /meta-openvuplus/recipes-multimedia
parentfc1fc594335687583fc2ac675d3da919dd484f2a (diff)
[gstreamer1.0] Remove *.bbappend and update.
Diffstat (limited to 'meta-openvuplus/recipes-multimedia')
-rw-r--r--meta-openvuplus/recipes-multimedia/gstreamer1.0/gstreamer1.0-plugin-dvbmediasink.bb16
-rw-r--r--meta-openvuplus/recipes-multimedia/gstreamer1.0/gstreamer1.0-plugin-dvbmediasink.bbappend12
-rw-r--r--meta-openvuplus/recipes-multimedia/gstreamer1.0/gstreamer1.0-plugins-bad.inc8
-rw-r--r--meta-openvuplus/recipes-multimedia/gstreamer1.0/gstreamer1.0-plugins-bad_1.4.%.bbappend14
-rw-r--r--meta-openvuplus/recipes-multimedia/gstreamer1.0/gstreamer1.0-plugins-bad_1.4.5.bb4
-rw-r--r--meta-openvuplus/recipes-multimedia/gstreamer1.0/gstreamer1.0-plugins-base.inc5
-rw-r--r--meta-openvuplus/recipes-multimedia/gstreamer1.0/gstreamer1.0-plugins-base/subparse-avoid-false-negatives-dealing-with-UTF-8.patch66
-rw-r--r--meta-openvuplus/recipes-multimedia/gstreamer1.0/gstreamer1.0-plugins-base_1.4.%.bbappend14
-rw-r--r--meta-openvuplus/recipes-multimedia/gstreamer1.0/gstreamer1.0-plugins-base_1.4.5.bb10
-rw-r--r--meta-openvuplus/recipes-multimedia/gstreamer1.0/gstreamer1.0-plugins-good.inc2
-rw-r--r--meta-openvuplus/recipes-multimedia/gstreamer1.0/gstreamer1.0-plugins-good_1.4.%.bbappend9
-rw-r--r--meta-openvuplus/recipes-multimedia/gstreamer1.0/gstreamer1.0-plugins-ugly.inc7
-rw-r--r--meta-openvuplus/recipes-multimedia/gstreamer1.0/gstreamer1.0-plugins-ugly_1.4.%.bbappend15
13 files changed, 100 insertions, 82 deletions
diff --git a/meta-openvuplus/recipes-multimedia/gstreamer1.0/gstreamer1.0-plugin-dvbmediasink.bb b/meta-openvuplus/recipes-multimedia/gstreamer1.0/gstreamer1.0-plugin-dvbmediasink.bb
index f2d6db1..534dd73 100644
--- a/meta-openvuplus/recipes-multimedia/gstreamer1.0/gstreamer1.0-plugin-dvbmediasink.bb
+++ b/meta-openvuplus/recipes-multimedia/gstreamer1.0/gstreamer1.0-plugin-dvbmediasink.bb
@@ -4,12 +4,16 @@ PRIORITY = "optional"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=7fbc338309ac38fefcd64b04bb903e34"
-DEPENDS = "gstreamer1.0 gstreamer1.0-plugins-base"
+DEPENDS = "gstreamer1.0 gstreamer1.0-plugins-base libdca"
GSTVERSION = "1.0"
-SRC_URI = "git://git.code.sf.net/p/openpli/gst-plugin-dvbmediasink;protocol=git;branch=gst-1.0"
-SRCREV = "${AUTOREV}"
+SRC_URI = " \
+ git://git.code.sf.net/p/openpli/gst-plugin-dvbmediasink;protocol=git;branch=gst-1.0 \
+ file://gstreamer10_dvbmediasink_vuplus.patch \
+"
+#SRCREV = "${AUTOREV}"
+SRCREV = "1e99787f3387d3dd1e6167af73597674bf8fe37d"
S = "${WORKDIR}/git"
@@ -17,7 +21,7 @@ inherit gitpkgv
PV = "${GSTVERSION}+git${SRCPV}"
PKGV = "${GSTVERSION}+git${GITPKGV}"
-PR = "r1"
+PR = "r2"
inherit autotools pkgconfig
@@ -29,3 +33,7 @@ FILES_${PN}-dbg += "${libdir}/gstreamer-${GSTVERSION}/.debug"
PACKAGE_ARCH = "${MACHINE_ARCH}"
EXTRA_OECONF = "${DVBMEDIASINK_CONFIG} --with-gstversion=${GSTVERSION}"
+
+RPROVIDES_${PN} = "gst-plugin-dvbmediasink"
+
+DVBMEDIASINK_CONFIG = "--with-wmv --with-pcm --with-eac3"
diff --git a/meta-openvuplus/recipes-multimedia/gstreamer1.0/gstreamer1.0-plugin-dvbmediasink.bbappend b/meta-openvuplus/recipes-multimedia/gstreamer1.0/gstreamer1.0-plugin-dvbmediasink.bbappend
deleted file mode 100644
index 0e7085e..0000000
--- a/meta-openvuplus/recipes-multimedia/gstreamer1.0/gstreamer1.0-plugin-dvbmediasink.bbappend
+++ /dev/null
@@ -1,12 +0,0 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
-
-SRCREV = "1e99787f3387d3dd1e6167af73597674bf8fe37d"
-
-SRC_URI += "\
- file://gstreamer10_dvbmediasink_vuplus.patch \
-"
-
-PR .= "-vuplus3"
-
-DVBMEDIASINK_CONFIG = "--with-wmv --with-pcm --with-eac3"
-
diff --git a/meta-openvuplus/recipes-multimedia/gstreamer1.0/gstreamer1.0-plugins-bad.inc b/meta-openvuplus/recipes-multimedia/gstreamer1.0/gstreamer1.0-plugins-bad.inc
index c657aee..d3b2b58 100644
--- a/meta-openvuplus/recipes-multimedia/gstreamer1.0/gstreamer1.0-plugins-bad.inc
+++ b/meta-openvuplus/recipes-multimedia/gstreamer1.0/gstreamer1.0-plugins-bad.inc
@@ -2,7 +2,7 @@ require gstreamer1.0-plugins.inc
LICENSE = "GPLv2+ & LGPLv2+ & LGPLv2.1+ "
-DEPENDS += "gstreamer1.0-plugins-base bzip2 libpng jpeg"
+DEPENDS += "gstreamer1.0-plugins-base bzip2 libpng jpeg libdca"
S = "${WORKDIR}/gst-plugins-bad-${PV}"
@@ -20,8 +20,9 @@ PACKAGECONFIG ?= " \
${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland', '', d)} \
${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez', '', d)} \
${@bb.utils.contains('DISTRO_FEATURES', 'directfb', 'directfb', '', d)} \
- orc curl uvch264 neon sndfile \
+ orc curl neon sndfile \
hls sbc dash bz2 smoothstreaming \
+ faac faad libmms dash webp rtmp \
"
# dash = Dynamic Adaptive Streaming over HTTP
@@ -74,6 +75,8 @@ EXTRA_OECONF += " \
--enable-shm \
--enable-fbdev \
--enable-decklink \
+ --enable-dts \
+ --enable-mpegdemux \
--disable-acm \
--disable-android_media \
--disable-apexsink \
@@ -86,7 +89,6 @@ EXTRA_OECONF += " \
--disable-direct3d \
--disable-directdraw \
--disable-directsound \
- --disable-dts \
--disable-gme \
--disable-gsettings \
--disable-gsm \
diff --git a/meta-openvuplus/recipes-multimedia/gstreamer1.0/gstreamer1.0-plugins-bad_1.4.%.bbappend b/meta-openvuplus/recipes-multimedia/gstreamer1.0/gstreamer1.0-plugins-bad_1.4.%.bbappend
deleted file mode 100644
index f73d38a..0000000
--- a/meta-openvuplus/recipes-multimedia/gstreamer1.0/gstreamer1.0-plugins-bad_1.4.%.bbappend
+++ /dev/null
@@ -1,14 +0,0 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
-DEPENDS += "libdca"
-EXTRA_OECONF := "${@bb.data.getVar('EXTRA_OECONF',d,1).replace('--disable-dts', '--enable-dts --enable-mpegdemux')}"
-PACKAGECONFIG += "faac faad libmms hls dash smoothstreaming webp rtmp"
-SRC_URI += "file://0001-rtmp-fix-seeking-and-potential-segfault.patch"
-
-# Do not strip binary
-#INHIBIT_PACKAGE_STRIP = "1"
-#do_strip[noexec] = "1"
-#do_strip="no"
-#do_strip(){
-# pass
-#}
-
diff --git a/meta-openvuplus/recipes-multimedia/gstreamer1.0/gstreamer1.0-plugins-bad_1.4.5.bb b/meta-openvuplus/recipes-multimedia/gstreamer1.0/gstreamer1.0-plugins-bad_1.4.5.bb
index 59065de..f46f834 100644
--- a/meta-openvuplus/recipes-multimedia/gstreamer1.0/gstreamer1.0-plugins-bad_1.4.5.bb
+++ b/meta-openvuplus/recipes-multimedia/gstreamer1.0/gstreamer1.0-plugins-bad_1.4.5.bb
@@ -5,7 +5,9 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=73a5855a8119deb017f5f13cf327095d \
file://COPYING.LIB;md5=21682e4e8fea52413fd26c60acb907e5 \
file://gst/tta/crc32.h;beginline=12;endline=29;md5=27db269c575d1e5317fffca2d33b3b50"
-SRC_URI += "file://0001-gl-do-not-check-for-GL-GLU-EGL-GLES2-libs-if-disable.patch"
+SRC_URI += "file://0001-gl-do-not-check-for-GL-GLU-EGL-GLES2-libs-if-disable.patch \
+ file://0001-rtmp-fix-seeking-and-potential-segfault.patch \
+"
SRC_URI[md5sum] = "e0bb39412cf4a48fe0397bcf3a7cd451"
SRC_URI[sha256sum] = "152fad7250683d72f9deb36c5685428338365fe4a4c87ffe15e38783b14f983c"
diff --git a/meta-openvuplus/recipes-multimedia/gstreamer1.0/gstreamer1.0-plugins-base.inc b/meta-openvuplus/recipes-multimedia/gstreamer1.0/gstreamer1.0-plugins-base.inc
index 8fdf53f..a725204 100644
--- a/meta-openvuplus/recipes-multimedia/gstreamer1.0/gstreamer1.0-plugins-base.inc
+++ b/meta-openvuplus/recipes-multimedia/gstreamer1.0/gstreamer1.0-plugins-base.inc
@@ -12,7 +12,7 @@ PACKAGES_DYNAMIC =+ "^libgst.*"
PACKAGECONFIG ?= " \
${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', '', d)} \
${@bb.utils.contains('DISTRO_FEATURES', 'alsa', 'alsa', '', d)} \
- orc ivorbis ogg theora vorbis \
+ orc ivorbis ogg theora vorbis cdparanoia \
"
X11DEPENDS = "virtual/libx11 libsm libxrender"
@@ -25,12 +25,11 @@ PACKAGECONFIG[ogg] = "--enable-ogg,--disable-ogg,libogg"
PACKAGECONFIG[theora] = "--enable-theora,--disable-theora,libtheora"
PACKAGECONFIG[vorbis] = "--enable-vorbis,--disable-vorbis,libvorbis"
PACKAGECONFIG[pango] = "--enable-pango,--disable-pango,pango"
-
+PACKAGECONFIG[cdparanoia] = "--enable-cdparanoia,--disable-cdparanoia,cdparanoia"
# cdparanoia and libvisual do not seem to exist anywhere in OE
EXTRA_OECONF += " \
--disable-freetypetest \
- --disable-cdparanoia \
--disable-libvisual \
${GSTREAMER_1_0_ORC} \
"
diff --git a/meta-openvuplus/recipes-multimedia/gstreamer1.0/gstreamer1.0-plugins-base/subparse-avoid-false-negatives-dealing-with-UTF-8.patch b/meta-openvuplus/recipes-multimedia/gstreamer1.0/gstreamer1.0-plugins-base/subparse-avoid-false-negatives-dealing-with-UTF-8.patch
new file mode 100644
index 0000000..f5ad2ad
--- /dev/null
+++ b/meta-openvuplus/recipes-multimedia/gstreamer1.0/gstreamer1.0-plugins-base/subparse-avoid-false-negatives-dealing-with-UTF-8.patch
@@ -0,0 +1,66 @@
+From cc5681e3d07023e8684c5da962c4fb5fcecfd385 Mon Sep 17 00:00:00 2001
+From: "Reynaldo H. Verdejo Pinochet" <reynaldo@osg.samsung.com>
+Date: Fri, 28 Nov 2014 13:26:13 -0300
+Subject: [PATCH] subparse: avoid false negatives dealing with UTF-8
+
+g_utf8_validate() chokes at any NUL among max_len
+bytes so we should avoid passing null character
+terminators if present. Additionally, only part of
+the available data might be valid UTF-8. For example
+a byte at the end might be the start of a valid UTF-8
+run (ie: d0) but not be a valid UTF-8 character by
+itself. In this case, we consume only the valid portion
+of the run.
+
+https://bugzilla.gnome.org/show_bug.cgi?id=740784
+---
+ gst/subparse/gstsubparse.c | 23 +++++++++++++++++++++--
+ 1 file changed, 21 insertions(+), 2 deletions(-)
+
+diff --git a/gst/subparse/gstsubparse.c b/gst/subparse/gstsubparse.c
+index 11b76c3..2719fd7 100644
+--- a/gst/subparse/gstsubparse.c
++++ b/gst/subparse/gstsubparse.c
+@@ -437,6 +437,9 @@ convert_encoding (GstSubParse * self, const gchar * str, gsize len,
+ const gchar *encoding;
+ GError *err = NULL;
+ gchar *ret = NULL;
++ gsize nuls = 0;
++ gsize valid_utf8_len;
++ const gchar *invalid_utf8_start;
+
+ *consumed = 0;
+
+@@ -457,11 +460,27 @@ convert_encoding (GstSubParse * self, const gchar * str, gsize len,
+
+ /* Otherwise check if it's UTF8 */
+ if (self->valid_utf8) {
+- if (g_utf8_validate (str, len, NULL)) {
++ /* Trim NUL terminator(s) if present */
++ while (len > 0 && str[len - 1] == '\0') {
++ len--;
++ nuls++;
++ }
++
++ /* Consume whole byte run if all valid UTF-8 */
++ if (g_utf8_validate (str, len, &invalid_utf8_start)) {
+ GST_LOG_OBJECT (self, "valid UTF-8, no conversion needed");
+- *consumed = len;
++ *consumed = len + nuls;
+ return g_strndup (str, len);
+ }
++
++ /* Consume initial data as far as we have at least 1 valid code point */
++ valid_utf8_len = invalid_utf8_start - str;
++ if (valid_utf8_len) {
++ GST_WARNING_OBJECT (self, "At least some of the data was invalid UTF-8");
++ *consumed = valid_utf8_len;
++ return g_strndup (str, valid_utf8_len);
++ }
++
+ GST_INFO_OBJECT (self, "invalid UTF-8!");
+ self->valid_utf8 = FALSE;
+ }
+--
+2.1.4
+
diff --git a/meta-openvuplus/recipes-multimedia/gstreamer1.0/gstreamer1.0-plugins-base_1.4.%.bbappend b/meta-openvuplus/recipes-multimedia/gstreamer1.0/gstreamer1.0-plugins-base_1.4.%.bbappend
deleted file mode 100644
index 4f1f0f5..0000000
--- a/meta-openvuplus/recipes-multimedia/gstreamer1.0/gstreamer1.0-plugins-base_1.4.%.bbappend
+++ /dev/null
@@ -1,14 +0,0 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
-PACKAGECONFIG[cdparanoia] = "--enable-cdparanoia,--disable-cdparanoia,cdparanoia"
-PACKAGECONFIG += "cdparanoia"
-EXTRA_OECONF := "${@bb.data.getVar('EXTRA_OECONF',d,1).replace('--disable-cdparanoia', '--enable-cdparanoia')}"
-SRC_URI += "file://0001-riff-media-added-fourcc-to-all-mpeg4-video-caps.patch"
-
-# Do not strip binary
-#INHIBIT_PACKAGE_STRIP = "1"
-#do_strip[noexec] = "1"
-#do_strip="no"
-#do_strip(){
-# pass
-#}
-
diff --git a/meta-openvuplus/recipes-multimedia/gstreamer1.0/gstreamer1.0-plugins-base_1.4.5.bb b/meta-openvuplus/recipes-multimedia/gstreamer1.0/gstreamer1.0-plugins-base_1.4.5.bb
index 11cf8b4..263ec87 100644
--- a/meta-openvuplus/recipes-multimedia/gstreamer1.0/gstreamer1.0-plugins-base_1.4.5.bb
+++ b/meta-openvuplus/recipes-multimedia/gstreamer1.0/gstreamer1.0-plugins-base_1.4.5.bb
@@ -5,12 +5,16 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=c54ce9345727175ff66d17b67ff51f58 \
file://COPYING.LIB;md5=6762ed442b3822387a51c92d928ead0d \
"
-SRC_URI += "file://do-not-change-eos-event-to-gap-event-if.patch \
- file://get-caps-from-src-pad-when-query-caps.patch \
- file://taglist-not-send-to-down-stream-if-all-the-frame-cor.patch \
+SRC_URI += " \
+ file://do-not-change-eos-event-to-gap-event-if.patch \
+ file://get-caps-from-src-pad-when-query-caps.patch \
+ file://taglist-not-send-to-down-stream-if-all-the-frame-cor.patch \
+ file://0001-riff-media-added-fourcc-to-all-mpeg4-video-caps.patch \
+ file://subparse-avoid-false-negatives-dealing-with-UTF-8.patch \
"
SRC_URI[md5sum] = "357165af625c0ca353ab47c5d843920e"
SRC_URI[sha256sum] = "77bd8199e7a312d3d71de9b7ddf761a3b78560a2c2a80829d0815ca39cbd551d"
S = "${WORKDIR}/gst-plugins-base-${PV}"
+
diff --git a/meta-openvuplus/recipes-multimedia/gstreamer1.0/gstreamer1.0-plugins-good.inc b/meta-openvuplus/recipes-multimedia/gstreamer1.0/gstreamer1.0-plugins-good.inc
index 299b95f..1b1ee36 100644
--- a/meta-openvuplus/recipes-multimedia/gstreamer1.0/gstreamer1.0-plugins-good.inc
+++ b/meta-openvuplus/recipes-multimedia/gstreamer1.0/gstreamer1.0-plugins-good.inc
@@ -11,7 +11,7 @@ inherit gettext
PACKAGECONFIG ?= " \
${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', '', d)} \
${@bb.utils.contains('DISTRO_FEATURES', 'pulseaudio', 'pulseaudio', '', d)} \
- orc cairo flac gdk-pixbuf gudev jpeg libpng soup speex taglib \
+ orc cairo flac gdk-pixbuf jpeg libpng soup speex taglib \
"
X11DEPENDS = "virtual/libx11 libsm libxrender libxfixes libxdamage"
diff --git a/meta-openvuplus/recipes-multimedia/gstreamer1.0/gstreamer1.0-plugins-good_1.4.%.bbappend b/meta-openvuplus/recipes-multimedia/gstreamer1.0/gstreamer1.0-plugins-good_1.4.%.bbappend
deleted file mode 100644
index e6711e7..0000000
--- a/meta-openvuplus/recipes-multimedia/gstreamer1.0/gstreamer1.0-plugins-good_1.4.%.bbappend
+++ /dev/null
@@ -1,9 +0,0 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
-
-# Do not strip binary
-#INHIBIT_PACKAGE_STRIP = "1"
-#do_strip[noexec] = "1"
-#do_strip="no"
-#do_strip(){
-# pass
-#}
diff --git a/meta-openvuplus/recipes-multimedia/gstreamer1.0/gstreamer1.0-plugins-ugly.inc b/meta-openvuplus/recipes-multimedia/gstreamer1.0/gstreamer1.0-plugins-ugly.inc
index 3d6d171..6b9629e 100644
--- a/meta-openvuplus/recipes-multimedia/gstreamer1.0/gstreamer1.0-plugins-ugly.inc
+++ b/meta-openvuplus/recipes-multimedia/gstreamer1.0/gstreamer1.0-plugins-ugly.inc
@@ -3,15 +3,18 @@ require gstreamer1.0-plugins.inc
LICENSE = "GPLv2+ & LGPLv2.1+ & LGPLv2+"
LICENSE_FLAGS = "commercial"
-DEPENDS += "gstreamer1.0-plugins-base libid3tag"
+DEPENDS += "gstreamer1.0-plugins-base libid3tag libmad"
inherit gettext
PACKAGECONFIG ?= " \
orc a52dec lame mad mpeg2dec \
+ cdio dvdread amrnb amrwb mad \
"
+PACKAGECONFIG[amrnb] = "--enable-amrnb,--disable-amrnb,opencore-amr"
+PACKAGECONFIG[amrwb] = "--enable-amrwb,--disable-amrwb,opencore-amr"
PACKAGECONFIG[a52dec] = "--enable-a52dec,--disable-a52dec,liba52"
PACKAGECONFIG[cdio] = "--enable-cdio,--disable-cdio,libcdio"
PACKAGECONFIG[dvdread] = "--enable-dvdread,--disable-dvdread,libdvdread"
@@ -22,8 +25,6 @@ PACKAGECONFIG[x264] = "--enable-x264,--disable-x264,x264"
EXTRA_OECONF += " \
- --disable-amrnb \
- --disable-amrwb \
--disable-sidplay \
--disable-twolame \
${GSTREAMER_1_0_ORC} \
diff --git a/meta-openvuplus/recipes-multimedia/gstreamer1.0/gstreamer1.0-plugins-ugly_1.4.%.bbappend b/meta-openvuplus/recipes-multimedia/gstreamer1.0/gstreamer1.0-plugins-ugly_1.4.%.bbappend
deleted file mode 100644
index c9b0ac6..0000000
--- a/meta-openvuplus/recipes-multimedia/gstreamer1.0/gstreamer1.0-plugins-ugly_1.4.%.bbappend
+++ /dev/null
@@ -1,15 +0,0 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
-PACKAGECONFIG[amrnb] = "--enable-amrnb,--disable-amrnb,opencore-amr"
-PACKAGECONFIG[amrwb] = "--enable-amrwb,--disable-amrwb,opencore-amr"
-PACKAGECONFIG += "cdio dvdread amrnb amrwb mad"
-EXTRA_OECONF := "${@bb.data.getVar('EXTRA_OECONF',d,1).replace('--disable-amrnb', '--enable-amrnb').replace('--disable-amrwb', '--enable-amrwb')}"
-DEPENDS += "libmad"
-
-# Do not strip binary
-#INHIBIT_PACKAGE_STRIP = "1"
-#do_strip[noexec] = "1"
-#do_strip="no"
-#do_strip(){
-# pass
-#}
-