summaryrefslogtreecommitdiff
path: root/meta-openvuplus/recipes-multimedia
diff options
context:
space:
mode:
authorChang.H.S <jhs@dev3>2012-12-06 08:58:24 (GMT)
committerChang.H.S <jhs@dev3>2012-12-06 08:58:24 (GMT)
commit1e4d20e9ec7bb68f954002199ef5ca09511e2124 (patch)
treedd4476f0057f86be675f86c84dc7247328a281ac /meta-openvuplus/recipes-multimedia
parent537050368d52d182b76f03d63d8691f652bb415a (diff)
gst-plugins-base : add patch.
Diffstat (limited to 'meta-openvuplus/recipes-multimedia')
-rw-r--r--meta-openvuplus/recipes-multimedia/gstreamer/gst-plugins-base-0.10.36/disable-vorbis-encoder.patch54
-rw-r--r--meta-openvuplus/recipes-multimedia/gstreamer/gst-plugins-base_0.10.36.bbappend5
2 files changed, 57 insertions, 2 deletions
diff --git a/meta-openvuplus/recipes-multimedia/gstreamer/gst-plugins-base-0.10.36/disable-vorbis-encoder.patch b/meta-openvuplus/recipes-multimedia/gstreamer/gst-plugins-base-0.10.36/disable-vorbis-encoder.patch
new file mode 100644
index 0000000..da59391
--- /dev/null
+++ b/meta-openvuplus/recipes-multimedia/gstreamer/gst-plugins-base-0.10.36/disable-vorbis-encoder.patch
@@ -0,0 +1,54 @@
+--- a/configure.ac 2012-08-25 00:33:07.000000000 +0200
++++ b/configure.ac 2012-08-25 00:34:12.730232665 +0200
+@@ -806,7 +806,7 @@
+ dnl AM_PATH_VORBIS only takes two options
+ translit(dnm, m, l) AM_CONDITIONAL(USE_VORBIS, true)
+ AG_GST_CHECK_FEATURE(VORBIS, [Xiph Vorbis audio codec], vorbis, [
+- AG_GST_PKG_CHECK_MODULES(VORBIS, vorbis >= 1.0 vorbisenc >= 1.0)
++ AG_GST_PKG_CHECK_MODULES(VORBIS, vorbis >= 1.0)
+ if test $HAVE_VORBIS = no
+ then
+ XIPH_PATH_VORBIS(HAVE_VORBIS="yes", HAVE_VORBIS="no")
+--- a/ext/vorbis/gstvorbis.c 2012-08-25 00:34:05.086232463 +0200
++++ b/ext/vorbis/gstvorbis.c 2012-08-25 00:33:32.000000000 +0200
+@@ -36,10 +36,6 @@
+ static gboolean
+ plugin_init (GstPlugin * plugin)
+ {
+- if (!gst_element_register (plugin, "vorbisenc", GST_RANK_PRIMARY,
+- GST_TYPE_VORBISENC))
+- return FALSE;
+-
+ if (!gst_element_register (plugin, "vorbisdec", GST_RANK_PRIMARY,
+ gst_vorbis_dec_get_type ()))
+ return FALSE;
+@@ -52,8 +48,6 @@
+ gst_vorbis_tag_get_type ()))
+ return FALSE;
+
+- GST_DEBUG_CATEGORY_INIT (vorbisenc_debug, "vorbisenc", 0,
+- "vorbis encoding element");
+ GST_DEBUG_CATEGORY_INIT (vorbisdec_debug, "vorbisdec", 0,
+ "vorbis decoding element");
+ GST_DEBUG_CATEGORY_INIT (vorbisparse_debug, "vorbisparse", 0,
+--- a/ext/vorbis/Makefile.am 2012-08-25 00:34:05.086232463 +0200
++++ b/ext/vorbis/Makefile.am 2012-08-25 00:33:32.000000000 +0200
+@@ -6,7 +6,6 @@
+ libgstvorbis_la_SOURCES = gstvorbis.c \
+ gstvorbisdec.c \
+ gstvorbisdeclib.c \
+- gstvorbisenc.c \
+ gstvorbisparse.c \
+ gstvorbistag.c \
+ gstvorbiscommon.c
+--- a/m4/vorbis.m4 2012-08-25 00:34:05.086232463 +0200
++++ b/m4/vorbis.m4 2012-08-25 00:33:32.000000000 +0200
+@@ -26,7 +26,7 @@
+
+ VORBIS_LIBS="$VORBIS_LIBS -lvorbis -lm"
+ VORBISFILE_LIBS="-lvorbisfile"
+- VORBISENC_LIBS="-lvorbisenc"
++ VORBISENC_LIBS=""
+
+ if test "x$vorbis_includes" != "x" ; then
+ VORBIS_CFLAGS="-I$vorbis_includes"
diff --git a/meta-openvuplus/recipes-multimedia/gstreamer/gst-plugins-base_0.10.36.bbappend b/meta-openvuplus/recipes-multimedia/gstreamer/gst-plugins-base_0.10.36.bbappend
index f27d55a..a0a4798 100644
--- a/meta-openvuplus/recipes-multimedia/gstreamer/gst-plugins-base_0.10.36.bbappend
+++ b/meta-openvuplus/recipes-multimedia/gstreamer/gst-plugins-base_0.10.36.bbappend
@@ -1,7 +1,8 @@
DEPENDS += "cdparanoia orc orc-native"
-PR .= "-vuplus0"
+PR .= "-vuplus1"
-SRC_URI += "file://orc.m4-fix-location-of-orcc-when-cross-compiling.patch"
+SRC_URI += "file://orc.m4-fix-location-of-orcc-when-cross-compiling.patch \
+ file://disable-vorbis-encoder.patch"
EXTRA_OECONF += "--enable-orc"