summaryrefslogtreecommitdiff
path: root/meta-openvuplus/recipes-multimedia
diff options
context:
space:
mode:
authorhschang <chang@dev3>2013-12-31 08:56:53 (GMT)
committerhschang <chang@dev3>2014-01-02 11:30:25 (GMT)
commit0e1e40be453faff8de5e6c2d71db09f5bb2ad8a9 (patch)
tree549f19095f9c53116a9cb301f6ed30ae761c8014 /meta-openvuplus/recipes-multimedia
parent7acc07e7425e5fae2ca44528f38f8726e74353ac (diff)
set dvbaudiosink caps to support mpeg 4 profile LC and apply relevant patches.
dvbapp : append gst-plugins-bad-faad on RDEPENDS.
Diffstat (limited to 'meta-openvuplus/recipes-multimedia')
-rw-r--r--meta-openvuplus/recipes-multimedia/gstreamer/gst-plugin-dvbmediasink/Set-only-by-hardware-supported-audio-mpeg-4-profile.patch27
-rw-r--r--meta-openvuplus/recipes-multimedia/gstreamer/gst-plugin-dvbmediasink_0.10.bb3
-rw-r--r--meta-openvuplus/recipes-multimedia/gstreamer/gst-plugins-bad-0.10.23/Lower-rank-of-faad-to-prevent-using-it-if-not-necess.patch25
-rw-r--r--meta-openvuplus/recipes-multimedia/gstreamer/gst-plugins-bad_0.10.23.1.bb7
-rw-r--r--meta-openvuplus/recipes-multimedia/gstreamer/gst-plugins-good-0.10.31/0004-MatroskaDemux-Set-profile-field-in-cap-for-aac-audio.patch25
-rw-r--r--meta-openvuplus/recipes-multimedia/gstreamer/gst-plugins-good-0.10.31/0005-FlvDemux-Set-profile-field-in-cap-for-aac-audio.patch14
-rw-r--r--meta-openvuplus/recipes-multimedia/gstreamer/gst-plugins-good_0.10.31.1.bb4
7 files changed, 100 insertions, 5 deletions
diff --git a/meta-openvuplus/recipes-multimedia/gstreamer/gst-plugin-dvbmediasink/Set-only-by-hardware-supported-audio-mpeg-4-profile.patch b/meta-openvuplus/recipes-multimedia/gstreamer/gst-plugin-dvbmediasink/Set-only-by-hardware-supported-audio-mpeg-4-profile.patch
new file mode 100644
index 0000000..ba03b4f
--- /dev/null
+++ b/meta-openvuplus/recipes-multimedia/gstreamer/gst-plugin-dvbmediasink/Set-only-by-hardware-supported-audio-mpeg-4-profile.patch
@@ -0,0 +1,27 @@
+From 7ef6975f50de5430bca938ad51d00f19e51a2be1 Mon Sep 17 00:00:00 2001
+From: Athanasios Oikonomou <athoik@gmail.com>
+Date: Thu, 4 Jul 2013 20:12:04 +0300
+Subject: [PATCH 1/1] Set only by hardware supported audio mpeg 4 profile
+
+Only mpeg 4 lc profile is supported by the hardware. Other profiles
+will be decoded by software. Based on betacentauri patches.
+---
+ src/gstdvbaudiosink.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/gstdvbaudiosink.c b/src/gstdvbaudiosink.c
+index 93cb587..2b5fe73 100644
+--- a/src/gstdvbaudiosink.c
++++ b/src/gstdvbaudiosink.c
+@@ -196,7 +196,7 @@ GST_STATIC_PAD_TEMPLATE (
+ X_RAW_INT(24,24)
+ X_RAW_INT(32,24)
+ X_RAW_INT(32,32)
+- "audio/mpeg; "
++ "audio/mpeg, profile = (string) lc; "
+ "audio/x-ac3; "
+ "audio/x-private1-ac3; "
+ "audio/x-dts; "
+--
+1.7.9.5
+
diff --git a/meta-openvuplus/recipes-multimedia/gstreamer/gst-plugin-dvbmediasink_0.10.bb b/meta-openvuplus/recipes-multimedia/gstreamer/gst-plugin-dvbmediasink_0.10.bb
index f2a3eda..e2dc6aa 100644
--- a/meta-openvuplus/recipes-multimedia/gstreamer/gst-plugin-dvbmediasink_0.10.bb
+++ b/meta-openvuplus/recipes-multimedia/gstreamer/gst-plugin-dvbmediasink_0.10.bb
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://src/gstdvbaudiosink.c;beginline=1;endline=45;md5=023e
DEPENDS = "gstreamer gst-plugins-base"
BRANCH="master"
SRCREV="91738211ef106ae7d14c1ccc5c4dd26c0f2dbf58"
-PR = "r10"
+PR = "r11"
inherit autotools pkgconfig git-project
SRC_URI = "git://schwerkraft.elitedvb.net/dvbmediasink/dvbmediasink.git;protocol=git;branch=${BRANCH};tag=${SRCREV}"
@@ -16,6 +16,7 @@ SRC_URI_append_vuplus = " \
file://fix_dvbaudiosink_async_opt.patch;patch=1;pnum=1 \
file://fix_dvbvideosink_dm8000_padtemplate.patch;patch=1;pnum=1 \
file://fix_dvbaudiosink_support_ddp.patch \
+ file://Set-only-by-hardware-supported-audio-mpeg-4-profile.patch \
"
FILES_${PN} = "${libdir}/gstreamer-0.10/*.so"
diff --git a/meta-openvuplus/recipes-multimedia/gstreamer/gst-plugins-bad-0.10.23/Lower-rank-of-faad-to-prevent-using-it-if-not-necess.patch b/meta-openvuplus/recipes-multimedia/gstreamer/gst-plugins-bad-0.10.23/Lower-rank-of-faad-to-prevent-using-it-if-not-necess.patch
new file mode 100644
index 0000000..50d5500
--- /dev/null
+++ b/meta-openvuplus/recipes-multimedia/gstreamer/gst-plugins-bad-0.10.23/Lower-rank-of-faad-to-prevent-using-it-if-not-necess.patch
@@ -0,0 +1,25 @@
+From bf4042d879346bb90814856b7eb023706d1a8e15 Mon Sep 17 00:00:00 2001
+From: betacentauri <@>
+Date: Sat, 29 Jun 2013 14:33:34 +0200
+Subject: [PATCH] Lower rank of faad to prevent using it if not necessary
+
+---
+ ext/faad/gstfaad.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/ext/faad/gstfaad.c b/ext/faad/gstfaad.c
+index e106da9..82fd547 100644
+--- a/ext/faad/gstfaad.c
++++ b/ext/faad/gstfaad.c
+@@ -893,7 +893,7 @@ gst_faad_close_decoder (GstFaad * faad)
+ static gboolean
+ plugin_init (GstPlugin * plugin)
+ {
+- return gst_element_register (plugin, "faad", GST_RANK_PRIMARY, GST_TYPE_FAAD);
++ return gst_element_register (plugin, "faad", GST_RANK_SECONDARY, GST_TYPE_FAAD);
+ }
+
+ GST_PLUGIN_DEFINE (GST_VERSION_MAJOR,
+--
+1.7.9.5
+
diff --git a/meta-openvuplus/recipes-multimedia/gstreamer/gst-plugins-bad_0.10.23.1.bb b/meta-openvuplus/recipes-multimedia/gstreamer/gst-plugins-bad_0.10.23.1.bb
index 625502a..3ef5166 100644
--- a/meta-openvuplus/recipes-multimedia/gstreamer/gst-plugins-bad_0.10.23.1.bb
+++ b/meta-openvuplus/recipes-multimedia/gstreamer/gst-plugins-bad_0.10.23.1.bb
@@ -6,16 +6,16 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \
file://COPYING.LIB;md5=55ca817ccb7d5b5b66355690e9abc605 \
file://gst/tta/crc32.h;beginline=12;endline=29;md5=71a904d99ce7ae0c1cf129891b98145c"
-DEPENDS += "libmusicbrainz tremor curl libmms librtmp libmms"
+DEPENDS += "libmusicbrainz tremor curl libmms librtmp libmms faad2"
DEPENDS += "gst-plugins-base"
CONFLICTS = "librsvg"
-PR = "r4"
+PR = "r5"
GIT_PV = ""
SRCREV = "cef47d85294a0dca38631f938b81a3f0dd6891bd"
-EXTRA_OECONF += "--disable-examples --disable-experimental --disable-sdl --disable-cdaudio --disable-directfb \
+EXTRA_OECONF += "--disable-examples --disable-experimental --disable-sdl --disable-cdaudio --disable-directfb --enable-faad \
--disable-vdpau --disable-apexsink --enable-orc --disable-mpeg2enc --disable-mplex --disable-rsvg --disable-uvch264"
ARM_INSTRUCTION_SET = "arm"
@@ -29,6 +29,7 @@ SRC_URI += " \
file://0006-hlsdemux-backport.patch \
file://0007-revert-rtmp-change.patch \
file://orc.m4-fix-location-of-orcc-when-cross-compiling.patch \
+ file://Lower-rank-of-faad-to-prevent-using-it-if-not-necess.patch \
"
inherit autotools pkgconfig gettext git-project
diff --git a/meta-openvuplus/recipes-multimedia/gstreamer/gst-plugins-good-0.10.31/0004-MatroskaDemux-Set-profile-field-in-cap-for-aac-audio.patch b/meta-openvuplus/recipes-multimedia/gstreamer/gst-plugins-good-0.10.31/0004-MatroskaDemux-Set-profile-field-in-cap-for-aac-audio.patch
new file mode 100644
index 0000000..602a7de
--- /dev/null
+++ b/meta-openvuplus/recipes-multimedia/gstreamer/gst-plugins-good-0.10.31/0004-MatroskaDemux-Set-profile-field-in-cap-for-aac-audio.patch
@@ -0,0 +1,25 @@
+From f4ac6c27e670473fc2944ecc6563fff7170dede3 Mon Sep 17 00:00:00 2001
+From: betacentauri <@>
+Date: Mon, 1 Jul 2013 17:41:53 +0200
+Subject: [PATCH] [MatroskaDemux] Set profile field in cap for aac audio
+
+---
+ gst/matroska/matroska-demux.c | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/gst/matroska/matroska-demux.c b/gst/matroska/matroska-demux.c
+index e9ce024..34e92b0 100644
+--- a/gst/matroska/matroska-demux.c
++++ b/gst/matroska/matroska-demux.c
+@@ -5413,6 +5413,8 @@ gst_matroska_demux_audio_caps (GstMatroskaTrackAudioContext *
+ "mpegversion", G_TYPE_INT, mpegversion,
+ "framed", G_TYPE_BOOLEAN, TRUE, NULL);
+ gst_caps_set_simple (caps, "codec_data", GST_TYPE_BUFFER, priv, NULL);
++ if (context->codec_priv && context->codec_priv_size > 0)
++ gst_codec_utils_aac_caps_set_level_and_profile (caps, context->codec_priv, context->codec_priv_size);
+ *codec_name = g_strdup_printf ("MPEG-%d AAC audio", mpegversion);
+ gst_buffer_unref (priv);
+ }
+--
+1.7.9.5
+
diff --git a/meta-openvuplus/recipes-multimedia/gstreamer/gst-plugins-good-0.10.31/0005-FlvDemux-Set-profile-field-in-cap-for-aac-audio.patch b/meta-openvuplus/recipes-multimedia/gstreamer/gst-plugins-good-0.10.31/0005-FlvDemux-Set-profile-field-in-cap-for-aac-audio.patch
new file mode 100644
index 0000000..455edd4
--- /dev/null
+++ b/meta-openvuplus/recipes-multimedia/gstreamer/gst-plugins-good-0.10.31/0005-FlvDemux-Set-profile-field-in-cap-for-aac-audio.patch
@@ -0,0 +1,14 @@
+diff --git a/gst/flv/gstflvdemux.c b/gst/flv/gstflvdemux.c
+index 203cb76..a8d4005 100644
+--- a/gst/flv/gstflvdemux.c
++++ b/gst/flv/gstflvdemux.c
+@@ -694,6 +694,9 @@ gst_flv_demux_audio_negotiate (GstFlvDemux * demux, guint32 codec_tag,
+ caps = gst_caps_new_simple ("audio/mpeg",
+ "mpegversion", G_TYPE_INT, 4, "framed", G_TYPE_BOOLEAN, TRUE,
+ "stream-format", G_TYPE_STRING, "raw", NULL);
++ if (demux->audio_codec_data &&
++ GST_BUFFER_SIZE (demux->audio_codec_data) >= 2)
++ gst_codec_utils_aac_caps_set_level_and_profile (caps, GST_BUFFER_DATA (demux->audio_codec_data), GST_BUFFER_SIZE (demux->audio_codec_data));
+ break;
+ }
+ case 7:
diff --git a/meta-openvuplus/recipes-multimedia/gstreamer/gst-plugins-good_0.10.31.1.bb b/meta-openvuplus/recipes-multimedia/gstreamer/gst-plugins-good_0.10.31.1.bb
index f735986..796e9c4 100644
--- a/meta-openvuplus/recipes-multimedia/gstreamer/gst-plugins-good_0.10.31.1.bb
+++ b/meta-openvuplus/recipes-multimedia/gstreamer/gst-plugins-good_0.10.31.1.bb
@@ -8,7 +8,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343 \
DEPENDS += "cdparanoia cairo jpeg libpng zlib libid3tag flac speex libsoup-2.4"
DEPENDS += "gst-plugins-base"
-PR = "r3"
+PR = "r4"
GIT_PV = ""
SRCREV = "7768342230450559509e3e593b2ea33e81ea0ca4"
@@ -22,6 +22,8 @@ SRC_URI = "git://anongit.freedesktop.org/gstreamer/${PN}"
SRC_URI += " \
file://orc.m4-fix-location-of-orcc-when-cross-compiling.patch \
file://0001-accept-substream-syncwords-DTS-HD.patch \
+ file://0004-MatroskaDemux-Set-profile-field-in-cap-for-aac-audio.patch \
+ file://0005-FlvDemux-Set-profile-field-in-cap-for-aac-audio.patch \
file://rtsp-check-all-protocols.patch;apply=yes;striplevel=1 \
"