summaryrefslogtreecommitdiff
path: root/meta-openvuplus/recipes-multimedia
diff options
context:
space:
mode:
authorhschang <chang@dev3>2014-07-15 08:00:38 (GMT)
committerhschang <chang@dev3>2014-07-17 02:04:41 (GMT)
commit0d6acda3c9daf671af6c3a8e02270bae96286cd6 (patch)
treeff61410bdc40a34314eb50c3fd010007d92ae238 /meta-openvuplus/recipes-multimedia
parent5a2998f220be01927c231fee1c9f2a6c6300ce7a (diff)
Add model soloSE & update kernel and drivers.
* Add model SoloSE * Update Kernel 3.13.5(solo2, duo2, solose) * Update Kernel 3.9.6(duo, solo, uno, ultimo) * Update r8192cu (4.0.2) * Add patch for usbtunerhelper * Update bridge-utils (1.4 -> 1.5) * Update dvbapp - Set sync PCR at PIP mode. * Update drivers - 20140715(duo, solo, duo2, solo2, solose) - 20140716(uno, ultimo) - Support SoloSE - Switch to Kernel 3.13.5(solo2, duo2, solose) - Switch to Kernel 3.9.6(duo, solo, uno, ultimo) - Fix sound drop in radio channel - Improve PIP(solo2, duo2, solose, Needs E2 update) - Allocate more memory to linux(duo2) - Improve media playback
Diffstat (limited to 'meta-openvuplus/recipes-multimedia')
-rw-r--r--meta-openvuplus/recipes-multimedia/gstreamer/gst-plugins-good-0.10.31/0001-v4l2_calls-define-V4L2_CID_HCENTER-and-V4L2_CID_VCEN.patch45
-rw-r--r--meta-openvuplus/recipes-multimedia/gstreamer/gst-plugins-good_0.10.31.1.bb5
2 files changed, 49 insertions, 1 deletions
diff --git a/meta-openvuplus/recipes-multimedia/gstreamer/gst-plugins-good-0.10.31/0001-v4l2_calls-define-V4L2_CID_HCENTER-and-V4L2_CID_VCEN.patch b/meta-openvuplus/recipes-multimedia/gstreamer/gst-plugins-good-0.10.31/0001-v4l2_calls-define-V4L2_CID_HCENTER-and-V4L2_CID_VCEN.patch
new file mode 100644
index 0000000..bd0de58
--- /dev/null
+++ b/meta-openvuplus/recipes-multimedia/gstreamer/gst-plugins-good-0.10.31/0001-v4l2_calls-define-V4L2_CID_HCENTER-and-V4L2_CID_VCEN.patch
@@ -0,0 +1,45 @@
+From ccb01de8096a32d86d47b0d92ec3416c57ee4d25 Mon Sep 17 00:00:00 2001
+From: Bruce Ashfield <bruce.ashfield@windriver.com>
+Date: Thu, 22 Aug 2013 12:15:54 -0400
+Subject: [PATCH] v4l2_calls: define V4L2_CID_HCENTER and V4L2_CID_VCENTER
+
+kernel commit 24b9f5017 [[media] V4L: Remove deprecated image centering controls]
+removed the definitions of V4L2_CID_HCENTER and V4L2_CID_VCENTER after three
+years of depreciation.
+
+The ioctl values are still free, and the case statement which processess them
+in v4l2 userspace falls through to the proper replacement. So in the short
+term, we can explicitly define them using the old absolute values, and everything
+will work.
+
+Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
+---
+ sys/v4l2/v4l2_calls.c | 9 +++++++--
+ 1 file changed, 7 insertions(+), 2 deletions(-)
+
+diff --git a/sys/v4l2/v4l2_calls.c b/sys/v4l2/v4l2_calls.c
+index 309bfb6..3c64544 100644
+--- a/sys/v4l2/v4l2_calls.c
++++ b/sys/v4l2/v4l2_calls.c
+@@ -54,11 +54,16 @@
+ #include "gst/gst-i18n-plugin.h"
+
+ /* Those are ioctl calls */
++
++/* V4L2_CID_HCENTER has been removed from the mainline kernel, but
++ the ioctl space is still present. Since these values fall through
++ to their replacement, it is safe (in the short term) to re-use the
++ old values explictily */
+ #ifndef V4L2_CID_HCENTER
+-#define V4L2_CID_HCENTER V4L2_CID_HCENTER_DEPRECATED
++#define V4L2_CID_HCENTER V4L2_CID_BASE+22
+ #endif
+ #ifndef V4L2_CID_VCENTER
+-#define V4L2_CID_VCENTER V4L2_CID_VCENTER_DEPRECATED
++#define V4L2_CID_VCENTER V4L2_CID_BASE+23
+ #endif
+
+ GST_DEBUG_CATEGORY_EXTERN (v4l2_debug);
+--
+1.7.10.4
+
diff --git a/meta-openvuplus/recipes-multimedia/gstreamer/gst-plugins-good_0.10.31.1.bb b/meta-openvuplus/recipes-multimedia/gstreamer/gst-plugins-good_0.10.31.1.bb
index 796e9c4..de33221 100644
--- a/meta-openvuplus/recipes-multimedia/gstreamer/gst-plugins-good_0.10.31.1.bb
+++ b/meta-openvuplus/recipes-multimedia/gstreamer/gst-plugins-good_0.10.31.1.bb
@@ -8,7 +8,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343 \
DEPENDS += "cdparanoia cairo jpeg libpng zlib libid3tag flac speex libsoup-2.4"
DEPENDS += "gst-plugins-base"
-PR = "r4"
+PR = "r5"
GIT_PV = ""
SRCREV = "7768342230450559509e3e593b2ea33e81ea0ca4"
@@ -27,6 +27,9 @@ SRC_URI += " \
file://rtsp-check-all-protocols.patch;apply=yes;striplevel=1 \
"
+SRC_URI += "file://0001-v4l2_calls-define-V4L2_CID_HCENTER-and-V4L2_CID_VCEN.patch"
+
+
do_common_update() {
cd ${S}
# Make sure we have common