summaryrefslogtreecommitdiff
path: root/meta-openvuplus/recipes-multimedia/gstreamer
diff options
context:
space:
mode:
authorkos <kos@dev3>2012-12-11 05:33:09 (GMT)
committerkos <kos@dev3>2012-12-11 05:33:09 (GMT)
commit462d73d2987416bb23b756e4379a1c830e925604 (patch)
tree7676a7ac20c073bc7fb7d56b30b21f44f89febb8 /meta-openvuplus/recipes-multimedia/gstreamer
parent42f0cc9ac2256e062368452f98b9db4b62ae8359 (diff)
parentf62149ebafebc2bc0c434b320433e0f1e0daf756 (diff)
Merge branch 'master' of http://192.168.102.71/openvuplus
Conflicts: meta-openvuplus/recipes-vuplus/enigma2/enigma2.bb meta-openvuplus/recipes-vuplus/tasks/task-vuplus-enigma2.inc
Diffstat (limited to 'meta-openvuplus/recipes-multimedia/gstreamer')
-rwxr-xr-xmeta-openvuplus/recipes-multimedia/gstreamer/gst-plugin-dvbmediasink/fix_dvbaudiosink_async_opt.patch19
-rw-r--r--meta-openvuplus/recipes-multimedia/gstreamer/gst-plugin-dvbmediasink/fix_dvbvideosink_dm8000_padtemplate.patch21
-rw-r--r--meta-openvuplus/recipes-multimedia/gstreamer/gst-plugin-dvbmediasink_0.10.bb25
-rw-r--r--meta-openvuplus/recipes-multimedia/gstreamer/gst-plugins-base-0.10.36/disable-vorbis-encoder.patch54
-rw-r--r--meta-openvuplus/recipes-multimedia/gstreamer/gst-plugins-base_0.10.36.bbappend5
5 files changed, 116 insertions, 8 deletions
diff --git a/meta-openvuplus/recipes-multimedia/gstreamer/gst-plugin-dvbmediasink/fix_dvbaudiosink_async_opt.patch b/meta-openvuplus/recipes-multimedia/gstreamer/gst-plugin-dvbmediasink/fix_dvbaudiosink_async_opt.patch
new file mode 100755
index 0000000..2961c28
--- /dev/null
+++ b/meta-openvuplus/recipes-multimedia/gstreamer/gst-plugin-dvbmediasink/fix_dvbaudiosink_async_opt.patch
@@ -0,0 +1,19 @@
+commit 962f9068bfd74aefe65a63ccdd89e417ef2ca827
+Author: Chang.H.S <jhs@dev3>
+Date: Mon Dec 10 16:07:30 2012 +0900
+
+ 2
+
+diff --git a/src/gstdvbaudiosink.c b/src/gstdvbaudiosink.c
+index 0966d33..ff54ab6 100644
+--- a/src/gstdvbaudiosink.c
++++ b/src/gstdvbaudiosink.c
+@@ -354,7 +354,7 @@ gst_dvbaudiosink_init (GstDVBAudioSink *klass, GstDVBAudioSinkClass * gclass)
+ klass->dump_filename = NULL;
+
+ gst_base_sink_set_sync (GST_BASE_SINK(klass), FALSE);
+- gst_base_sink_set_async_enabled (GST_BASE_SINK(klass), TRUE);
++ gst_base_sink_set_async_enabled (GST_BASE_SINK(klass), FALSE);
+ }
+
+ static void
diff --git a/meta-openvuplus/recipes-multimedia/gstreamer/gst-plugin-dvbmediasink/fix_dvbvideosink_dm8000_padtemplate.patch b/meta-openvuplus/recipes-multimedia/gstreamer/gst-plugin-dvbmediasink/fix_dvbvideosink_dm8000_padtemplate.patch
new file mode 100644
index 0000000..c0520b3
--- /dev/null
+++ b/meta-openvuplus/recipes-multimedia/gstreamer/gst-plugin-dvbmediasink/fix_dvbvideosink_dm8000_padtemplate.patch
@@ -0,0 +1,21 @@
+commit 34a5871e18b59f852a86ac131dba020b31d0ba0e
+Author: Chang.H.S <jhs@dev3>
+Date: Mon Dec 10 16:06:20 2012 +0900
+
+ 1
+
+diff --git a/src/gstdvbvideosink.c b/src/gstdvbvideosink.c
+index fcd8fed..b3ce35f 100644
+--- a/src/gstdvbvideosink.c
++++ b/src/gstdvbvideosink.c
+@@ -316,8 +316,8 @@ gst_dvbvideosink_base_init (gpointer klass)
+ GST_INFO ("model is DM7020HD... set bcm7405 caps");
+ } else if ( !strncasecmp(string, "DM8000", 6) ) {
+ hwtype = DM8000;
+- hwtemplate = &sink_factory_bcm7400;
+- GST_INFO ("model is DM8000... set bcm7400 caps");
++ hwtemplate = &sink_factory_bcm7405;
++ GST_INFO ("model is DM8000... set bcm7405 caps");
+ } else if ( !strncasecmp(string, "DM800", 5) ) {
+ hwtype = DM800;
+ hwtemplate = &sink_factory_bcm7401;
diff --git a/meta-openvuplus/recipes-multimedia/gstreamer/gst-plugin-dvbmediasink_0.10.bb b/meta-openvuplus/recipes-multimedia/gstreamer/gst-plugin-dvbmediasink_0.10.bb
index 11febfc..e1070bd 100644
--- a/meta-openvuplus/recipes-multimedia/gstreamer/gst-plugin-dvbmediasink_0.10.bb
+++ b/meta-openvuplus/recipes-multimedia/gstreamer/gst-plugin-dvbmediasink_0.10.bb
@@ -1,15 +1,28 @@
SUMMARY = "Plugin for gstreamer: dvbmediasink"
SECTION = "multimedia"
+MAINTAINER = "Felix Domke <tmbinc@openembedded.org>"
LICENSE = "MIT | LGPLv2.1"
-LIC_FILES_CHKSUM = "file://src/gstdvbaudiosink.c;beginline=1;endline=45;md5=023ebb8eaef9b8cce8591a9d96638392 \
- file://src/gstdvbvideosink.c;beginline=1;endline=44;md5=b597d3f0a4e3b49db42d2b5140bd7004"
+LIC_FILES_CHKSUM = "file://src/gstdvbaudiosink.c;md5=1b3d0c8e4a67b80e29e1a8bf0e7d568c \
+ file://src/gstdvbvideosink.c;md5=01003daf0d4030982ef58f3f8540bd33"
+
DEPENDS = "gstreamer gst-plugins-base"
-SRCREV = "1bc9f47255396df4b3119a02790c4e864566560a"
-PR = "r5"
-SCHWERKRAFT_PROJECT = "dvbmediasink"
+#SRCREV="15a323fd769d4546bc454bfd81848aa43d655f3d"
+SRCREV="1bc9f47255396df4b3119a02790c4e864566560a"
+SRCDATE="20110210"
+BRANCH="master"
+PV = "0.10+git${SRCDATE}"
+PR = "r6"
+
+inherit autotools pkgconfig
+SRC_URI = "git://schwerkraft.elitedvb.net/dvbmediasink/dvbmediasink.git;protocol=git;branch=${BRANCH};tag=${SRCREV}"
+
+SRC_URI_append_vuplus = " \
+ file://fix_dvbaudiosink_async_opt.patch;patch=1;pnum=1 \
+ file://fix_dvbvideosink_dm8000_padtemplate.patch;patch=1;pnum=1 \
+ "
-inherit autotools schwerkraft-git
+S = "${WORKDIR}/git"
FILES_${PN} = "${libdir}/gstreamer-0.10/*.so"
FILES_${PN}-dev += "${libdir}/gstreamer-0.10/*.la"
diff --git a/meta-openvuplus/recipes-multimedia/gstreamer/gst-plugins-base-0.10.36/disable-vorbis-encoder.patch b/meta-openvuplus/recipes-multimedia/gstreamer/gst-plugins-base-0.10.36/disable-vorbis-encoder.patch
new file mode 100644
index 0000000..da59391
--- /dev/null
+++ b/meta-openvuplus/recipes-multimedia/gstreamer/gst-plugins-base-0.10.36/disable-vorbis-encoder.patch
@@ -0,0 +1,54 @@
+--- a/configure.ac 2012-08-25 00:33:07.000000000 +0200
++++ b/configure.ac 2012-08-25 00:34:12.730232665 +0200
+@@ -806,7 +806,7 @@
+ dnl AM_PATH_VORBIS only takes two options
+ translit(dnm, m, l) AM_CONDITIONAL(USE_VORBIS, true)
+ AG_GST_CHECK_FEATURE(VORBIS, [Xiph Vorbis audio codec], vorbis, [
+- AG_GST_PKG_CHECK_MODULES(VORBIS, vorbis >= 1.0 vorbisenc >= 1.0)
++ AG_GST_PKG_CHECK_MODULES(VORBIS, vorbis >= 1.0)
+ if test $HAVE_VORBIS = no
+ then
+ XIPH_PATH_VORBIS(HAVE_VORBIS="yes", HAVE_VORBIS="no")
+--- a/ext/vorbis/gstvorbis.c 2012-08-25 00:34:05.086232463 +0200
++++ b/ext/vorbis/gstvorbis.c 2012-08-25 00:33:32.000000000 +0200
+@@ -36,10 +36,6 @@
+ static gboolean
+ plugin_init (GstPlugin * plugin)
+ {
+- if (!gst_element_register (plugin, "vorbisenc", GST_RANK_PRIMARY,
+- GST_TYPE_VORBISENC))
+- return FALSE;
+-
+ if (!gst_element_register (plugin, "vorbisdec", GST_RANK_PRIMARY,
+ gst_vorbis_dec_get_type ()))
+ return FALSE;
+@@ -52,8 +48,6 @@
+ gst_vorbis_tag_get_type ()))
+ return FALSE;
+
+- GST_DEBUG_CATEGORY_INIT (vorbisenc_debug, "vorbisenc", 0,
+- "vorbis encoding element");
+ GST_DEBUG_CATEGORY_INIT (vorbisdec_debug, "vorbisdec", 0,
+ "vorbis decoding element");
+ GST_DEBUG_CATEGORY_INIT (vorbisparse_debug, "vorbisparse", 0,
+--- a/ext/vorbis/Makefile.am 2012-08-25 00:34:05.086232463 +0200
++++ b/ext/vorbis/Makefile.am 2012-08-25 00:33:32.000000000 +0200
+@@ -6,7 +6,6 @@
+ libgstvorbis_la_SOURCES = gstvorbis.c \
+ gstvorbisdec.c \
+ gstvorbisdeclib.c \
+- gstvorbisenc.c \
+ gstvorbisparse.c \
+ gstvorbistag.c \
+ gstvorbiscommon.c
+--- a/m4/vorbis.m4 2012-08-25 00:34:05.086232463 +0200
++++ b/m4/vorbis.m4 2012-08-25 00:33:32.000000000 +0200
+@@ -26,7 +26,7 @@
+
+ VORBIS_LIBS="$VORBIS_LIBS -lvorbis -lm"
+ VORBISFILE_LIBS="-lvorbisfile"
+- VORBISENC_LIBS="-lvorbisenc"
++ VORBISENC_LIBS=""
+
+ if test "x$vorbis_includes" != "x" ; then
+ VORBIS_CFLAGS="-I$vorbis_includes"
diff --git a/meta-openvuplus/recipes-multimedia/gstreamer/gst-plugins-base_0.10.36.bbappend b/meta-openvuplus/recipes-multimedia/gstreamer/gst-plugins-base_0.10.36.bbappend
index f27d55a..a0a4798 100644
--- a/meta-openvuplus/recipes-multimedia/gstreamer/gst-plugins-base_0.10.36.bbappend
+++ b/meta-openvuplus/recipes-multimedia/gstreamer/gst-plugins-base_0.10.36.bbappend
@@ -1,7 +1,8 @@
DEPENDS += "cdparanoia orc orc-native"
-PR .= "-vuplus0"
+PR .= "-vuplus1"
-SRC_URI += "file://orc.m4-fix-location-of-orcc-when-cross-compiling.patch"
+SRC_URI += "file://orc.m4-fix-location-of-orcc-when-cross-compiling.patch \
+ file://disable-vorbis-encoder.patch"
EXTRA_OECONF += "--enable-orc"