summaryrefslogtreecommitdiff
path: root/meta-openvuplus/recipes-extended
diff options
context:
space:
mode:
authorChang.H.S <jhs@dev3>2012-11-30 09:09:08 (GMT)
committerChang.H.S <jhs@dev3>2012-11-30 09:21:08 (GMT)
commit0e6c5d97c12ae5eb100dc835a2ec6df30c9ebb95 (patch)
treea8b60d7dfd416b50deec6ac9282381aa5312f965 /meta-openvuplus/recipes-extended
parente56f897c120c6a2c70e6b3129dde975f92d105cc (diff)
relocate packages on recipes-base/recipes-enigma2/recipes-wlan.
Diffstat (limited to 'meta-openvuplus/recipes-extended')
-rw-r--r--meta-openvuplus/recipes-extended/hddtemp/hddtemp/hddtemp-no-nls-support.patch66
-rw-r--r--meta-openvuplus/recipes-extended/hddtemp/hddtemp_0.3-beta15.bb22
-rw-r--r--meta-openvuplus/recipes-extended/joe/joe_3.7.bb14
-rw-r--r--meta-openvuplus/recipes-extended/mc/mc-4.8.1/optional-extfs-dir.patch18
-rw-r--r--meta-openvuplus/recipes-extended/mc/mc-4.8.1/optional-hints.patch17
-rw-r--r--meta-openvuplus/recipes-extended/mc/mc-4.8.1/optional-sfs-ini.patch17
-rw-r--r--meta-openvuplus/recipes-extended/mc/mc-4.8.1/optional-syntax-file.patch18
-rw-r--r--meta-openvuplus/recipes-extended/mc/mc_4.8.1.bbappend26
-rw-r--r--meta-openvuplus/recipes-extended/ncdu/ncdu_1.8.bb11
-rw-r--r--meta-openvuplus/recipes-extended/shadow/shadow-securetty/securetty275
-rw-r--r--meta-openvuplus/recipes-extended/shadow/shadow-securetty_4.1.4.3.bbappend3
-rw-r--r--meta-openvuplus/recipes-extended/smartmontools/smartmontools.inc10
-rw-r--r--meta-openvuplus/recipes-extended/smartmontools/smartmontools_5.42.bb6
13 files changed, 503 insertions, 0 deletions
diff --git a/meta-openvuplus/recipes-extended/hddtemp/hddtemp/hddtemp-no-nls-support.patch b/meta-openvuplus/recipes-extended/hddtemp/hddtemp/hddtemp-no-nls-support.patch
new file mode 100644
index 0000000..8f6b9c3
--- /dev/null
+++ b/meta-openvuplus/recipes-extended/hddtemp/hddtemp/hddtemp-no-nls-support.patch
@@ -0,0 +1,66 @@
+diff -ru hddtemp-0.3-beta15.orig/configure.in hddtemp-0.3-beta15/configure.in
+--- hddtemp-0.3-beta15.orig/configure.in 2005-10-17 20:14:19.000000000 +0100
++++ hddtemp-0.3-beta15/configure.in 2008-06-27 00:00:46.000000000 +0100
+@@ -17,6 +17,7 @@
+ # append the host alias to the tools for cross compiling
+ AC_HEADER_STDC
+ AC_CHECK_HEADERS(fcntl.h)
++AC_CHECK_HEADERS(iconv.h)
+ AC_CHECK_HEADERS(netinet/in.h)
+ AC_CHECK_TYPE(in_addr_t, ,[AC_DEFINE_UNQUOTED([in_addr_t], [uint32_t], [Define to 'uint32_t' if <netinet/in.h> does not define.])], [#include <netinet/in.h>])
+
+@@ -29,6 +30,8 @@
+ AM_GNU_GETTEXT
+ #AM_GNU_GETTEXT([external])
+
++AC_CHECK_FUNCS([bindtextdomain textdomain iconv])
++
+ dnl reasonable guesses for where stuff is installed
+ dnl if we don't do that now, the config.h will use ${prefix}
+ dnl for DEFAULT_DATABASE_PATH.
+diff -ru hddtemp-0.3-beta15.orig/src/hddtemp.c hddtemp-0.3-beta15/src/hddtemp.c
+--- hddtemp-0.3-beta15.orig/src/hddtemp.c 2006-04-19 03:37:35.000000000 +0100
++++ hddtemp-0.3-beta15/src/hddtemp.c 2008-06-26 23:59:40.000000000 +0100
+@@ -276,8 +276,12 @@
+ backtrace_sigbus();
+
+ setlocale (LC_ALL, "");
++#ifdef HAVE_BINDTEXTDOMAIN
+ bindtextdomain (PACKAGE, LOCALEDIR);
++#endif
++#ifdef HAVE_TEXTDOMAIN
+ textdomain (PACKAGE);
++#endif
+
+ show_db = debug = numeric = quiet = wakeup = af_hint = syslog_interval = 0;
+ unit = DEFAULT;
+diff -ru hddtemp-0.3-beta15.orig/src/utf8.c hddtemp-0.3-beta15/src/utf8.c
+--- hddtemp-0.3-beta15.orig/src/utf8.c 2006-04-19 03:37:02.000000000 +0100
++++ hddtemp-0.3-beta15/src/utf8.c 2008-06-27 00:02:15.000000000 +0100
+@@ -23,7 +23,9 @@
+
+ // Standard includes
+ #include <stdlib.h>
++#ifdef HAVE_ICONV_H
+ #include <iconv.h>
++#endif
+ #include <langinfo.h>
+ #include <locale.h>
+ #include <string.h>
+@@ -34,6 +36,7 @@
+
+ static char *iconv_from_utf8_to_locale(const char *string, const char* fallback_string)
+ {
++#ifdef HAVE_ICONV
+ const size_t buffer_inc = 80; // Increment buffer size in 80 bytes step
+ const char *charset;
+ iconv_t cd;
+@@ -93,6 +96,8 @@
+ if (dest_buffer != NULL)
+ free(dest_buffer); // free buffer
+ free(src_buffer); // free string
++#endif
++
+ return strdup(fallback_string); // and return fallback string
+ }
+
diff --git a/meta-openvuplus/recipes-extended/hddtemp/hddtemp_0.3-beta15.bb b/meta-openvuplus/recipes-extended/hddtemp/hddtemp_0.3-beta15.bb
new file mode 100644
index 0000000..8ef9a2c
--- /dev/null
+++ b/meta-openvuplus/recipes-extended/hddtemp/hddtemp_0.3-beta15.bb
@@ -0,0 +1,22 @@
+SUMMARY = "Hard disk temperature monitor daemon"
+SECTION = "console/network"
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://GPL-2;md5=eb723b61539feef013de476e68b5c50a"
+PR = "r1"
+
+SRC_URI = "http://download.savannah.nongnu.org/releases/${PN}/${PN}-${PV}.tar.bz2;name=tar \
+ http://download.savannah.nongnu.org/releases/${PN}/hddtemp.db;name=db \
+ file://hddtemp-no-nls-support.patch"
+SRC_URI[tar.md5sum] = "8b829339e1ae9df701684ec239021bb8"
+SRC_URI[tar.sha256sum] = "618541584054093d53be8a2d9e81c97174f30f00af91cb8700a97e442d79ef5b"
+SRC_URI[db.md5sum] = "5321858f8c028d4b1a91a8a5f951f2f8"
+SRC_URI[db.sha256sum] = "8b19e70228214562eb10a46bd73b6ea8601e996f2d6527907b560d35b33f5240"
+
+inherit autotools gettext
+
+FILES_${PN} += "/usr/share/misc/hddtemp.db"
+
+do_install_append() {
+ install -d ${D}/usr/share/misc/
+ install -m 0644 ${WORKDIR}/hddtemp.db ${D}/usr/share/misc/hddtemp.db
+}
diff --git a/meta-openvuplus/recipes-extended/joe/joe_3.7.bb b/meta-openvuplus/recipes-extended/joe/joe_3.7.bb
new file mode 100644
index 0000000..436fd07
--- /dev/null
+++ b/meta-openvuplus/recipes-extended/joe/joe_3.7.bb
@@ -0,0 +1,14 @@
+SUMMARY = "Console text editor with good functionality, good choice for vi-haters."
+HOMEPAGE = "http://joe-editor.sourceforge.net/"
+SECTION = "console/utils"
+LICENSE = "GPL-1.0"
+LIC_FILES_CHKSUM = "file://COPYING;md5=da10ed7cf8038981c580e11c1d3e8fb6"
+PR = "r2"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/joe-editor/joe-${PV}.tar.gz"
+SRC_URI[md5sum] = "66de1b073e869ba12abbfcde3885c577"
+SRC_URI[sha256sum] = "cae456e1ad5a8c1d3c94920a3416c2347277739b260e3494d3bc0f2b9b73106f"
+
+inherit autotools
+
+RDEPENDS_${PN} = "ncurses-terminfo"
diff --git a/meta-openvuplus/recipes-extended/mc/mc-4.8.1/optional-extfs-dir.patch b/meta-openvuplus/recipes-extended/mc/mc-4.8.1/optional-extfs-dir.patch
new file mode 100644
index 0000000..aebb31e
--- /dev/null
+++ b/meta-openvuplus/recipes-extended/mc/mc-4.8.1/optional-extfs-dir.patch
@@ -0,0 +1,18 @@
+Upstream-Status: Inappropriate [Configuration]
+
+Don't show "Warning: cannot open /usr/libexec/mc/extfs.d directory",
+because it's packaged separately.
+
+Signed-off-by: Andreas Oberritter <obi@opendreambox.org>
+
+--- mc-4.8.1/src/vfs/extfs/extfs.c.orig 2012-05-10 15:50:04.633833530 +0200
++++ mc-4.8.1/src/vfs/extfs/extfs.c 2012-05-10 15:50:20.349833289 +0200
+@@ -1558,8 +1558,6 @@
+ * appear on screen. */
+ if (dir == NULL)
+ {
+- if (!silent)
+- fprintf (stderr, _("Warning: cannot open %s directory\n"), dirname);
+ g_free (dirname);
+ return FALSE;
+ }
diff --git a/meta-openvuplus/recipes-extended/mc/mc-4.8.1/optional-hints.patch b/meta-openvuplus/recipes-extended/mc/mc-4.8.1/optional-hints.patch
new file mode 100644
index 0000000..a0ccdcd
--- /dev/null
+++ b/meta-openvuplus/recipes-extended/mc/mc-4.8.1/optional-hints.patch
@@ -0,0 +1,17 @@
+Upstream-Status: Pending
+
+Fixes a text drawing issue if hints are unavailable.
+
+Signed-off-by: Andreas Oberritter <obi@opendreambox.org>
+
+--- mc-4.8.1/src/filemanager/midnight.c.orig 2012-05-10 15:30:56.645804130 +0200
++++ mc-4.8.1/src/filemanager/midnight.c 2012-05-10 15:31:27.601804920 +0200
+@@ -1587,7 +1587,7 @@
+ {
+ char text[BUF_SMALL];
+
+- g_snprintf (text, sizeof (text), _("GNU Midnight Commander %s\n"), VERSION);
++ g_snprintf (text, sizeof (text), _("GNU Midnight Commander %s"), VERSION);
+ set_hintbar (text);
+ }
+ }
diff --git a/meta-openvuplus/recipes-extended/mc/mc-4.8.1/optional-sfs-ini.patch b/meta-openvuplus/recipes-extended/mc/mc-4.8.1/optional-sfs-ini.patch
new file mode 100644
index 0000000..fd5afd3
--- /dev/null
+++ b/meta-openvuplus/recipes-extended/mc/mc-4.8.1/optional-sfs-ini.patch
@@ -0,0 +1,17 @@
+Upstream-Status: Inappropriate [Configuration]
+
+Don't show "sfs_init(): Warning: file /etc/mc/sfs.ini not found",
+because it's packaged separately.
+
+Signed-off-by: Andreas Oberritter <obi@opendreambox.org>
+
+--- mc-4.8.1/src/vfs/sfs/sfs.c.orig 2012-05-10 15:48:05.405830465 +0200
++++ mc-4.8.1/src/vfs/sfs/sfs.c 2012-05-10 15:48:24.389830919 +0200
+@@ -419,7 +419,6 @@
+
+ if (cfg == NULL)
+ {
+- fprintf (stderr, _("%s: Warning: file %s not found\n"), "sfs_init()", mc_sfsini);
+ g_free (mc_sfsini);
+ return 0;
+ }
diff --git a/meta-openvuplus/recipes-extended/mc/mc-4.8.1/optional-syntax-file.patch b/meta-openvuplus/recipes-extended/mc/mc-4.8.1/optional-syntax-file.patch
new file mode 100644
index 0000000..ee0ee46
--- /dev/null
+++ b/meta-openvuplus/recipes-extended/mc/mc-4.8.1/optional-syntax-file.patch
@@ -0,0 +1,18 @@
+Upstream-Status: Inappropriate [Configuration]
+
+Don't show an error message if the syntax file can't
+be opened, because it's packaged separately.
+
+Signed-off-by: Andreas Oberritter <obi@opendreambox.org>
+
+--- mc-4.8.1/src/editor/syntax.c.orig 2011-12-12 10:15:38.000000000 +0100
++++ mc-4.8.1/src/editor/syntax.c 2012-05-10 15:07:56.517768788 +0200
+@@ -1522,8 +1522,6 @@
+ if (r == -1)
+ {
+ edit_free_syntax_rules (edit);
+- message (D_ERROR, _("Load syntax file"),
+- _("Cannot open file %s\n%s"), f, unix_error_string (errno));
+ }
+ else if (r != 0)
+ {
diff --git a/meta-openvuplus/recipes-extended/mc/mc_4.8.1.bbappend b/meta-openvuplus/recipes-extended/mc/mc_4.8.1.bbappend
new file mode 100644
index 0000000..73b41c6
--- /dev/null
+++ b/meta-openvuplus/recipes-extended/mc/mc_4.8.1.bbappend
@@ -0,0 +1,26 @@
+PR .= "-vuplus0"
+
+SRC_URI += "file://optional-extfs-dir.patch \
+ file://optional-hints.patch \
+ file://optional-sfs-ini.patch \
+ file://optional-syntax-file.patch"
+
+PACKAGES += "${PN}-full"
+
+RDEPENDS_${PN} = ""
+RDEPENDS_${PN}-full = "ncurses-terminfo"
+
+RSUGGESTS_${PN} = "${PN}-full"
+
+FILES_${PN} = " \
+ ${bindir}/* \
+ ${sysconfdir}/mc/filehighlight.ini \
+ ${sysconfdir}/mc/*.ext \
+ ${sysconfdir}/mc/*.keymap \
+ ${sysconfdir}/mc/*.menu \
+ ${datadir}/${BPN}/mc.* \
+ ${datadir}/${BPN}/skins/default.ini \
+"
+FILES_${PN}-full = "${libexecdir}/* ${sysconfdir} ${datadir}/${BPN}"
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/${P}:"
diff --git a/meta-openvuplus/recipes-extended/ncdu/ncdu_1.8.bb b/meta-openvuplus/recipes-extended/ncdu/ncdu_1.8.bb
new file mode 100644
index 0000000..75e0641
--- /dev/null
+++ b/meta-openvuplus/recipes-extended/ncdu/ncdu_1.8.bb
@@ -0,0 +1,11 @@
+SUMMARY = "NCurses Disk Usage"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://COPYING;md5=321d4ec4e1e7746028446d003a975868"
+DEPENDS = "ncurses"
+PR = "r1"
+
+SRC_URI = "http://dev.yorhel.nl/download/ncdu-${PV}.tar.gz"
+SRC_URI[md5sum] = "94d7a821f8a0d7ba8ef3dd926226f7d5"
+SRC_URI[sha256sum] = "42aaf0418c05e725b39b220166a9c604a9c54c0fbf7692c9c119b36d0ed5d099"
+
+inherit autotools
diff --git a/meta-openvuplus/recipes-extended/shadow/shadow-securetty/securetty b/meta-openvuplus/recipes-extended/shadow/shadow-securetty/securetty
new file mode 100644
index 0000000..e1dfa24
--- /dev/null
+++ b/meta-openvuplus/recipes-extended/shadow/shadow-securetty/securetty
@@ -0,0 +1,275 @@
+# /etc/securetty: list of terminals on which root is allowed to login.
+# See securetty(5) and login(1).
+console
+
+# Standard serial ports
+ttyS0
+ttyS1
+ttyS2
+ttyS3
+
+# Samsung ARM SoCs
+ttySAC0
+ttySAC1
+ttySAC2
+ttySAC3
+
+# TI OMAP SoCs
+ttyO0
+ttyO1
+ttyO2
+ttyO3
+
+# USB dongles
+ttyUSB0
+ttyUSB1
+ttyUSB2
+
+# USB serial gadget
+ttyGS0
+
+# PowerMac
+ttyPZ0
+ttyPZ1
+ttyPZ2
+ttyPZ3
+
+# Embedded MPC platforms
+ttyPSC0
+ttyPSC1
+ttyPSC2
+ttyPSC3
+ttyPSC4
+ttyPSC5
+
+# PA-RISC mux ports
+ttyB0
+ttyB1
+
+# Standard hypervisor virtual console
+hvc0
+
+# Oldstyle Xen console
+xvc0
+
+# Standard consoles
+tty1
+tty2
+tty3
+tty4
+tty5
+tty6
+tty7
+tty8
+tty9
+tty10
+tty11
+tty12
+tty13
+tty14
+tty15
+tty16
+tty17
+tty18
+tty19
+tty20
+tty21
+tty22
+tty23
+tty24
+tty25
+tty26
+tty27
+tty28
+tty29
+tty30
+tty31
+tty32
+tty33
+tty34
+tty35
+tty36
+tty37
+tty38
+tty39
+tty40
+tty41
+tty42
+tty43
+tty44
+tty45
+tty46
+tty47
+tty48
+tty49
+tty50
+tty51
+tty52
+tty53
+tty54
+tty55
+tty56
+tty57
+tty58
+tty59
+tty60
+tty61
+tty62
+tty63
+
+# Local X displays (allows empty passwords with pam_unix's nullok_secure)
+:0
+:0.0
+:0.1
+:1
+:1.0
+:1.1
+:2
+:2.0
+:2.1
+:3
+:3.0
+:3.1
+
+# Embedded Freescale i.MX ports
+ttymxc0
+ttymxc1
+ttymxc2
+ttymxc3
+ttymxc4
+ttymxc5
+
+# Standard serial ports, with devfs
+tts/0
+tts/1
+
+# Standard consoles, with devfs
+vc/1
+vc/2
+vc/3
+vc/4
+vc/5
+vc/6
+vc/7
+vc/8
+vc/9
+vc/10
+vc/11
+vc/12
+vc/13
+vc/14
+vc/15
+vc/16
+vc/17
+vc/18
+vc/19
+vc/20
+vc/21
+vc/22
+vc/23
+vc/24
+vc/25
+vc/26
+vc/27
+vc/28
+vc/29
+vc/30
+vc/31
+vc/32
+vc/33
+vc/34
+vc/35
+vc/36
+vc/37
+vc/38
+vc/39
+vc/40
+vc/41
+vc/42
+vc/43
+vc/44
+vc/45
+vc/46
+vc/47
+vc/48
+vc/49
+vc/50
+vc/51
+vc/52
+vc/53
+vc/54
+vc/55
+vc/56
+vc/57
+vc/58
+vc/59
+vc/60
+vc/61
+vc/62
+vc/63
+
+# Pseudo terminals
+pts/0
+pts/1
+pts/2
+pts/3
+pts/4
+pts/5
+pts/6
+pts/7
+pts/8
+pts/9
+pts/10
+pts/11
+pts/12
+pts/13
+pts/14
+pts/15
+pts/16
+pts/17
+pts/18
+pts/19
+pts/20
+pts/21
+pts/22
+pts/23
+pts/24
+pts/25
+pts/26
+pts/27
+pts/28
+pts/29
+pts/30
+pts/31
+pts/32
+pts/33
+pts/34
+pts/35
+pts/36
+pts/37
+pts/38
+pts/39
+pts/40
+pts/41
+pts/42
+pts/43
+pts/44
+pts/45
+pts/46
+pts/47
+pts/48
+pts/49
+pts/50
+pts/51
+pts/52
+pts/53
+pts/54
+pts/55
+pts/56
+pts/57
+pts/58
+pts/59
+pts/60
+pts/61
+pts/62
+pts/63
diff --git a/meta-openvuplus/recipes-extended/shadow/shadow-securetty_4.1.4.3.bbappend b/meta-openvuplus/recipes-extended/shadow/shadow-securetty_4.1.4.3.bbappend
new file mode 100644
index 0000000..f6a5fef
--- /dev/null
+++ b/meta-openvuplus/recipes-extended/shadow/shadow-securetty_4.1.4.3.bbappend
@@ -0,0 +1,3 @@
+PR .= "-vuplus0"
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
diff --git a/meta-openvuplus/recipes-extended/smartmontools/smartmontools.inc b/meta-openvuplus/recipes-extended/smartmontools/smartmontools.inc
new file mode 100644
index 0000000..c1ded3a
--- /dev/null
+++ b/meta-openvuplus/recipes-extended/smartmontools/smartmontools.inc
@@ -0,0 +1,10 @@
+SECTION = "console/utils"
+SUMMARY = "Control and monitor storage systems using S.M.A.R.T."
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
+INC_PR = "r1"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/smartmontools/smartmontools-${PV}.tar.gz"
+S = "${WORKDIR}/smartmontools-${PV}"
+
+inherit autotools
diff --git a/meta-openvuplus/recipes-extended/smartmontools/smartmontools_5.42.bb b/meta-openvuplus/recipes-extended/smartmontools/smartmontools_5.42.bb
new file mode 100644
index 0000000..98ebb37
--- /dev/null
+++ b/meta-openvuplus/recipes-extended/smartmontools/smartmontools_5.42.bb
@@ -0,0 +1,6 @@
+PR = "${INC_PR}.0"
+
+SRC_URI[md5sum] = "4460bf9a79a1252ff5c00ba52cf76b2a"
+SRC_URI[sha256sum] = "b664d11e814e114ce3a32a4fa918c9e649c684e2897c007b2a8b92574decc374"
+
+require smartmontools.inc