summaryrefslogtreecommitdiff
path: root/meta-bsp
diff options
context:
space:
mode:
authorhschang <chang@dev3>2018-03-02 07:12:31 (GMT)
committerhschang <chang@dev3>2018-03-02 07:12:31 (GMT)
commit2c2a0a3ac6bb9146f3306bbd7164d9b82b3b0bfd (patch)
tree6ae5f5dbb82b6fdd3fccd262287a812ee0a3418f /meta-bsp
parent10abb3c99037d31b7d121a4eeb8bafb035d7732a (diff)
[dvbapp] apply pvr patch to E2
Diffstat (limited to 'meta-bsp')
-rw-r--r--meta-bsp/recipes-vuplus/enigma2/enigma2.bbappend5
-rw-r--r--meta-bsp/recipes-vuplus/enigma2/enigma2/enigma2_vuplus_remove_pvr_action.patch157
2 files changed, 1 insertions, 161 deletions
diff --git a/meta-bsp/recipes-vuplus/enigma2/enigma2.bbappend b/meta-bsp/recipes-vuplus/enigma2/enigma2.bbappend
index a77f3d7..4028df1 100644
--- a/meta-bsp/recipes-vuplus/enigma2/enigma2.bbappend
+++ b/meta-bsp/recipes-vuplus/enigma2/enigma2.bbappend
@@ -1,6 +1,6 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
-PR .= "-bsp26"
+PR .= "-bsp27"
SRC_URI_append_vusolo = " \
file://enigma2_vuplus_misc.patch \
@@ -18,11 +18,9 @@ SRC_URI_append_vuduo2 = " \
"
SRC_URI_append_vusolose = " \
- file://enigma2_vuplus_remove_pvr_action.patch \
"
SRC_URI_append_vuzero = " \
- file://enigma2_vuplus_remove_pvr_action.patch \
"
SRC_URI_append_vusolo4k = " \
@@ -37,7 +35,6 @@ SRC_URI_append_vuultimo4k = " \
"
SRC_URI_append_vuuno4k = " \
- file://enigma2_vuplus_remove_pvr_action.patch \
"
SRC_URI_append_vuuno4kse = " \
diff --git a/meta-bsp/recipes-vuplus/enigma2/enigma2/enigma2_vuplus_remove_pvr_action.patch b/meta-bsp/recipes-vuplus/enigma2/enigma2/enigma2_vuplus_remove_pvr_action.patch
deleted file mode 100644
index d8cecc7..0000000
--- a/meta-bsp/recipes-vuplus/enigma2/enigma2/enigma2_vuplus_remove_pvr_action.patch
+++ /dev/null
@@ -1,157 +0,0 @@
-diff --git a/RecordTimer.py b/RecordTimer.py
-index 763ee8ca3..6f7acfa18 100755
---- a/RecordTimer.py
-+++ b/RecordTimer.py
-@@ -4,6 +4,7 @@ from enigma import eEPGCache, getBestPlayableServiceReference, \
- from Components.config import config
- from Components.UsageConfig import defaultMoviePath
- from Components.TimerSanityCheck import TimerSanityCheck
-+from Components.SystemInfo import SystemInfo
-
- from Screens.MessageBox import MessageBox
- import Screens.Standby
-@@ -135,7 +136,10 @@ class RecordTimerEntry(timer.TimerEntry, object):
- self.timer = None
- self.__record_service = None
- self.start_prepare = 0
-- self.justplay = justplay
-+ if SystemInfo["PVRSupport"]:
-+ self.justplay = justplay
-+ else:
-+ self.justplay = True
- self.afterEvent = afterEvent
- self.dirname = dirname
- self.dirnameHadToFallback = False
-@@ -460,7 +464,10 @@ def createTimer(xml):
- description = xml.get("description").encode("utf-8")
- repeated = xml.get("repeated").encode("utf-8")
- disabled = long(xml.get("disabled") or "0")
-- justplay = long(xml.get("justplay") or "0")
-+ if SystemInfo["PVRSupport"]:
-+ justplay = long(xml.get("justplay") or "0")
-+ else:
-+ justplay = long("1")
- afterevent = str(xml.get("afterevent") or "nothing")
- afterevent = {
- "nothing": AFTEREVENT.NONE,
-@@ -658,7 +665,10 @@ class RecordTimer(timer.Timer):
- if timer.tags is not None:
- list.append(' tags="' + str(stringToXML(' '.join(timer.tags))) + '"')
- list.append(' disabled="' + str(int(timer.disabled)) + '"')
-- list.append(' justplay="' + str(int(timer.justplay)) + '"')
-+ if SystemInfo["PVRSupport"]:
-+ list.append(' justplay="' + str(int(timer.justplay)) + '"')
-+ else:
-+ list.append(' justplay="1"')
- list.append('>\n')
-
- if config.recording.debug.value:
-diff --git a/data/menu.xml b/data/menu.xml
-index a71c0367c..0340a8ce9 100755
---- a/data/menu.xml
-+++ b/data/menu.xml
-@@ -71,7 +71,7 @@
- <item level="1" text="Device Setup..." entryID="device_setup"><screen module="NetworkSetup" screen="NetworkAdapterSelection"/></item>
- <item level="1" text="Nameserver Setup..." entryID="dns_setup"><screen module="NetworkSetup" screen="NameserverSetup"/></item>
- </menu>-->
-- <item level="2" text="Recording paths" entryId="RecordPaths"><screen module="RecordPaths" screen="RecordPathsSettings" /></item>
-+ <item level="2" text="Recording paths" entryId="RecordPaths" requires="PVRSupport"><screen module="RecordPaths" screen="RecordPathsSettings" /></item>
- </menu>
- <item weight="10" level="1" text="Common Interface" entryID="ci_setup" requires="CommonInterface"><screen module="Ci" screen="CiSelection" /></item>
- <item weight="15" level="0" text="Parental control" entryID="parental_setup"><screen module="ParentalControlSetup" screen="ParentalControlSetup" /></item>
-diff --git a/data/setup.xml b/data/setup.xml
-index 8e42c578c..99b0a92d6 100755
---- a/data/setup.xml
-+++ b/data/setup.xml
-@@ -22,11 +22,11 @@
- </setup>
- <setup key="usage" title="Customize">
- <item level="0" text="Setup Mode">config.usage.setup_level</item>
-- <item level="1" text="Recordings always have priority">config.recording.asktozap</item>
-- <item level="0" text="Margin before record (minutes)">config.recording.margin_before</item>
-- <item level="0" text="Margin after record">config.recording.margin_after</item>
-- <item level="0" text="Show blinking clock in display during recording">config.usage.blinking_display_clock_during_recording</item>
-- <item level="2" text="Show Message when Recording starts">config.usage.show_message_when_recording_starts</item>
-+ <item level="1" text="Recordings always have priority" requires="PVRSupport">config.recording.asktozap</item>
-+ <item level="0" text="Margin before record (minutes)" requires="PVRSupport">config.recording.margin_before</item>
-+ <item level="0" text="Margin after record" requires="PVRSupport">config.recording.margin_after</item>
-+ <item level="0" text="Show blinking clock in display during recording" requires="PVRSupport">config.usage.blinking_display_clock_during_recording</item>
-+ <item level="2" text="Show Message when Recording starts" requires="PVRSupport">config.usage.show_message_when_recording_starts</item>
- <item level="2" text="Load Length of Movies in Movielist">config.usage.load_length_of_movies_in_moviellist</item>
- <item level="1" text="Show positioner movement">config.usage.showdish</item>
- <item level="1" text="Enable multiple bouquets">config.usage.multibouquet</item>
-diff --git a/lib/python/Components/SystemInfo.py b/lib/python/Components/SystemInfo.py
-index 5b01c4cbe..205a68e38 100644
---- a/lib/python/Components/SystemInfo.py
-+++ b/lib/python/Components/SystemInfo.py
-@@ -35,4 +35,4 @@ SystemInfo["ScrambledPlayback"] = HardwareInfo().get_vu_device_name() in ("solo4
- SystemInfo["FastChannelChange"] = fileExists("/proc/stb/frontend/fbc/fcc")
- SystemInfo["MiniTV"] = fileExists("/proc/stb/lcd/live_enable")
- SystemInfo["DisableUsbRecord"] = HardwareInfo().get_vu_device_name() in ("solo4k", "uno4kse", "zero4k")
--
-+SystemInfo["PVRSupport"] = HardwareInfo().get_vu_device_name() not in ["solose", "zero", "uno4k"]
-diff --git a/lib/python/Screens/InfoBarGenerics.py b/lib/python/Screens/InfoBarGenerics.py
-index 7e30af7b8..c91927265 100755
---- a/lib/python/Screens/InfoBarGenerics.py
-+++ b/lib/python/Screens/InfoBarGenerics.py
-@@ -235,7 +235,7 @@ class InfoBarNumberZap:
- else:
- self.servicelist.recallPrevService()
- else:
-- if self.has_key("TimeshiftActions") and not self.timeshift_enabled:
-+ if not (self.has_key("TimeshiftActions") and self.timeshift_enabled):
- self.session.openWithCallback(self.numberEntered, NumberZap, number)
-
- def numberEntered(self, retval):
-@@ -1201,11 +1201,12 @@ class InfoBarShowMovies:
-
- class InfoBarTimeshift:
- def __init__(self):
-- self["TimeshiftActions"] = HelpableActionMap(self, "InfobarTimeshiftActions",
-- {
-- "timeshiftStart": (self.startTimeshift, _("start timeshift")), # the "yellow key"
-- "timeshiftStop": (self.stopTimeshift, _("stop timeshift")) # currently undefined :), probably 'TV'
-- }, prio=1)
-+ if SystemInfo["PVRSupport"]:
-+ self["TimeshiftActions"] = HelpableActionMap(self, "InfobarTimeshiftActions",
-+ {
-+ "timeshiftStart": (self.startTimeshift, _("start timeshift")), # the "yellow key"
-+ "timeshiftStop": (self.stopTimeshift, _("stop timeshift")) # currently undefined :), probably 'TV'
-+ }, prio=1)
- self["TimeshiftActivateActions"] = ActionMap(["InfobarTimeshiftActivateActions"],
- {
- "timeshiftActivateEnd": self.activateTimeshiftEnd, # something like "rewind key"
-@@ -1534,10 +1535,11 @@ class InfoBarInstantRecord:
- """Instant Record - handles the instantRecord action in order to
- start/stop instant records"""
- def __init__(self):
-- self["InstantRecordActions"] = HelpableActionMap(self, "InfobarInstantRecord",
-- {
-- "instantRecord": (self.instantRecord, _("Instant Record...")),
-- })
-+ if SystemInfo["PVRSupport"]:
-+ self["InstantRecordActions"] = HelpableActionMap(self, "InfobarInstantRecord",
-+ {
-+ "instantRecord": (self.instantRecord, _("Instant Record...")),
-+ })
- self.recording = []
-
- def stopCurrentRecording(self, entry = -1):
-diff --git a/lib/python/Screens/TimerEntry.py b/lib/python/Screens/TimerEntry.py
-index c3e71c775..5ee9e414b 100644
---- a/lib/python/Screens/TimerEntry.py
-+++ b/lib/python/Screens/TimerEntry.py
-@@ -94,7 +94,12 @@ class TimerEntry(Screen, ConfigListScreen):
- weekday = (int(strftime("%w", localtime(self.timer.begin))) - 1) % 7
- day[weekday] = 1
-
-- self.timerentry_justplay = ConfigSelection(choices = [("zap", _("zap")), ("record", _("record"))], default = {0: "record", 1: "zap"}[justplay])
-+ timer_choices = [("zap", _("zap"))]
-+ default = "zap"
-+ if SystemInfo["PVRSupport"]:
-+ timer_choices.append(("record", _("record")))
-+ default = {0: "record", 1: "zap"}[justplay]
-+ self.timerentry_justplay = ConfigSelection(choices = timer_choices, default = default)
- if SystemInfo["DeepstandbySupport"]:
- shutdownString = _("go to standby")
- else: