Wireless Access Point : add new plugin.
authorChang.H.S <jhs@dev3>
Wed, 18 Apr 2012 07:29:47 +0000 (16:29 +0900)
committerChang.H.S <jhs@dev3>
Wed, 18 Apr 2012 10:52:11 +0000 (19:52 +0900)
17 files changed:
conf/distro/vuplus.conf
conf/machine/include/vuplus-modules.inc
recipes/enigma2/enigma2.bb
recipes/enigma2/enigma2/vuplus/enigma2_vuplus_skin.patch
recipes/hostap/hostap-daemon-0.7.3/defconfig [new file with mode: 0644]
recipes/hostap/hostap-daemon-0.7.inc [new file with mode: 0644]
recipes/hostap/hostap-daemon_0.7.3.bb [new file with mode: 0644]
recipes/linux/linux-bm750-3.1.1/bm750_defconfig
recipes/linux/linux-bm750_3.1.1.bb
recipes/linux/linux-vusolo-3.1.1/vusolo_defconfig
recipes/linux/linux-vusolo_3.1.1.bb
recipes/linux/linux-vuultimo-3.1.1/vuultimo_defconfig
recipes/linux/linux-vuultimo_3.1.1.bb
recipes/linux/linux-vuuno-3.1.1/vuuno_defconfig
recipes/linux/linux-vuuno_3.1.1.bb
recipes/tasks/task-boot.bb
recipes/tasks/task-vuplus-enigma2.bb

index b97034e..1bda803 100644 (file)
@@ -78,6 +78,7 @@ PREFERRED_VERSION_samba = "3.0.37"
 PREFERRED_VERSION_ushare = "1.1a"
 #PREFERRED_VERSION_liboil = "0.3.14"
 PREFERRED_VERSION_hdparm = "6.6"
+PREFERRED_VERSION_hostap-daemon = "0.7.3"
 
 PREFERRED_PROVIDER_avahi = "avahi"
 PREFERRED_PROVIDER_opkg = "opkg-nogpg"
index f6d0008..ef4783a 100644 (file)
@@ -24,9 +24,12 @@ KERNEL_WIFI_MODULES = " \
        kernel-module-w35und \
        kernel-module-zd1211rw \
        ${@base_contains("MACHINE_FEATURES", "rt3070-legacy", "", "kernel-module-rt2800usb", d)} \
+       kernel-module-llc \
+        kernel-module-stp \
+        kernel-module-bridge \
+        kernel-module-hostap \
        "
 
-
 KERNEL_DVB_MODULES = " \
        kernel-module-em28xx-dvb \
        kernel-module-dvb-usb-a800 \
@@ -61,6 +64,3 @@ KERNEL_DVB_MODULES = " \
        kernel-module-dvb-usb-vp7045 \
        kernel-module-smsdvb kernel-module-smsusb \
        "
-
-
-
index b6f5ac3..b06bf46 100644 (file)
@@ -3,7 +3,8 @@ MAINTAINER = "Felix Domke <tmbinc@elitedvb.net>"
 DEPENDS = "jpeg libungif libmad libpng libsigc++-1.2 gettext-native \
        dreambox-dvbincludes freetype libdvbsi++ python swig-native \
        libfribidi libxmlccwrap libdreamdvd gstreamer gst-plugin-dvbmediasink \
-       gst-plugins-bad gst-plugins-good gst-plugins-ugly python-wifi wvdial wvstreams ppp usbmodeswitch usbmodeswitch-data "
+       gst-plugins-bad gst-plugins-good gst-plugins-ugly python-wifi wvdial wvstreams ppp usbmodeswitch usbmodeswitch-data \
+       hostap-daemon bridge-utils"
 RDEPENDS = "python-codecs python-core python-lang python-re python-threading \
        python-xml python-fcntl gst-plugin-decodebin gst-plugin-decodebin2 python-stringold \
        python-pickle gst-plugin-app gst-plugin-fragmented \
@@ -66,9 +67,10 @@ RDEPENDS_enigma2-plugin-extensions-webbrowser = "python-gdata libqtwebkite4 vupl
 DESCRIPTION_append_enigma2-plugin-systemplugins-crashreport = "automatically send crashlogs to Vu+"
 RDEPENDS_enigma2-plugin-systemplugins-crashreport = "twisted-mail twisted-names python-compression python-mime python-email"
 RDEPENDS_enigma2-plugin-systemplugins-3gmodemmanager = "ppp usbmodeswitch usbmodeswitch-data wvdial wvstreams libwvutils4.6 libwvstreams-extras libuniconf4.6"
+RDEPENDS_enigma2-plugin-systemplugins-wirelessaccesspoint = "hostap-daemon bridge-utils"
 
 PN = "enigma2"
-PR = "r27"
+PR = "r28"
 
 SRCDATE = "20110922"
 SRCREV = "5e19a3f8a5e8ce8a4e2cb2b601a1b8ef3554e4be"
index ed1bffe..78c5f8e 100644 (file)
@@ -1,5 +1,5 @@
 diff --git a/configure.ac b/configure.ac
-index 28fd415..97ff37f 100644
+index f11245a..87be088 100644
 --- a/configure.ac
 +++ b/configure.ac
 @@ -134,6 +134,16 @@ data/skin_default/menu/Makefile
@@ -81,10 +81,10 @@ index 0000000..20f24d9
 +      *.png
 diff --git a/data/750S/skin.xml b/data/750S/skin.xml
 new file mode 100644
-index 0000000..f6cb31e
+index 0000000..356191e
 --- /dev/null
 +++ b/data/750S/skin.xml
-@@ -0,0 +1,2825 @@
+@@ -0,0 +1,2841 @@
 +<skin>
 +      <!-- VU+ skin (skin.xml)  -->
 +      <output id="0">
@@ -2909,6 +2909,22 @@ index 0000000..f6cb31e
 +              <ePixmap pixmap="750S/buttons/red.png" position="190,360" size="135,40" alphatest="on" />
 +              <widget source="key_red" render="Label" position="185,360" zPosition="1" size="140,40" font="Regular;20" halign="center" valign="center" transparent="1" />
 +      </screen>
++
++      <!-- Wireless Access Point plugin-->
++      <screen name="WirelessAccessPoint" position="center,center" size="560,450" title="Wireless Access Point Setup" >
++              <ePixmap pixmap="750S/buttons/red.png" position="110,10" size="140,40" alphatest="on" />
++              <ePixmap pixmap="750S/buttons/green.png" position="310,10" size="140,40" alphatest="on" />
++              <widget source="key_red" render="Label" position="115,10" zPosition="1" size="135,40" font="Regular;20" halign="center" valign="center" transparent="1" />
++              <widget source="key_green" render="Label" position="315,10" zPosition="1" size="135,40" font="Regular;20" halign="center" valign="center" transparent="1" />
++              <widget name="config" zPosition="2" position="5,70" size="550,270" scrollbarMode="showOnDemand" transparent="1" />
++              <widget source="current_settings" render="Label" position="10,340" size="570,20" font="Regular;19" halign="center" valign="center" transparent="1" />
++              <widget source="IPAddress_text" render="Label" position="130,370" size="190,21" font="Regular;19" transparent="1" />
++              <widget source="Netmask_text" render="Label" position="130,395" size="190,21" font="Regular;19" transparent="1" />
++              <widget source="Gateway_text" render="Label" position="130,420" size="190,21" font="Regular;19" transparent="1" />
++              <widget source="IPAddress" render="Label" position="340,370" size="240,21" font="Regular;19" transparent="1" />
++              <widget source="Netmask" render="Label" position="340,395" size="240,21" font="Regular;19" transparent="1" />
++              <widget source="Gateway" render="Label" position="340,420" size="240,21" font="Regular;19" transparent="1" />
++      </screen>"""
 +</skin>
 diff --git a/data/Makefile.am b/data/Makefile.am
 index 0eaa082..869a16e 100644
@@ -2982,10 +2998,10 @@ index 0000000..9d4f458
 +      *.png
 diff --git a/data/Vu_HD/skin.xml b/data/Vu_HD/skin.xml
 new file mode 100644
-index 0000000..daa1abf
+index 0000000..ccf3ae3
 --- /dev/null
 +++ b/data/Vu_HD/skin.xml
-@@ -0,0 +1,3355 @@
+@@ -0,0 +1,3377 @@
 +<skin>
 +      <!-- VU+ skin (skin.xml)  -->
 +      <output id="0">
@@ -6340,7 +6356,29 @@ index 0000000..daa1abf
 +              <widget source="key_red" render="Label" position="66,97" zPosition="1" size="150,25" font="Regular;20" halign="center" valign="center" backgroundColor="darkgrey" foregroundColor="#1c1c1c" transparent="1" />
 +              <widget source="status" render="Label" position="110,200" size="650,400" transparent="1" font="Regular;20" foregroundColor="#1c1c1c" backgroundColor="#27d9dee2" zPosition="1" />
 +      </screen>
++
++      <!-- Wireless Access Point Plugin -->
++      <screen name = "WirelessAccessPoint" position="center,center" size="650,520" title="Wireless Access Point Setup" >
++              <ePixmap pixmap="Vu_HD/buttons/red.png" position="20,10" size="140,40" alphatest="on" />
++              <ePixmap pixmap="Vu_HD/buttons/green.png" position="180,10" size="140,40" alphatest="on" />
++              <ePixmap pixmap="Vu_HD/buttons/yellow.png" position="340,10" size="140,40" alphatest="on" />
++              <ePixmap pixmap="Vu_HD/buttons/blue.png" position="500,10" size="140,40" alphatest="on" />
++              <widget source="key_red" render="Label" position="25,10" zPosition="1" size="140,30" font="Regular;20" halign="center" valign="center" transparent="1" />
++              <widget source="key_green" render="Label" position="185,10" zPosition="1" size="140,30" font="Regular;20" halign="center" valign="center" transparent="1" />
++              <widget source="key_yellow" render="Label" position="345,10" zPosition="1" size="140,30" font="Regular;20" halign="center" valign="center" transparent="1" />
++              <widget source="key_blue" render="Label" position="505,10" zPosition="1" size="140,30" font="Regular;20" halign="center" valign="center" transparent="1" />
++              <widget name="config" zPosition="2" position="10,60" size="630,350" scrollbarMode="showOnDemand" transparent="1" />
++              <widget source="current_settings" render="Label" position="10,410" size="630,20" font="Regular;19" halign="center" valign="center" transparent="1" />
++              <widget source="IPAddress_text" render="Label" position="160,440" size="190,21" font="Regular;19" transparent="1" />
++              <widget source="Netmask_text" render="Label" position="160,465" size="190,21" font="Regular;19" transparent="1" />
++              <widget source="Gateway_text" render="Label" position="160,490" size="190,21" font="Regular;19" transparent="1" />
++              <widget source="IPAddress" render="Label" position="370,440" size="240,21" font="Regular;19" transparent="1" />
++              <widget source="Netmask" render="Label" position="370,465" size="240,21" font="Regular;19" transparent="1" />
++              <widget source="Gateway" render="Label" position="370,490" size="240,21" font="Regular;19" transparent="1" />
++      </screen>
++
 +</skin>
++
 diff --git a/data/fonts/Makefile.am b/data/fonts/Makefile.am
 index 2f7e7c7..f81801a 100644
 --- a/data/fonts/Makefile.am
diff --git a/recipes/hostap/hostap-daemon-0.7.3/defconfig b/recipes/hostap/hostap-daemon-0.7.3/defconfig
new file mode 100644 (file)
index 0000000..1f3c6f4
--- /dev/null
@@ -0,0 +1,145 @@
+# Example hostapd build time configuration
+#
+# This file lists the configuration options that are used when building the
+# hostapd binary. All lines starting with # are ignored. Configuration option
+# lines must be commented out complete, if they are not to be included, i.e.,
+# just setting VARIABLE=n is not disabling that variable.
+#
+# This file is included in Makefile, so variables like CFLAGS and LIBS can also
+# be modified from here. In most cass, these lines should use += in order not
+# to override previous values of the variables.
+
+# Driver interface for Host AP driver
+CONFIG_DRIVER_HOSTAP=y
+
+# Driver interface for wired authenticator
+CONFIG_DRIVER_WIRED=y
+
+# Driver interface for madwifi driver
+#CONFIG_DRIVER_MADWIFI=y
+#CFLAGS += -I../../madwifi # change to the madwifi source directory
+
+# Driver interface for Prism54 driver
+CONFIG_DRIVER_PRISM54=y
+
+# Driver interface for drivers using the nl80211 kernel interface
+CONFIG_DRIVER_NL80211=y
+CONFIG_LIBNL20=y
+# driver_nl80211.c requires a rather new libnl (version 1.1) which may not be
+# shipped with your distribution yet. If that is the case, you need to build
+# newer libnl version and point the hostapd build to use it.
+#LIBNL=/usr/src/libnl
+#CFLAGS += -I$(LIBNL)/include
+#LIBS += -L$(LIBNL)/lib
+
+# Driver interface for FreeBSD net80211 layer (e.g., Atheros driver)
+#CONFIG_DRIVER_BSD=y
+#CFLAGS += -I/usr/local/include
+#LIBS += -L/usr/local/lib
+
+# Driver interface for no driver (e.g., RADIUS server only)
+#CONFIG_DRIVER_NONE=y
+
+# IEEE 802.11F/IAPP
+CONFIG_IAPP=y
+
+# WPA2/IEEE 802.11i RSN pre-authentication
+CONFIG_RSN_PREAUTH=y
+
+# PeerKey handshake for Station to Station Link (IEEE 802.11e DLS)
+CONFIG_PEERKEY=y
+
+# IEEE 802.11w (management frame protection)
+# This version is an experimental implementation based on IEEE 802.11w/D1.0
+# draft and is subject to change since the standard has not yet been finalized.
+# Driver support is also needed for IEEE 802.11w.
+#CONFIG_IEEE80211W=y
+
+# Integrated EAP server
+CONFIG_EAP=y
+
+# EAP-MD5 for the integrated EAP server
+CONFIG_EAP_MD5=y
+
+# EAP-TLS for the integrated EAP server
+CONFIG_EAP_TLS=y
+
+# EAP-MSCHAPv2 for the integrated EAP server
+CONFIG_EAP_MSCHAPV2=y
+
+# EAP-PEAP for the integrated EAP server
+CONFIG_EAP_PEAP=y
+
+# EAP-GTC for the integrated EAP server
+CONFIG_EAP_GTC=y
+
+# EAP-TTLS for the integrated EAP server
+CONFIG_EAP_TTLS=y
+
+# EAP-SIM for the integrated EAP server
+#CONFIG_EAP_SIM=y
+
+# EAP-AKA for the integrated EAP server
+#CONFIG_EAP_AKA=y
+
+# EAP-AKA' for the integrated EAP server
+# This requires CONFIG_EAP_AKA to be enabled, too.
+#CONFIG_EAP_AKA_PRIME=y
+
+# EAP-PAX for the integrated EAP server
+#CONFIG_EAP_PAX=y
+
+# EAP-PSK for the integrated EAP server (this is _not_ needed for WPA-PSK)
+#CONFIG_EAP_PSK=y
+
+# EAP-SAKE for the integrated EAP server
+#CONFIG_EAP_SAKE=y
+
+# EAP-GPSK for the integrated EAP server
+#CONFIG_EAP_GPSK=y
+# Include support for optional SHA256 cipher suite in EAP-GPSK
+#CONFIG_EAP_GPSK_SHA256=y
+
+# EAP-FAST for the integrated EAP server
+# Note: Default OpenSSL package does not include support for all the
+# functionality needed for EAP-FAST. If EAP-FAST is enabled with OpenSSL,
+# the OpenSSL library must be patched (openssl-0.9.9-session-ticket.patch)
+# to add the needed functions.
+#CONFIG_EAP_FAST=y
+
+# Wi-Fi Protected Setup (WPS)
+CONFIG_WPS=y
+# Enable UPnP support for external WPS Registrars
+#CONFIG_WPS_UPNP=y
+
+# EAP-IKEv2
+#CONFIG_EAP_IKEV2=y
+
+# Trusted Network Connect (EAP-TNC)
+#CONFIG_EAP_TNC=y
+
+# PKCS#12 (PFX) support (used to read private key and certificate file from
+# a file that usually has extension .p12 or .pfx)
+CONFIG_PKCS12=y
+
+# RADIUS authentication server. This provides access to the integrated EAP
+# server from external hosts using RADIUS.
+CONFIG_RADIUS_SERVER=y
+
+# Build IPv6 support for RADIUS operations
+CONFIG_IPV6=y
+
+# IEEE Std 802.11r-2008 (Fast BSS Transition)
+#CONFIG_IEEE80211R=y
+
+# Use the hostapd's IEEE 802.11 authentication (ACL), but without
+# the IEEE 802.11 Management capability (e.g., madwifi or FreeBSD/net80211)
+CONFIG_DRIVER_RADIUS_ACL=y
+
+# IEEE 802.11n (High Throughput) support
+CONFIG_IEEE80211N=y
+
+# Remove debugging code that is printing out debug messages to stdout.
+# This can be used to reduce the size of the hostapd considerably if debugging
+# code is not needed.
+#CONFIG_NO_STDOUT_DEBUG=y
diff --git a/recipes/hostap/hostap-daemon-0.7.inc b/recipes/hostap/hostap-daemon-0.7.inc
new file mode 100644 (file)
index 0000000..49f2650
--- /dev/null
@@ -0,0 +1,26 @@
+HOMEPAGE = "http://hostap.epitest.fi"
+SECTION = "kernel/userland"
+PRIORITY = "optional"
+LICENSE = "GPL"
+DEPENDS = "libnl openssl"
+
+inherit update-rc.d
+INITSCRIPT_NAME=hostapd
+
+do_configure() {
+       install -m 0644 ${WORKDIR}/defconfig ${S}/.config
+}
+
+do_compile() {
+       make
+}
+
+do_install() {
+       install -d ${D}${sbindir} ${D}${sysconfdir}/init.d
+       install -m 0644 ${S}/hostapd.conf ${D}${sysconfdir}
+       install -m 0755 ${S}/hostapd ${D}${sbindir}
+       install -m 0755 ${S}/hostapd_cli ${D}${sbindir}
+       install -m 755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/hostapd
+}
+
+CONFFILES_${PN} += "${sysconfdir}/hostapd.conf"
diff --git a/recipes/hostap/hostap-daemon_0.7.3.bb b/recipes/hostap/hostap-daemon_0.7.3.bb
new file mode 100644 (file)
index 0000000..5a8aee7
--- /dev/null
@@ -0,0 +1,17 @@
+DESCRIPTION = "User space daemon for extended IEEE 802.11 management"
+
+require hostap-daemon-0.7.inc
+
+PR = "r3"
+
+DEFAULT_PREFERENCE = "-1"
+
+SRC_URI = "http://hostap.epitest.fi/releases/hostapd-${PV}.tar.gz \
+       file://defconfig \
+       file://init"
+SRC_URI[md5sum] = "91a7c8d0f090b7104152d3455a84c112"
+SRC_URI[sha256sum] = "31eb2781f37e1a4c27969d1594f8019c0ca87779349c099ab812833289961567"
+
+S = "${WORKDIR}/hostapd-${PV}/hostapd"
+
+
index 62e1c58..e391159 100644 (file)
@@ -500,10 +500,13 @@ CONFIG_IPV6_PIMSM_V2=y
 # CONFIG_TIPC is not set
 # CONFIG_ATM is not set
 # CONFIG_L2TP is not set
-# CONFIG_BRIDGE is not set
+CONFIG_STP=m
+CONFIG_BRIDGE=m
+#CONFIG_BRIDGE_IGMP_SNOOPING is not set
 # CONFIG_NET_DSA is not set
 # CONFIG_VLAN_8021Q is not set
 # CONFIG_DECNET is not set
+CONFIG_LLC=m
 # CONFIG_LLC2 is not set
 # CONFIG_IPX is not set
 # CONFIG_ATALK is not set
index 614673b..ca27b9e 100644 (file)
@@ -1,6 +1,6 @@
 require linux-vuplus-3.1.1.inc
 
-PR = "r7"
+PR = "r8"
 
 SRC_URI += "\
         file://linux_3.1.1_bm750.patch;patch=1;pnum=1 \
index c475f1f..791195d 100644 (file)
@@ -489,10 +489,13 @@ CONFIG_IPV6_PIMSM_V2=y
 # CONFIG_TIPC is not set
 # CONFIG_ATM is not set
 # CONFIG_L2TP is not set
-# CONFIG_BRIDGE is not set
+CONFIG_STP=m
+CONFIG_BRIDGE=m
+#CONFIG_BRIDGE_IGMP_SNOOPING is not set
 # CONFIG_NET_DSA is not set
 # CONFIG_VLAN_8021Q is not set
 # CONFIG_DECNET is not set
+CONFIG_LLC=m
 # CONFIG_LLC2 is not set
 # CONFIG_IPX is not set
 # CONFIG_ATALK is not set
index 49918e6..6ac55d7 100644 (file)
@@ -1,6 +1,6 @@
 require linux-vuplus-3.1.1.inc
 
-PR = "r7"
+PR = "r8"
 
 SRC_URI += "\
         file://linux_3.1.1_vusolo.patch;patch=1;pnum=1 \
index 76bc32b..8c95080 100644 (file)
@@ -503,10 +503,13 @@ CONFIG_IPV6_PIMSM_V2=y
 # CONFIG_TIPC is not set
 # CONFIG_ATM is not set
 # CONFIG_L2TP is not set
-# CONFIG_BRIDGE is not set
+CONFIG_STP=m
+CONFIG_BRIDGE=m
+# CONFIG_BRIDGE_IGMP_SNOOPING is not set
 # CONFIG_NET_DSA is not set
 # CONFIG_VLAN_8021Q is not set
 # CONFIG_DECNET is not set
+CONFIG_LLC=m
 # CONFIG_LLC2 is not set
 # CONFIG_IPX is not set
 # CONFIG_ATALK is not set
index 4e5e09d..c85bab2 100644 (file)
@@ -1,6 +1,6 @@
 require linux-vuplus-3.1.1.inc
 
-PR = "r8"
+PR = "r9"
 
 SRC_URI += "\
        file://linux-sata_brcm.patch;patch=1;pnum=1 \
index 1da18e7..2f60a4f 100644 (file)
@@ -503,10 +503,13 @@ CONFIG_IPV6_PIMSM_V2=y
 # CONFIG_TIPC is not set
 # CONFIG_ATM is not set
 # CONFIG_L2TP is not set
-# CONFIG_BRIDGE is not set
+CONFIG_STP=m
+CONFIG_BRIDGE=m
+#CONFIG_BRIDGE_IGMP_SNOOPING is not set
 # CONFIG_NET_DSA is not set
 # CONFIG_VLAN_8021Q is not set
 # CONFIG_DECNET is not set
+CONFIG_LLC=m
 # CONFIG_LLC2 is not set
 # CONFIG_IPX is not set
 # CONFIG_ATALK is not set
index 4db676d..b2392db 100644 (file)
@@ -1,6 +1,6 @@
 require linux-vuplus-3.1.1.inc
 
-PR = "r8"
+PR = "r9"
 
 SRC_URI += "\
         file://linux_3.1.1_vuuno.patch;patch=1;pnum=1 \
index 45871fc..ef5e5c6 100644 (file)
@@ -1,5 +1,5 @@
 DESCRIPTION = "Basic task to get a device booting"
-PR = "r67"
+PR = "r68"
 
 inherit task
 
index ac48fb8..7acc715 100644 (file)
@@ -1,7 +1,7 @@
 DESCRIPTION = "Vuplus: E2 Task for the Vuplus Distribution"
 SECTION = "vuplus/base"
 LICENSE = "MIT"
-PR = "r16"
+PR = "r17"
 
 inherit task
 
@@ -48,6 +48,7 @@ RRECOMMENDS_task-vuplus-enigma2 = "\
   enigma2-plugin-systemplugins-ui3dsetup \
   enigma2-plugin-systemplugins-uipositionsetup \
   enigma2-plugin-systemplugins-hdmicec \
+  enigma2-plugin-systemplugins-wirelessaccesspoint \
   ${@base_contains("MACHINE_FEATURES", "wifi", "task-vuplus-wlan", "", d)} \
 "