add autoshutdown plugin and remove deep-standby manager plugin.
authorkos <kos@dev3>
Fri, 7 Dec 2012 06:06:54 +0000 (15:06 +0900)
committerkos <kos@dev3>
Fri, 7 Dec 2012 06:06:54 +0000 (15:06 +0900)
recipes/e2openplugins/enigma2-plugin-systemplugins-autoshutdown.bb [new file with mode: 0644]
recipes/e2openplugins/files/autoshutdown-default-time_20121207.patch [new file with mode: 0644]
recipes/enigma2/enigma2-plugin-systemplugins-adsm.bb [deleted file]
recipes/enigma2/enigma2-plugins.bb
recipes/tasks/task-vuplus-enigma2.bb

diff --git a/recipes/e2openplugins/enigma2-plugin-systemplugins-autoshutdown.bb b/recipes/e2openplugins/enigma2-plugin-systemplugins-autoshutdown.bb
new file mode 100644 (file)
index 0000000..e6ea4a9
--- /dev/null
@@ -0,0 +1,18 @@
+MODULE = "AutoShutDown"
+DESCRIPTION = "automated power off for STB"
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+inherit gitpkgv
+SRCREV = ""
+PV = "0.3+git${SRCPV}"
+PKGV = "0.3+git${GITPKGV}"
+PR = "r1"
+
+require openplugins.inc
+SRC_URI += "file://autoshutdown-default-time_20121207.patch;patch=1;pnum=1 "
+
+inherit autotools
+
+FILES_${PN} = "/"
+
+require assume-gplv2.inc
diff --git a/recipes/e2openplugins/files/autoshutdown-default-time_20121207.patch b/recipes/e2openplugins/files/autoshutdown-default-time_20121207.patch
new file mode 100644 (file)
index 0000000..4cfaf21
--- /dev/null
@@ -0,0 +1,22 @@
+diff --git a/src/plugin.py b/src/plugin.py
+index 4bb7533..4f90dae 100644
+--- a/src/plugin.py
++++ b/src/plugin.py
+@@ -27,7 +27,7 @@ from __init__ import _
+ config.autoshutdown = ConfigSubsection()
+ config.autoshutdown.time = ConfigInteger(default = 120, limits = (1, 1440))
+-config.autoshutdown.inactivetime = ConfigInteger(default = 60, limits = (1, 1440))
++config.autoshutdown.inactivetime = ConfigInteger(default = 300, limits = (1, 1440))
+ config.autoshutdown.autostart = ConfigEnableDisable(default=True)
+ config.autoshutdown.enableinactivity = ConfigEnableDisable(default=True)
+ config.autoshutdown.inactivityaction = ConfigSelection(default = "standby", choices = [("standby", _("Standby")), ("deepstandby", _("Deepstandby"))])
+@@ -263,7 +263,7 @@ class AutoShutDownConfiguration(Screen, ConfigListScreen):
+                       config.autoshutdown.time.setValue(120)
+                       config.autoshutdown.autostart.setValue(1)
+                       config.autoshutdown.enableinactivity.setValue(1)
+-                      config.autoshutdown.inactivetime.setValue(60)
++                      config.autoshutdown.inactivetime.setValue(300)
+                       config.autoshutdown.inactivityaction.setValue("standby")
+                       config.autoshutdown.epgrefresh.setValue(1)
+                       config.autoshutdown.plugin.setValue(1)
diff --git a/recipes/enigma2/enigma2-plugin-systemplugins-adsm.bb b/recipes/enigma2/enigma2-plugin-systemplugins-adsm.bb
deleted file mode 100644 (file)
index 32035c9..0000000
+++ /dev/null
@@ -1,37 +0,0 @@
-DESCRIPTION = "Automatically Deep Standby Manager Plugins"
-SECTION  = "base"
-PRIORITY = "optional"
-LICENSE  = "proprietary"
-
-DEPENDS  = "enigma2"
-
-PR = "r0"
-PV = "20121113.3"
-
-SRC_URI = "http://code.vuplus.com/download/build.fc3abf29fb03f797e78f907928125638/embedded/adsm/vuplus_enigma2_adsm_${PV}.tar.gz"
-
-PLUGINPATH = "/usr/lib/enigma2/python/Plugins/SystemPlugins/ADSM"
-
-S = "${WORKDIR}/adsm"
-
-do_compile() {
-}
-
-do_install() {
-        install -d  ${D}/${PLUGINPATH}
-        install -m 0644 ${S}/__init__.py ${D}/${PLUGINPATH}
-        install -m 0644 ${S}/plugin.py ${D}/${PLUGINPATH}
-        install -m 0644 ${S}/helper.py ${D}/${PLUGINPATH}
-        install -m 0644 ${S}/singleton.py ${D}/${PLUGINPATH}
-        install -m 0644 ${S}/keymap.xml ${D}/${PLUGINPATH}
-}
-
-PACKAGE_ARCH := "${MACHINE_ARCH}"
-FILES_${PN} = "${PLUGINPATH}"
-PACKAGES = "${PN}"
-
-PROVIDES="${PACKAGES}"
-
-SRC_URI[md5sum] = "cee7c2960b3d652036dd804b99dc2c25"
-SRC_URI[sha256sum] = "d6a997d687126d217a2e64b58d7ebab31ffb3a49910d9295c11801a9fdfd0241"
-
index 33c74eb..0c0fbb7 100755 (executable)
@@ -10,7 +10,7 @@ SRCDATE="20110215"
 BRANCH="master"
 PV = "experimental-git${SRCDATE}"
 
-PR = "r6"
+PR = "r7"
 SRC_URI="git://code.vuplus.com/git/dvbapp-plugin.git;protocol=git;branch=${BRANCH};tag=${SRCREV}"
 
 EXTRA_OECONF = " \
@@ -43,7 +43,8 @@ S = "${WORKDIR}/git"
 DEPENDS = "python-pyopenssl python-gdata streamripper python-mutagen python-daap"
 DEPENDS += "enigma2"
 DEPENDS += "enigma2-plugin-extensions-openwebif"
-DEPENDS += "enigma2-plugin-systemplugins-adsm"
+
+DEPENDS_vusolo2 += "enigma2-plugin-systemplugins-autoshutdown"
 
 def modify_po():
        import os
index e1cd158..e5a70dd 100644 (file)
@@ -1,7 +1,7 @@
 DESCRIPTION = "Vuplus: E2 Task for the Vuplus Distribution"
 SECTION = "vuplus/base"
 LICENSE = "MIT"
-PR = "r22"
+PR = "r23"
 
 inherit task
 
@@ -81,7 +81,7 @@ RDEPENDS_task-vuplus-enigma2_append_vusolo2 = "\
   enigma2-plugin-extensions-hbbtv \
   enigma2-plugin-systemplugins-firmwareupgrade \
   enigma2-plugin-systemplugins-manualfancontrol \
-  enigma2-plugin-systemplugins-adsm \
+  enigma2-plugin-systemplugins-autoshutdown \
 "
 
 RDEPENDS_task-vuplus-enigma2_append_vuuno = "\