update linux kernel recipes of vuplus
authorschon <schon@dev03-server>
Tue, 8 Jun 2010 08:03:14 +0000 (17:03 +0900)
committerschon <schon@dev03-server>
Tue, 8 Jun 2010 08:03:14 +0000 (17:03 +0900)
recipes/linux/linux-bm750.bb
recipes/linux/linux-bm750/bm750_defconfig [changed mode: 0755->0644]
recipes/linux/linux-bm750/linux_bm750_nand.patch [changed mode: 0755->0644]
recipes/linux/linux-bm750/linux_bm750_proc.patch [changed mode: 0755->0644]
recipes/linux/linux-bm750/linux_bm750_resource.patch [changed mode: 0755->0644]
recipes/linux/linux-bm750/linux_bm750_serial.patch [changed mode: 0755->0644]
recipes/linux/linux-bm750/linux_bm750_setup.patch [changed mode: 0755->0644]
recipes/linux/linux-bm750/stblinux-2.6.18.makefile.patch [changed mode: 0755->0644]
recipes/linux/linux-vusolo.bb [changed mode: 0755->0644]
recipes/linux/linux-vusolo/stblinux-2.6.18.makefile.patch [changed mode: 0755->0644]

index 953b642..23aed08 100755 (executable)
@@ -2,7 +2,7 @@ DESCRIPTION = "Linux kernel for vuplus duo"
 LICENSE = "GPL"
 KV = "2.6.18-7.3"
 PV = "2.6.18-7.3"
-PR = "r2"
+PR = "r4"
 
 MODULE = "stblinux-2.6.18"
 
@@ -12,7 +12,8 @@ SRC_URI = "http://archive.vuplus.com/download/stblinux-${KV}.tar.bz2 \
         file://linux_bm750_resource.patch;patch=1;pnum=0 \
         file://linux_bm750_serial.patch;patch=1;pnum=0 \
         file://linux_bm750_setup.patch;patch=1;pnum=0 \
-        file://linux_bm750_arch_makefile.patch;patch=1;pnum=0 \
+        file://linux_bm750_kobject.patch;patch=1;pnum=0 \
+        file://linux_bm750_dvb-core_fe.patch;patch=1;pnum=0 \
        file://bm750_defconfig \
        file://stblinux-2.6.18.makefile.patch;patch=1"
 
old mode 100755 (executable)
new mode 100644 (file)
index 2619a48..f9bf5f9
@@ -428,7 +428,7 @@ CONFIG_LLC=y
 #
 CONFIG_STANDALONE=y
 CONFIG_PREVENT_FIRMWARE_BUILD=y
-# CONFIG_FW_LOADER is not set
+CONFIG_FW_LOADER=m
 # CONFIG_SYS_HYPERVISOR is not set
 
 #
@@ -808,7 +808,38 @@ CONFIG_BCMINTEMAC_7038_STREAMING=y
 #
 # Input device support
 #
-# CONFIG_INPUT is not set
+CONFIG_INPUT=m
+
+#
+## Userland interfaces
+#
+CONFIG_INPUT_MOUSEDEV=m
+CONFIG_INPUT_MOUSEDEV_PSAUX=y
+CONFIG_INPUT_MOUSEDEV_SCREEN_X=1024
+CONFIG_INPUT_MOUSEDEV_SCREEN_Y=768
+# CONFIG_INPUT_JOYDEV is not set
+# CONFIG_INPUT_TSDEV is not set
+CONFIG_INPUT_EVDEV=m
+# CONFIG_INPUT_EVBUG is not set
+
+#
+# Input Device Drivers
+#
+CONFIG_INPUT_KEYBOARD=y
+CONFIG_KEYBOARD_ATKBD=m
+# CONFIG_KEYBOARD_SUNKBD is not set
+# CONFIG_KEYBOARD_LKKBD is not set
+# CONFIG_KEYBOARD_XTKBD is not set
+# CONFIG_KEYBOARD_NEWTON is not set
+CONFIG_INPUT_MOUSE=y
+CONFIG_MOUSE_PS2=m
+# CONFIG_MOUSE_SERIAL is not set
+# CONFIG_MOUSE_VSXXXAA is not set
+# CONFIG_INPUT_JOYSTICK is not set
+# CONFIG_INPUT_TOUCHSCREEN is not set
+# CONFIG_INPUT_MISC is not set
+
+
 
 #
 # Hardware I/O ports
@@ -874,7 +905,56 @@ CONFIG_HW_RANDOM=y
 #
 # I2C support
 #
-# CONFIG_I2C is not set
+CONFIG_I2C=m
+CONFIG_I2C_CHARDEV=m
+
+#
+# I2C Algorithms
+#
+# CONFIG_I2C_ALGOBIT is not set
+# CONFIG_I2C_ALGOPCF is not set
+# CONFIG_I2C_ALGOPCA is not set
+
+#
+# I2C Hardware Bus support
+#
+# CONFIG_I2C_ALI1535 is not set
+# CONFIG_I2C_ALI1563 is not set
+# CONFIG_I2C_ALI15X3 is not set
+# CONFIG_I2C_AMD756 is not set
+# CONFIG_I2C_AMD8111 is not set
+# CONFIG_I2C_I801 is not set
+# CONFIG_I2C_I810 is not set
+# CONFIG_I2C_PIIX4 is not set
+# CONFIG_I2C_NFORCE2 is not set
+# CONFIG_I2C_OCORES is not set
+# CONFIG_I2C_PARPORT_LIGHT is not set
+# CONFIG_I2C_PROSAVAGE is not set
+# CONFIG_I2C_SAVAGE4 is not set
+# CONFIG_I2C_SIS5595 is not set
+# CONFIG_I2C_SIS630 is not set
+# CONFIG_I2C_SIS96X is not set
+# CONFIG_I2C_STUB is not set
+# CONFIG_I2C_VIA is not set
+# CONFIG_I2C_VIAPRO is not set
+# CONFIG_I2C_VOODOO3 is not set
+# CONFIG_I2C_PCA_ISA is not set
+
+#
+# Miscellaneous I2C Chip support
+#
+# CONFIG_SENSORS_DS1337 is not set
+# CONFIG_SENSORS_DS1374 is not set
+# CONFIG_SENSORS_EEPROM is not set
+# CONFIG_SENSORS_PCF8574 is not set
+# CONFIG_SENSORS_PCA9539 is not set
+# CONFIG_SENSORS_PCF8591 is not set
+# CONFIG_SENSORS_MAX6875 is not set
+# CONFIG_I2C_DEBUG_CORE is not set
+# CONFIG_I2C_DEBUG_ALGO is not set
+# CONFIG_I2C_DEBUG_BUS is not set
+# CONFIG_I2C_DEBUG_CHIP is not set
+#
 
 #
 # SPI support
old mode 100755 (executable)
new mode 100644 (file)
index a1f3568..e87e656
@@ -2,19 +2,25 @@ DESCRIPTION = "Linux kernel for vuplus solo"
 LICENSE = "GPL"
 KV = "2.6.18-7.3"
 PV = "2.6.18-7.3"
-PR = "r2"
+PR = "r4"
 
 MODULE = "stblinux-2.6.18"
 
-SRC_URI = "http://archive.vuplus.com/download/stblinux-${KV}.tar.bz2 \
-       file://linux_bm750_nand.patch;patch=1;pnum=0 \
-        file://linux_bm750_proc.patch;patch=1;pnum=0 \
-        file://linux_bm750_resource.patch;patch=1;pnum=0 \
-        file://linux_bm750_serial.patch;patch=1;pnum=0 \
-        file://linux_bm750_setup.patch;patch=1;pnum=0 \
-        file://linux_bm750_arch_makefile.patch;patch=1;pnum=0 \
-       file://bm750_defconfig \
-       file://stblinux-2.6.18.makefile.patch;patch=1"
+SRC_URI = "http://archive.vuplus.com/download/stblinux-${KV}.tar.bz2"
+
+SRC_URI += "file://stblinux-2.6.18.makefile.patch;patch=1 \
+       file://vusolo_defconfig"
+
+#SRC_URI += "file://linux-vusolo_nand.patch;patch=1;pnum=0 \
+
+SRC_URI += "file://linux-vusolo_nand4.patch;patch=1;pnum=0 \
+       file://linux-vusolo_info.patch;patch=1;pnum=0 \
+       file://linux-vusolo_resource.patch;patch=1;pnum=0 \
+       file://linux-vusolo_kojbect.patch;patch=1;pnum=0 \
+       file://linux-vusolo_dvb-core_fe.patch;patch=1;pnum=0 \
+       file://linux-vusolo_romblock.patch;patch=1;pnum=0 \
+       file://linux-vusolo_serial.patch;patch=1;pnum=0"
+
 
 
 S = "${WORKDIR}/stblinux-2.6.18"
@@ -29,8 +35,10 @@ KERNEL_OUTPUT = "vmlinux"
 KERNEL_OBJECT_SUFFIX = "ko"
 
 
+#addtask munge before do_patch after do_unpack
+
 do_configure_prepend() {
-       oe_machinstall -m 0644 ${WORKDIR}/bm750_defconfig ${S}/.config
+       oe_machinstall -m 0644 ${WORKDIR}/vusolo_defconfig ${S}/.config
        if [ -d ${WORKDIR}/cdfs-${PV} ]; then
                mv ${WORKDIR}/cdfs-${PV} ${S}/fs/cdfs
                cd ${S} & patch -p0 < ${S}/fs/cdfs/patch.cdfs
@@ -47,18 +55,17 @@ do_install_append () {
 pkg_preinst_kernel-image () {
        [ -d /proc/stb ] && mount -o rw,remount /boot
        true
-       if [ -f /boot/vmlinux.gz ];
-       then rm -f /boot/vmlinux.gz;
-       fi
+        if [ -f /boot/vmlinux.gz ];
+        then rm -f /boot/vmlinux.gz;
+        fi  
 }
 
 pkg_postinst_kernel-image () {
-       if [ -d /proc/stb ];
-       then flash_eraseall /dev/mtd1; nandwrite /dev/mtd1 /boot/vmlinux.gz -p;
-       fi
+        if [ -d /proc/stb ];
+        then flash_eraseall /dev/mtd1; nandwrite /dev/mtd1 /boot/vmlinux.gz -p; 
+        fi  
        [ -d /proc/stb ] && mount -o ro,remount /boot
        true
-
 }
 
 pkg_prerm_kernel-image () {