merge of '61fbd617cd31be5cf16e7fef30e206cf64890e27'
authorStelios Koroneos <skoroneos@digital-opsis.com>
Wed, 22 Aug 2007 15:41:40 +0000 (15:41 +0000)
committerStelios Koroneos <skoroneos@digital-opsis.com>
Wed, 22 Aug 2007 15:41:40 +0000 (15:41 +0000)
     and '842df413eedc02ad89050dbcaa83f9139bfa98b5'

packages/linux/linux-ml403-slab-2.6.x_git.bb

index bdaeb39..7523349 100644 (file)
@@ -4,8 +4,7 @@
 SECTION = "kernel"
 DESCRIPTION = "Linux kernel for Xilinx ML403 Virtex 4 fpga board"
 LICENSE = "GPL"
-DEPENDS = "git-native"
-PR = "r1"
+PR = "r2"
 PV = "2.6+git${SRCDATE}"
 
 COMPATIBLE_MACHINE = "xilinx-ml403"
@@ -24,6 +23,18 @@ ARCH = "ppc"
 KERNEL_IMAGETYPE = "zImage"
 KERNEL_OUTPUT = "arch/ppc/boot/images/zImage.elf"
 
+#make sure git-native gets build before as
+python __anonymous () {
+
+    import bb
+
+
+    depends = bb.data.getVarFlag('do_fetch', 'depends', d) or ""
+    depends = depends + " git-native:do_populate_staging"
+    bb.data.setVarFlag('do_fetch', 'depends', depends, d)
+
+}
+
 
 do_fetch () {