Merge bk://oe-devel@oe-devel.bkbits.net/openembedded
authorNigel Kostiuck <emte@labotomy.net>
Sat, 11 Dec 2004 22:37:13 +0000 (22:37 +0000)
committerNigel Kostiuck <emte@labotomy.net>
Sat, 11 Dec 2004 22:37:13 +0000 (22:37 +0000)
into t.(none):/home/OE/speedracer/packages

2004/12/11 14:36:36-08:00 (none)!emte
 gtk-industrial-engine_0.2.36.2 License Set

BKrev: 41bb7699g0S4IGrjga8OTRoUQuLAwA

packages/gtk-engines/gtk-industrial-engine_0.2.36.2.bb

index e69de29..78700b9 100644 (file)
@@ -0,0 +1,22 @@
+SECTION = "x11/base"
+DESCRIPTION = "Industrial theme engine for GTK"
+MAINTAINER = "Phil Blundell <pb@handhelds.org>"
+LICENSE = "GPL2"
+DEPENDS = "gtk+"
+
+SRC_URI = "${DEBIAN_MIRROR}/main/g/gtk-industrial-engine/gtk-industrial-engine_${PV}.tar.gz \
+       file://no-gtk1.patch;patch=1"
+
+PACKAGES += "gtk-theme-industrial"
+FILES_${PN} = "${libdir}/gtk-2.0/*/engines/*.so"
+FILES_${PN}-dev = "${libdir}/gtk-2.0/*/engines/*"
+FILES_gtk-theme-industrial = "${datadir}/icons ${datadir}/themes"
+
+inherit autotools
+
+do_configure_prepend() {
+       for i in `ls gtk-common`; do
+               ln -sf ../gtk-common/$i gtk2-engine/$i
+       done
+}
+