wireshare: fix building with current toolchain
authorDmitry Eremin-Solenikov <dbaryshkov@gmail.com>
Tue, 27 Jan 2009 17:03:41 +0000 (20:03 +0300)
committerSergey Lapin <slapin@ossfans.org>
Mon, 16 Feb 2009 07:10:17 +0000 (10:10 +0300)
Signed-off-by: Dmitry Eremin-Solenikov <dbaryshkov@gmail.com>
packages/wireshark/files/acinclude-net-snmp-fix.patch [new file with mode: 0644]
packages/wireshark/files/libtool-fix.patch [new file with mode: 0644]
packages/wireshark/tshark_0.99.4.bb
packages/wireshark/wireshark_0.99.4.bb

diff --git a/packages/wireshark/files/acinclude-net-snmp-fix.patch b/packages/wireshark/files/acinclude-net-snmp-fix.patch
new file mode 100644 (file)
index 0000000..3f6dbf3
--- /dev/null
@@ -0,0 +1,13 @@
+Index: wireshark-0.99.4/acinclude.m4
+===================================================================
+--- wireshark-0.99.4.orig/acinclude.m4 2009-01-03 22:57:54.106829288 +0300
++++ wireshark-0.99.4/acinclude.m4      2009-01-03 22:57:59.806420438 +0300
+@@ -1117,7 +1117,7 @@ AC_DEFUN([AC_WIRESHARK_NETSNMP_CHECK],
+               #
+               AC_PATH_PROG(NETSNMPCONFIG, net-snmp-config)
+       else
+-              NETSNMPCNFIG=$netsnmpconfig
++              NETSNMPCONFIG=$netsnmpconfig
+               if test ! -x $NETSNMPCONFIG -o ! -f $NETSNMPCONFIG ; then
+                       NETSNMPCONFIG=$netsnmpconfig/bin/net-snmp-config
+                       if test ! -x $NETSNMPCONFIG -o ! -f $NETSNMPCONFIG ; then
diff --git a/packages/wireshark/files/libtool-fix.patch b/packages/wireshark/files/libtool-fix.patch
new file mode 100644 (file)
index 0000000..4a978ba
--- /dev/null
@@ -0,0 +1,14 @@
+Index: wireshark-0.99.4/configure.in
+===================================================================
+--- wireshark-0.99.4.orig/configure.in 2009-01-05 01:23:50.887336868 +0300
++++ wireshark-0.99.4/configure.in      2009-01-05 01:24:03.136385630 +0300
+@@ -16,8 +16,7 @@ dnl Checks for programs.
+ AC_PROG_CC
+ AC_PROG_CPP
+ dnl Work around libtool bug (fixed in the version 1.5a?)
+-AC_DEFUN([AC_PROVIDE_AC_LIBTOOL_DLOPEN], )
+-AC_LIBTOOL_DLOPEN
++LT_INIT([dlopen])
+ AC_PROG_LIBTOOL
+ AC_PROG_YACC
+ AM_PROG_LEX
index 7338efd..e63a0c2 100644 (file)
@@ -2,17 +2,19 @@ DESCRIPTION = "tshark is the text based verion of wireshark - a popular network
 HOMEPAGE = "http://www.ethereal.com"
 SECTION = "network"
 LICENSE = "GPL"
-DEPENDS = "perl-native gnutls libpcap pcre expat"
+DEPENDS = "perl-native gnutls libpcap pcre expat glib-2.0 net-snmp"
 
 SRC_URI = "${SOURCEFORGE_MIRROR}/wireshark/wireshark-${PV}.tar.bz2 \
            file://use-our-lemon.patch;patch=1 \
+           file://acinclude-net-snmp-fix.patch;patch=1 \
+           file://libtool-fix.patch;patch=1 \
           file://no-host-includes.patch;patch=1"
 
 S=${WORKDIR}/wireshark-${PV}
 
 inherit autotools
 
-EXTRA_OECONF = "--disable-wireshark"
+EXTRA_OECONF = "--disable-wireshark --with-net-snmp=${STAGING_DIR_HOST}${layout_bindir}/net-snmp-config"
 
 do_compile_prepend() {
        ${BUILD_CC} ${BUILD_CFLAGS} -o rdps rdps.c
index e34ca84..357f264 100644 (file)
@@ -8,6 +8,8 @@ PR = "r1"
 
 SRC_URI = "${SOURCEFORGE_MIRROR}/${PN}/${PN}-${PV}.tar.bz2 \
            file://use-our-lemon.patch;patch=1 \
+           file://acinclude-net-snmp-fix.patch;patch=1 \
+           file://libtool-fix.patch;patch=1 \
           file://no-host-includes.patch;patch=1"
 
 inherit autotools