console-tools_0.3.2.bb : showkey needs to be u-d-a because also supplied by
authorGraeme Gregory <dp@xora.org.uk>
Thu, 5 Feb 2009 17:38:19 +0000 (17:38 +0000)
committerGraeme Gregory <dp@xora.org.uk>
Thu, 5 Feb 2009 17:39:32 +0000 (17:39 +0000)
busybox

packages/console-tools/console-tools_0.3.2.bb

index 1a02827..9e48c2c 100644 (file)
@@ -1,7 +1,7 @@
 SECTION = "base"
 LICENSE = "GPL"
 DESCRIPTION = "Allows you to set-up and manipulate the Linux console."
-PR = "r3"
+PR = "r4"
 
 SRC_URI = "${SOURCEFORGE_MIRROR}/lct/console-tools-${PV}.tar.gz \
            file://codepage.patch;patch=1 \
@@ -32,17 +32,20 @@ do_install () {
        mv ${D}${bindir}/chvt ${D}${bindir}/chvt.${PN}
        mv ${D}${bindir}/deallocvt ${D}${bindir}/deallocvt.${PN}
        mv ${D}${bindir}/openvt ${D}${bindir}/openvt.${PN}
+       mv ${D}${bindir}/showkey ${D}${bindir}/showkey.${PN}
 }
 
 pkg_postinst_${PN} () {
        update-alternatives --install ${bindir}/chvt chvt chvt.${PN} 100
        update-alternatives --install ${bindir}/deallocvt deallocvt deallocvt.${PN} 100
        update-alternatives --install ${bindir}/openvt openvt openvt.${PN} 100
+       update-alternatives --install ${bindir}/showkey showkey showkey.${PN} 100
 }
 
 pkg_prerm_${PN} () {
        update-alternatives --remove chvt chvt.${PN}
        update-alternatives --remove deallocvt deallocvt.${PN}
        update-alternatives --remove openvt openvt.${PN}
+       update-alternatives --remove showkey showkey.${PN}
 }