Merge bk://openembedded@openembedded.bkbits.net/packages
authorBruno Randolf <br1@subnet.at>
Tue, 12 Oct 2004 18:31:32 +0000 (18:31 +0000)
committerBruno Randolf <br1@subnet.at>
Tue, 12 Oct 2004 18:31:32 +0000 (18:31 +0000)
into null.(none):/data/mtx/oe/oe.write/packages

2004/10/12 20:30:55+02:00 (none)!br1
copy some more to KERNEL_STAGING_DIR, use KERNEL_STAGING_DIR in prism54 and madwifi modules

BKrev: 416c2304DJhyYErUXYgQL2Ej6ZOLkQ

classes/kernel.oeclass
hostap/hostap-modules_0.2.5.oe
madwifi/madwifi-modules_cvs.oe
prism54/prism54-module_1.2.oe

index 8fa1db8..b8e199f 100644 (file)
@@ -68,6 +68,13 @@ kernel_do_stage() {
        echo "${KERNEL_LDSUFFIX}" >${STAGING_KERNEL_DIR}/kernel-ldsuffix
        [ -e Rules.make ] && install -m 0644 Rules.make ${STAGING_KERNEL_DIR}/
        [ -e Makefile ] && install -m 0644 Makefile ${STAGING_KERNEL_DIR}/
+       # Makefile includes arch/mips/Makefile on mips
+       if [ ARCH="mips" ]; then
+               install -d ${STAGING_KERNEL_DIR}/arch/mips
+               install -m 0644 arch/mips/Makefile ${STAGING_KERNEL_DIR}/arch/mips
+       fi
+       cp -fR scripts ${STAGING_KERNEL_DIR}/
+       cp -fR include/config* ${STAGING_KERNEL_DIR}/include/   
        install -m 0644 ${KERNEL_OUTPUT} ${STAGING_KERNEL_DIR}/${KERNEL_IMAGETYPE}
 }
 
index e69de29..452e43a 100644 (file)
@@ -0,0 +1,42 @@
+DESCRIPTION = "A driver for wireless LAN cards based on Intersil's Prism2/2.5/3 chipset"
+SECTION = "base"
+PRIORITY = "optional"
+MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
+LICENSE = "GPL"
+PR = "r2"
+
+SRC_URI = "http://hostap.epitest.fi/releases/hostap-driver-${PV}.tar.gz \
+           file://hostap_cs.conf \
+          file://Makefile.patch;patch=1"
+SRC_URI_append_mtx-1 = " file://mtx_compat.diff;patch=1;pnum=0 \
+       file://mtx_hostap_deferred_irq.diff;patch=1;pnum=0"
+
+S = "${WORKDIR}/hostap-driver-${PV}"
+
+inherit module
+
+# Hack Alert :D
+ARCH_mipsel = "mips"
+EXTRA_OEMAKE = "EXTRA_CFLAGS='-DPRISM2_NON_VOLATILE_DOWNLOAD'"
+
+NET_MODULES = "hostap.o hostap_pci.o hostap_crypt_ccmp.o hostap_crypt_tkip.o hostap_crypt_wep.o"
+
+do_install() {
+       install -d ${D}/lib/modules/${KERNEL_VERSION}/net \
+                  ${D}/lib/modules/${KERNEL_VERSION}/pcmcia \
+                  ${D}/${sysconfdir}/pcmcia
+       for i in ${NET_MODULES}
+       do
+               install -m 0644 driver/modules/$i ${D}/lib/modules/${KERNEL_VERSION}/net/
+       done
+       install -m 0644 driver/modules/hostap_cs.o ${D}/lib/modules/${KERNEL_VERSION}/pcmcia/
+       install -m 0644 driver/etc/hostap_cs.conf ${D}/${sysconfdir}/pcmcia/hostap_cs.conf
+       cat ${WORKDIR}/hostap_cs.conf >>${D}/${sysconfdir}/pcmcia/hostap_cs.conf
+}
+
+PACKAGES = "hostap-modules-cs hostap-modules-pci hostap-modules"
+FILES_hostap-modules-cs = "/lib/modules/${KERNEL_VERSION}/pcmcia/ /${sysconfdir}/pcmcia/"
+FILES_hostap-modules-pci = "/lib/modules/${KERNEL_VERSION}/net/hostap_pci.o"
+FILES_hostap-modules = "/lib/modules/"
+RDEPENDS_hostap-modules-cs = "hostap-modules"
+RDEPENDS_hostap-modules-pci = "hostap-modules"
index 088868b..68a8cf0 100644 (file)
@@ -14,7 +14,7 @@ inherit module-base
 
 # Hack Alert :D
 ARCH_mipsel = "mips"
-EXTRA_OEMAKE_mtx-1 = "TARGET=mips-le-elf KERNELPATH=${KERNEL_SOURCE} KERNELRELEASE=${KERNEL_VERSION} TOOLPREFIX=${TARGET_PREFIX} \
+EXTRA_OEMAKE_mtx-1 = "TARGET=mips-le-elf KERNELPATH=${STAGING_KERNEL_DIR} KERNELRELEASE=${KERNEL_VERSION} TOOLPREFIX=${TARGET_PREFIX} \
 COPTS='-G 0 -mno-abicalls -fno-pic -Wa,--trap -fno-strict-aliasing -fno-common -fomit-frame-pointer -mlong-calls -DATH_PCI'"
 
 do_compile() {
index 838fcfa..4b998dd 100644 (file)
@@ -15,7 +15,7 @@ inherit module-base
 # Hack Alert :D
 ARCH_mipsel = "mips"
 
-EXTRA_OEMAKE = "KDIR=${KERNEL_SOURCE} KMISC=${D}/lib/modules/${KERNEL_VERSION}/net KVER=${KERNEL_VERSION}"
+EXTRA_OEMAKE = "KDIR=${STAGING_KERNEL_DIR} KMISC=${D}/lib/modules/${KERNEL_VERSION}/net KVER=${KERNEL_VERSION}"
 
 do_compile() {
        unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS