xserver-xorg-conf_0.1.bb : split the xorg.conf out of xserver-xorg
authorGraeme Gregory <dp@xora.org.uk>
Wed, 12 Nov 2008 11:15:52 +0000 (11:15 +0000)
committerGraeme Gregory <dp@xora.org.uk>
Wed, 12 Nov 2008 15:23:08 +0000 (15:23 +0000)
package to prevent xserver-xorg becoming a machine package.

packages/xorg-xserver/xorg-xserver-common.inc
packages/xorg-xserver/xserver-xorg-conf/omap3evm/xorg.conf [new file with mode: 0644]
packages/xorg-xserver/xserver-xorg-conf/xorg.conf [new file with mode: 0644]
packages/xorg-xserver/xserver-xorg-conf_0.1.bb [new file with mode: 0644]
packages/xorg-xserver/xserver-xorg/omap3evm/xorg.conf [deleted file]
packages/xorg-xserver/xserver-xorg/xorg.conf [deleted file]

index 84e3c30..d391ffe 100644 (file)
@@ -16,8 +16,7 @@ libxkbui libxxf86misc libxi libdmx libxtst libxres mesa libxcalibrate"
 RECOMMENDS_${PN} = "hal"
 
 XORG_PN = "xorg-server"
-SRC_URI = "${XORG_MIRROR}/individual/xserver/${XORG_PN}-${PV}.tar.bz2 \
-       file://xorg.conf"
+SRC_URI = "${XORG_MIRROR}/individual/xserver/${XORG_PN}-${PV}.tar.bz2"
 
 S = "${WORKDIR}/${XORG_PN}-${PV}"
 
@@ -30,7 +29,7 @@ EXTRA_OECONF_append_arm = " ac_cv_header_linux_apm_bios_h=no "
 
 PACKAGES =+ "xserver-security-policy"
 FILES_xserver-security-policy += "${libdir}/xserver/SecurityPolicy"
-RRECOMMENDS_${PN} += "xserver-security-policy xkeyboard-config xorg-minimal-fonts rgb"
+RRECOMMENDS_${PN} += "xserver-security-policy xkeyboard-config xorg-minimal-fonts rgb xserver-xorg-conf"
 
 PACKAGES =+ "${PN}-xprint ${PN}-xvfb ${PN}-utils"
 
@@ -45,14 +44,10 @@ FILES_${PN}-dbg += "${libdir}/xorg/modules/.debug \
                    ${libdir}/xorg/modules/*/*/.debug \
                    "
 
-CONFFILES_${PN} += "${sysconfdir}/X11/xorg.conf"
-
 do_stage() {
        autotools_stage_all
 }
 
 do_install_append () {
-       install -d ${D}/${sysconfdir}/X11
-       install -m 0644 ${WORKDIR}/xorg.conf ${D}/${sysconfdir}/X11/
        ln -sf ${datadir}/fonts/X11 ${D}/${libdir}/X11/fonts
 }
diff --git a/packages/xorg-xserver/xserver-xorg-conf/omap3evm/xorg.conf b/packages/xorg-xserver/xserver-xorg-conf/omap3evm/xorg.conf
new file mode 100644 (file)
index 0000000..983bb08
--- /dev/null
@@ -0,0 +1,29 @@
+Section "Module"                                       
+        Load    "extmod"                                
+        Load    "dbe"                           
+        Load    "glx"                                           
+        Load    "freetype"                             
+        Load    "type1"                        
+        Load    "record"                    
+        Load    "dri"                       
+EndSection                            
+
+Section "Monitor"                                                                    
+        Identifier      "Builtin Default Monitor"
+EndSection                                       
+
+Section "Device"                                  
+        Identifier      "Builtin Default fbdev Device 0"
+        Driver  "omapfb"
+EndSection                                                
+
+Section "Screen"                                        
+        Identifier      "Builtin Default fbdev Screen 0"     
+        Device  "Builtin Default fbdev Device 0"            
+        Monitor "Builtin Default Monitor"               
+EndSection                                              
+
+Section "ServerLayout"                                 
+        Identifier      "Builtin Default Layout"                                     
+        Screen  "Builtin Default fbdev Screen 0"        
+EndSection                                              
diff --git a/packages/xorg-xserver/xserver-xorg-conf/xorg.conf b/packages/xorg-xserver/xserver-xorg-conf/xorg.conf
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/xorg-xserver/xserver-xorg-conf_0.1.bb b/packages/xorg-xserver/xserver-xorg-conf_0.1.bb
new file mode 100644 (file)
index 0000000..1ff83ea
--- /dev/null
@@ -0,0 +1,11 @@
+DESCRIPTION = "Machine specific xorg.conf files"
+
+SRC_URI = "file://xorg.conf"
+
+do_install() {
+       install -d ${D}/${sysconfdir}/X11
+       install -m 0644 ${WORKDIR}/xorg.conf ${D}/${sysconfdir}/X11/
+}
+
+CONFFILES_${PN} += "${sysconfdir}/X11/xorg.conf"
+
diff --git a/packages/xorg-xserver/xserver-xorg/omap3evm/xorg.conf b/packages/xorg-xserver/xserver-xorg/omap3evm/xorg.conf
deleted file mode 100644 (file)
index 983bb08..0000000
+++ /dev/null
@@ -1,29 +0,0 @@
-Section "Module"                                       
-        Load    "extmod"                                
-        Load    "dbe"                           
-        Load    "glx"                                           
-        Load    "freetype"                             
-        Load    "type1"                        
-        Load    "record"                    
-        Load    "dri"                       
-EndSection                            
-
-Section "Monitor"                                                                    
-        Identifier      "Builtin Default Monitor"
-EndSection                                       
-
-Section "Device"                                  
-        Identifier      "Builtin Default fbdev Device 0"
-        Driver  "omapfb"
-EndSection                                                
-
-Section "Screen"                                        
-        Identifier      "Builtin Default fbdev Screen 0"     
-        Device  "Builtin Default fbdev Device 0"            
-        Monitor "Builtin Default Monitor"               
-EndSection                                              
-
-Section "ServerLayout"                                 
-        Identifier      "Builtin Default Layout"                                     
-        Screen  "Builtin Default fbdev Screen 0"        
-EndSection                                              
diff --git a/packages/xorg-xserver/xserver-xorg/xorg.conf b/packages/xorg-xserver/xserver-xorg/xorg.conf
deleted file mode 100644 (file)
index 4b32702..0000000
+++ /dev/null
@@ -1,135 +0,0 @@
-
-# xorg configuration
-
-Section "ServerLayout"
-       Identifier     "Default Layout"
-       Screen      0  "Screen0" 0 0
-       InputDevice    "Mouse0" "CorePointer"
-       InputDevice    "Keyboard0" "CoreKeyboard"
-EndSection
-
-Section "Files"
-
-# RgbPath is the location of the RGB database.  Note, this is the name of the 
-# file minus the extension (like ".txt" or ".db").  There is normally
-# no need to change the default.
-# Multiple FontPath entries are allowed (they are concatenated together)
-# By default, Red Hat 6.0 and later now use a font server independent of
-# the X server to render fonts.
-#       FontPath     "unix/:7100"
-       FontPath     "/usr/lib/X11/fonts/misc"
-EndSection
-
-Section "Module"
-       Load  "dbe"
-       Load  "extmod"
-       Load  "fbdevhw"
-#      Load  "glx"
-       Load  "record"
-       Load  "freetype"
-       Load  "type1"
-# to enable Xv, link /dev/videox to video device, eg. ln -s video0 /dev/videox
-#      Load  "z4l"
-EndSection
-
-Section "InputDevice"
-
-# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
-#      Option  "Xleds"         "1 2 3"
-# To disable the XKEYBOARD extension, uncomment XkbDisable.
-#      Option  "XkbDisable"
-# To customise the XKB settings to suit your keyboard, modify the
-# lines below (which are the defaults).  For example, for a non-U.S.
-# keyboard, you will probably want to use:
-#      Option  "XkbModel"      "pc102"
-# If you have a US Microsoft Natural keyboard, you can use:
-#      Option  "XkbModel"      "microsoft"
-#
-# Then to change the language, change the Layout setting.
-# For example, a german layout can be obtained with:
-#      Option  "XkbLayout"     "de"
-# or:
-#      Option  "XkbLayout"     "de"
-#      Option  "XkbVariant"    "nodeadkeys"
-#
-# If you'd like to switch the positions of your capslock and
-# control keys, use:
-#      Option  "XkbOptions"    "ctrl:swapcaps"
-# Or if you just want both to be control, use:
-#      Option  "XkbOptions"    "ctrl:nocaps"
-#
-       Identifier  "Keyboard0"
-       Driver      "keyboard"
-       Option      "XkbModel" "pc105"
-       Option      "XkbLayout" "us"
-EndSection
-
-Section "InputDevice"
-       Identifier  "Mouse0"
-       Driver      "mouse"
-       Option      "Protocol" "IMPS/2"
-       Option      "Device" "/dev/input/mice"
-       Option      "ZAxisMapping" "4 5"
-       Option      "Emulate3Buttons" "yes"
-EndSection
-
-Section "Monitor"
-       Identifier   "Monitor0"
-       VendorName   "Monitor Vendor"
-       ModelName    "NEC FP2141SB"
-#      DisplaySize  400 300
-# Note: setting HorizSync/VertRefresh will override DDC probe
-#      HorizSync    30.0 - 140.0
-#      VertRefresh  25.0 - 160.0
-       Option       "dpms"
-EndSection
-
-Section "Monitor"
-       Identifier   "Monitor1"
-       VendorName   "Generic Vendor"
-       ModelName    "Generic Monitor"
-       HorizSync    28-50
-       VertRefresh  43-73
-       Modeline     "800x600-60"  40.0000  800  840  976 1056   600  601  605  628
-       Modeline     "800x600-72"  50.0000  800  856  976 1040   600  637  643  666
-       Modeline     "640x480-60"  25.1749  640  656  744  800   480  490  492  525 -HSync -VSync
-       Modeline     "640x480-72"  31.5000  640  664  704  832   480  489  492  520 -HSync -VSync
-       Option       "dpms"
-EndSection
-
-
-Section "Device"
-        Identifier  "FBDev"
-        Driver      "fbdev"
-       #Option     "shadowfb" "off"
-EndSection
-
-Section "Screen"
-    Identifier "Screen0"
-    Device     "FBDev"
-    Monitor    "Monitor0"
-    DefaultDepth 16
-
-    SubSection "Display"
-        Depth          8
-        Modes          "1024x768" "800x600" "640x480"
-    EndSubsection
-
-    SubSection "Display"
-        Depth          16
-        Modes          "1024x768" "800x600" "640x480"
-    EndSubsection
-
-    SubSection "Display"
-        Depth          24
-       FbBpp           32
-        Modes          "1024x768" "800x600" "640x480"
-    EndSubsection
-
-EndSection
-
-Section "DRI"
-       Group        0
-       Mode         0666
-EndSection
-