merge of '7ebcf65940382b7ebea258189704cb0e4a77dc70'
authorMichael Lauer <mickey@vanille-media.de>
Fri, 29 Feb 2008 15:59:47 +0000 (15:59 +0000)
committerMichael Lauer <mickey@vanille-media.de>
Fri, 29 Feb 2008 15:59:47 +0000 (15:59 +0000)
     and 'ae9980c1d055e682beb2fea6cfddb080c495b43b'

packages/glibc/files/glibc-2.5-local-dynamic-resolvconf.patch
packages/glibc/glibc_2.5.bb
packages/glibc/glibc_2.6.1.bb

index bab3747..e137287 100644 (file)
@@ -1,44 +1,41 @@
---- glibc-2.5.orig/debian/patches/any/local-dynamic-resolvconf.diff
-+++ glibc-2.5/debian/patches/any/local-dynamic-resolvconf.diff
-@@ -0,0 +1,41 @@
-+# All lines beginning with `# DP:' are a description of the patch.
-+# DP: Description: allow dynamic long-running processes to
-+# DP: re-read a dynamically updated resolv.conf on the fly
-+# DP: Dpatch author: Adam Conrad <adconrad@ubuntu.com>
-+# DP: Patch author: Thorsten Kukuk <kukuk@suse.de>
-+# DP: Upstream status: Ubuntu-Specific
-+# DP: Date: 2006-01-13 08:14:21 UTC
+# All lines beginning with `# DP:' are a description of the patch.
+# DP: Description: allow dynamic long-running processes to
+# DP: re-read a dynamically updated resolv.conf on the fly
+# DP: Dpatch author: Adam Conrad <adconrad@ubuntu.com>
+# DP: Patch author: Thorsten Kukuk <kukuk@suse.de>
+# DP: Upstream status: Ubuntu-Specific
+# DP: Date: 2006-01-13 08:14:21 UTC
+
+Index: resolv/res_libc.c
+===================================================================
+--- resolv/res_libc.c.orig
++++ resolv/res_libc.c
+@@ -22,7 +22,7 @@
+ #include <arpa/nameser.h>
+ #include <resolv.h>
+ #include <bits/libc-lock.h>
+-
++#include <sys/stat.h>
+ /* The following bit is copied from res_data.c (where it is #ifdef'ed
+    out) since res_init() should go into libc.so but the rest of that
+@@ -94,8 +94,17 @@
+ int
+ __res_maybe_init (res_state resp, int preinit)
+ {
+-      if (resp->options & RES_INIT) {
+-              if (__res_initstamp != resp->_u._ext.initstamp) {
++  static time_t last_mtime;
++  struct stat statbuf;
++  int ret;
 +
-+Index: resolv/res_libc.c
-+===================================================================
-+--- resolv/res_libc.c.orig
-++++ resolv/res_libc.c
-+@@ -22,7 +22,7 @@
-+ #include <arpa/nameser.h>
-+ #include <resolv.h>
-+ #include <bits/libc-lock.h>
-+-
-++#include <sys/stat.h>
-+ 
-+ /* The following bit is copied from res_data.c (where it is #ifdef'ed
-+    out) since res_init() should go into libc.so but the rest of that
-+@@ -94,8 +94,17 @@
-+ int
-+ __res_maybe_init (res_state resp, int preinit)
-+ {
-+-     if (resp->options & RES_INIT) {
-+-             if (__res_initstamp != resp->_u._ext.initstamp) {
-++  static time_t last_mtime;
-++  struct stat statbuf;
-++  int ret;
-++
-++             
-++  if (resp->options & RES_INIT) {
-++     ret = stat (_PATH_RESCONF, &statbuf);
-++             if (__res_initstamp != resp->_u._ext.initstamp
-++               || (ret == 0) && (last_mtime != statbuf.st_mtime))
-++               {
-++                     last_mtime = statbuf.st_mtime;
-+                      if (resp->nscount > 0) {
-+                              __res_iclose (resp, true);
-+                              return __res_vinit (resp, 1);
++              
++  if (resp->options & RES_INIT) {
++      ret = stat (_PATH_RESCONF, &statbuf);
++              if (__res_initstamp != resp->_u._ext.initstamp
++                || (ret == 0) && (last_mtime != statbuf.st_mtime))
++                {
++                      last_mtime = statbuf.st_mtime;
+                       if (resp->nscount > 0) {
+                               __res_iclose (resp, true);
+                               return __res_vinit (resp, 1);
index f50c85b..0dc1c41 100644 (file)
@@ -1,5 +1,5 @@
 require glibc.inc
-PR = "r9"
+PR = "r10"
 
 ARM_INSTRUCTION_SET = "arm"
 
@@ -44,7 +44,7 @@ SRC_URI = "\
   file://dl-cache-libcmp.patch;patch=1 \
   file://ldsocache-varrun.patch;patch=1 \
   file://nptl-crosscompile.patch;patch=1 \
-  file://glibc-2.5-local-dynamic-resolvconf.patch;patch=1 \
+  file://glibc-2.5-local-dynamic-resolvconf.patch;patch=1;pnum=0 \
   file://glibc-check_pf.patch;patch=1;pnum=0 \
   file://zecke-sane-readelf.patch;patch=1 \
   file://ldd-unbash.patch;patch=1 \
index 705fab6..4c59bbd 100644 (file)
@@ -1,5 +1,5 @@
 require glibc.inc
-PR = "r2"
+PR = "r3"
 
 ARM_INSTRUCTION_SET = "arm"
 
@@ -45,7 +45,7 @@ SRC_URI = "\
   file://dl-cache-libcmp.patch;patch=1 \
   file://ldsocache-varrun.patch;patch=1 \
   file://nptl-crosscompile.patch;patch=1 \
-  file://glibc-2.5-local-dynamic-resolvconf.patch;patch=1 \
+  file://glibc-2.5-local-dynamic-resolvconf.patch;patch=1;pnum=0 \
   file://glibc-check_pf.patch;patch=1;pnum=0 \
   file://zecke-sane-readelf.patch;patch=1 \
   file://ldd-unbash.patch;patch=1 \